Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-12-2022, 08:51 AM   #1
Member
 
Join Date: Nov 2020
Posts: 33
Running lights not working on 08' Monaco Dynasty

Anyone have any idea why the daytime running lights would suddenly stop working? They were working just fine, then they all stopped working, front and rear.
Fuse is good. Replaced the pullout headlight switch, still nothing.
__________________
2008 Monaco Dynasty Squire
alaskan.2020 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-12-2022, 02:27 PM   #2
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 11,457
I had a separate relay for my Windsor for the DRL. It was in the front drivers side front electrical bay, they had it tucked up under a bunch of wires and it was hard to see.
In my case the DRL would only work with the high beams on, didn't like that so I jumped the relay so I could operate the all the lights separately.
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is offline   Reply With Quote
Old 01-12-2022, 05:45 PM   #3
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 20,616
Monaco daisy chained a lot of their lighting. I would pull one light and add a temporary ground and see what happens.
__________________
Don & Mary
2019 Newmar Dutch Star 4018 (Freightliner)
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 01-13-2022, 05:56 AM   #4
Senior Member
 
Monaco Owners Club
Join Date: Sep 2013
Posts: 2,299
Have you checked the Hamsar Driving Light Module in the FRB? Board 16 J2. Headlight Schematic #38040216 in your wiring diagram book.
__________________
2014 Newell 2020P ISX 600 HP

was 2007 Monaco Signature Noble III 45' ISX 600HP
hypoxia is offline   Reply With Quote
Old 01-13-2022, 05:59 AM   #5
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 5,584
EDIT Hypoxia commenting same time...
I've read Monaco had special DRL relay up in dash. It's hard to remember what years have what. Looks like similar common relay but if replaced with wrong one does something weird/wrong. Search Monaco DLR / relay.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Old 01-13-2022, 04:05 PM   #6
Member
 
Join Date: Nov 2020
Posts: 33
Still trouble shooting a 12v electrical lighting issue.
2008 monaco dynasty squire iv.

My running/parking lights do not work in the front or rear, my lower side markers also do not work. When connected to my toad, the running/parking lights also do not work on the toad.

What does work: Headlights work on low and high, turn signals work, flashers work, emergency lights work, brakes work, upper front and rear markers work.

I have checked and rechecked every fuse in the front run bay and bedroom using a test light and replaced any that were questionable.
I have replaced the headlight switch, I ordered a 2nd replacment just in case the 1st replacement was a dud.

I have checked all the grounds in the front run bay.

What else am I missing?

Some have suggested the smartwheel, thats a last resort replacement @ $400 for the part.
My running lights and markers are not controlled by the wheel from what I can tell. Rather, they are controlled by the pull our headlight switch.
__________________
2008 Monaco Dynasty Squire
alaskan.2020 is offline   Reply With Quote
Old 05-15-2022, 04:50 PM   #7
Junior Member
 
Join Date: May 2022
Posts: 2
Alaskan.2020, I have a 04 Holiday rambler navigator that is having the same lighting issues that you described, did you come up with a solution to fix yours? Any help would be greatly appreciated. Thanks, Steve
SteveNShae is offline   Reply With Quote
Old 05-16-2022, 01:33 AM   #8
Senior Member
 
153stars's Avatar
 
Join Date: Mar 2019
Location: Braidwood Il.
Posts: 5,584
There's a lot of years between ours but most ,of my lights are on/through relays not direct through HL switch, blinkers, EM flasher and brake. To be honest I haven't checked markers and tails because haven't had trouble with those. OOPS knock on wood.. I know some of my lights are on self resetting thermal fuses as well.
__________________
95 Monaco Crown Royale
M11 400hp, 4060 trans.
Aquahot, Generac Guardian7.5k
153stars is offline   Reply With Quote
Reply

Tags
light, lights, monaco, monaco dynasty, running lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running lights and rear lights not working Wpbyrns MH-General Discussions & Problems 4 06-16-2021 10:30 PM
Monaco Dynasty Barron III :: 1997 Monaco Dynasty Barron III ctmdr iRV2 Owners Registry 0 01-17-2018 09:52 AM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Owner's Forum 3 02-26-2014 07:02 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.