Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-31-2018, 06:21 AM   #1
Senior Member
 
bharrisv65's Avatar
 
Tiffin Owners Club
Appalachian Campers
Join Date: Nov 2017
Location: TN
Posts: 157
RVI Tire Patrol

I've seen and read a few posts about tire pressure monitoring systems but I wanted to SPECIFICALLY ask about any issues anyone has had with the RVI Tire Patrol system. Initially, I didn't have any issues with mine once I paired the RV and toad's sensors (which was about 4 months ago) but recently, it seems I was having an issue with a random sensor not pairing or it would take awhile, now I have 4 on the RV which won't pair at all and seem to be "dead". I went through all the procedures to try and get them to pair but to no avail. I have called the company and they DID RETURN MY CALL but I missed the call so I'm going to try and get back in touch with them. THIS POST IN NO WAY IS REFLECTIVE OF BAD SERVICE ON THEIR PART, I'm just curious to see who all may have had issues with this set up and if it was resolved, fixed, not fixed, etc. I also bought the RVI3 braking system which, so far has been GREAT!

Please, I ask respectfully, only those who have the RVI Tire Patrol reply with your opinions, issues, etc. I've read the other remarks regarding the other brands so I'm not asking which ones are best/better. Thanks!
__________________
Bill, Christine & Rip (Ripley Dash Dutton) (Chihuahua/terrier mix)
2022 Montana Legacy 5th Wheel - 2019 F350 Ford 4X4
bharrisv65 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-31-2018, 06:58 AM   #2
Senior Member
 
Join Date: Apr 2010
Location: Washington Court House, Ohio
Posts: 155
I bought the system right after it came out. It never has worked properly. I have had sensors replaced , the hub replaced and even drove to the factory where they tested the system but I still can’t get all the sensors to pair. I will say the people at RVI have been very responsive and tried to help but as of now two years later the system is still not working properly. I am ready to give up and get a different system.
__________________
CMSGT, USAF Retired
2015 Georgetown XL 377ts
georgew48 is offline   Reply With Quote
Old 08-31-2018, 08:49 AM   #3
Member
 
Glenn2's Avatar
 
Join Date: Mar 2017
Location: College Station, TX
Posts: 65
My Tire Patrol sensors worked great until I took them off to air up my tires. I could never get them to pair again. RVI assisted and even sent me a new set of sensors. To no avail. I think the following conditions caused the problem. The toad was in my garage and was out of signal range to the Command hub when I removed the sensors. When I replaced the sensors in and out of range of the Command hub they would not pair. The new sensors would not pair in range of the Command hub. RVI really tried to correct the problem. I decided to de-pair the Command hub and rebuild the system including a new download of the RVI app. I then paired the Command hub, RVi brake 3 and Tire Patrol. All now work. I guess the moral to my problem is don't remove the tire sensors unless you unpair them first.
__________________
2017 Thor Challenger 37YT
Glenn2 is offline   Reply With Quote
Old 08-31-2018, 07:23 PM   #4
Junior Member
 
fkondor's Avatar
 
Join Date: Nov 2017
Posts: 9
I bought them when they first came out and had initial issues. i was told they had a problem with a weld. they sent a new set did a replace on all of the sensors and now all is good. have to run latest software also look at the version of the sensor need to be version 2. Important to remove the sensor nad add as a replacement otherwise it looks for the old sensor.
fkondor is offline   Reply With Quote
Old 09-01-2018, 09:31 AM   #5
Senior Member
 
bharrisv65's Avatar
 
Tiffin Owners Club
Appalachian Campers
Join Date: Nov 2017
Location: TN
Posts: 157
Quote:
Originally Posted by fkondor View Post
I bought them when they first came out and had initial issues. i was told they had a problem with a weld. they sent a new set did a replace on all of the sensors and now all is good. have to run latest software also look at the version of the sensor need to be version 2. Important to remove the sensor nad add as a replacement otherwise it looks for the old sensor.
I spoke to Matt at RVI and he mentioned they redesigned the sensors due to questionable welds on some of them. He’s sending me a whole new set and hopefully that will fix my issues. Let me say, so far, they have been great to work with and I like their brake system, even the TPMS system, so I’m hoping to get things working properly. The RVI3 brake unit has been fine so far, excellent and very easy to install. I’ll post updates as they happen.
__________________
Bill, Christine & Rip (Ripley Dash Dutton) (Chihuahua/terrier mix)
2022 Montana Legacy 5th Wheel - 2019 F350 Ford 4X4
bharrisv65 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RVibrake Tire Patrol gostberg iRV2.com General Discussion 2 08-14-2018 08:37 PM
RVi Brake's Tire Patrol wnytaxman Class A Motorhome Discussions 5 03-13-2018 07:34 AM
RVI Tire Patrol georgew48 Class A Motorhome Discussions 23 03-05-2018 10:15 PM
RVI Tire Patrol TPMS Ron Everson Gear and Product Discussions 2 02-27-2018 03:40 PM
Rvi TPMS vs Tire Tracker vs EEZ rv? rlott2k Class A Motorhome Discussions 14 04-11-2017 11:54 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.