Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-13-2017, 02:10 PM   #1
Member
 
djenkins452's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 30
Smile Tecma silence plus #28970

Would love some help if there is any to be found. Just got setup a few days ago. Wife used the commode and it will not flush. There is power to the wall push button, but it will not flush. Tried holding it down for 8 sec (recommended by manufacturer), but that didn't help. Hoping to find a one time flush just to get us through the week so I can have it worked on. We are far away from home and have our dogs. Not easy just to drop off and have it worked on. If I could just get it to flush once, or open the valve, I can have it worked on when we get back. Any ideas? Thanks in advance.

Thanks...
__________________
Danny & Heather, Knoxville, TN
2006 Fleetwood Revolution LE 40'
2002 Chevrolet Tahoe Z71
djenkins452 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-13-2017, 02:32 PM   #2
Senior Member
 
Join Date: Jan 2016
Posts: 531
Did you try holding down both buttons at the same rate time? Do you actually have power to the toilet? I believe that the toilet and control panel are fused independently.
Deep Water D is offline   Reply With Quote
Old 06-13-2017, 02:37 PM   #3
Senior Member
 
Join Date: Oct 2014
Posts: 418
Are there any lights on the panel?
msturtz is offline   Reply With Quote
Old 06-13-2017, 02:38 PM   #4
Moderator Emeritus
 
Country Coach Owners Club
Freightliner Owners Club
Join Date: Sep 2004
Location: Glen Allen, VA
Posts: 7,902
Blog Entries: 1
Look for a circuit breaker or fuse associated with the toilet. I have a little circuit breaker in my inverter bay that if tripped, the Tecma toilet will not flush. I can't remember if I still get lights on the panel if that breaker is tripped.
__________________
2007 Country Coach Allure Siskiyou Summit, sold/traded Nov. 2018.
2019 Grand Designs 384GK-R 5th wheel. Glen Allen, VA
smlranger is offline   Reply With Quote
Old 06-13-2017, 02:46 PM   #5
Member
 
djenkins452's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 30
Quote:
Originally Posted by Deep Water D View Post
Did you try holding down both buttons at the same rate time? Do you actually have power to the toilet? I believe that the toilet and control panel are fused independently.


There is only one button on this control. 2006 Revolution. Thanks for the suggestion though!
__________________
Danny & Heather, Knoxville, TN
2006 Fleetwood Revolution LE 40'
2002 Chevrolet Tahoe Z71
djenkins452 is offline   Reply With Quote
Old 06-13-2017, 02:47 PM   #6
Member
 
djenkins452's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 30
Quote:
Originally Posted by msturtz View Post
Are there any lights on the panel?


Yes, the green light is visible.
__________________
Danny & Heather, Knoxville, TN
2006 Fleetwood Revolution LE 40'
2002 Chevrolet Tahoe Z71
djenkins452 is offline   Reply With Quote
Old 06-13-2017, 02:47 PM   #7
Member
 
djenkins452's Avatar
 
Fleetwood Owners Club
Join Date: Jul 2013
Location: Knoxville, TN
Posts: 30
Quote:
Originally Posted by smlranger View Post
Look for a circuit breaker or fuse associated with the toilet. I have a little circuit breaker in my inverter bay that if tripped, the Tecma toilet will not flush. I can't remember if I still get lights on the panel if that breaker is tripped.


Great suggestion. I will look. Thank you for the suggestion.
__________________
Danny & Heather, Knoxville, TN
2006 Fleetwood Revolution LE 40'
2002 Chevrolet Tahoe Z71
djenkins452 is offline   Reply With Quote
Old 06-13-2017, 03:06 PM   #8
Senior Member
 
Join Date: Oct 2014
Posts: 418
My toilet stopped working when a fuse blew.
msturtz is offline   Reply With Quote
Old 06-13-2017, 04:16 PM   #9
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 5,362
Also make sure your black tank is not anywhere close to full. Techma uses a sensor in the black tank system and will not flush if IT thinks the tank is full. It will even do this for about 10 min after flushing the tanks while the Techma sensor is still wet.
Ours has 2 buttons and a there is a light in the lower right corner that will turn from green to yellow and then red as the black tank fills. This can be over ridden by holding a button down, but it really takes an effort.
8 seconds feels like 30 seconds while holding the button down.
Holding both buttons down empties the toilet of all water.
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 06-14-2017, 05:03 AM   #10
Senior Member
 
Monaco Owners Club
Join Date: Sep 2013
Posts: 2,163
I have two of the 2 button model. One was intermittant, I replaced the controller & it has worked ever since.

Make sure you have good voltage at the toilet, low voltage will keep it from flushing. You can take the bolts out and move the toilet enough to check it. Will take some finesse if it's loaded!
__________________
2007 Monaco Signature Noble III 45' ISX 600HP
hypoxia is offline   Reply With Quote
Reply

Tags
ecm



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thetford Tecma Silence Plus - No Power Scottybdivin Newmar Owner's Forum 3 05-31-2017 11:19 AM
My Thetford Tecma silence plus Toilet drains tomd85208 Monaco Owner's Forum 2 07-12-2014 07:57 PM
No Water into Tecma Silence Plus Toilet ChrisKW Class A Motorhome Discussions 3 01-20-2014 10:44 PM
tecma silence plus problem Pattijr New Member Check-In 9 01-15-2013 04:48 PM
Tecma silence plus toilet a johnson Fleetwood Owner's Forum 2 06-17-2012 05:40 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.