Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-12-2019, 02:13 PM   #1
Junior Member
 
Join Date: Sep 2018
Location: Tucson,AZ
Posts: 14
Water pump problem

2009 Monaco Knight. Just installed a new 4008 Shurflo pump, I have no power to the pump or switches, the in house fuse is good. Any ideas
dave_330 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-12-2019, 02:15 PM   #2
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 22,816
Trace the positive wire backwards until you locate the problem.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 09-12-2019, 03:08 PM   #3
Senior Member
 
Join Date: Jul 2015
Location: Watertown NY USA
Posts: 4,079
You installed a new pump. Why? Was the old pump bad or was it working when you pulled it out?
Lynn
__________________
2002 Fleetwood Storm 30H on Workhorse P32 chassis 8.1 gas.
LETMGROW is online now   Reply With Quote
Old 09-13-2019, 06:32 AM   #4
Junior Member
 
Join Date: Sep 2018
Location: Tucson,AZ
Posts: 14
Yes it was working, the red wire broke off un able to fix it
dave_330 is offline   Reply With Quote
Old 09-13-2019, 06:49 AM   #5
Senior Member
 
Join Date: Jul 2015
Location: Watertown NY USA
Posts: 4,079
Quote:
Originally Posted by dave_330 View Post
Yes it was working, the red wire broke off un able to fix it
That being the case I would be suspicious the broken wire end touched the pump body and shorted the power wire blowing a fuse.
I'd take a test light and check every fuse in every fuse box in your MH.
Lynn
__________________
2002 Fleetwood Storm 30H on Workhorse P32 chassis 8.1 gas.
LETMGROW is online now   Reply With Quote
Old 09-13-2019, 01:41 PM   #6
Junior Member
 
Join Date: Sep 2018
Location: Tucson,AZ
Posts: 14
Thanks ill try that
dave_330 is offline   Reply With Quote
Old 09-15-2019, 03:48 PM   #7
Junior Member
 
Join Date: Sep 2018
Location: Tucson,AZ
Posts: 14
I have done that. I now have power to the pump but not to the on off switch, someone talked about a controle switch anyone now were that mite be?
dave_330 is offline   Reply With Quote
Old 09-15-2019, 05:13 PM   #8
Senior Member
 
Reacher's Avatar
 
Tiffin Owners Club
Join Date: Apr 2019
Posts: 688
If you scroll down to the bottom of this guide there are common wiring diagrams with and without a controller. I hope this helps.



Aquajet RV & ES User's Manual and Installation Guide
__________________
2019 Open Road 34PA
2016 Ford C-Max Energi Toad
Reacher is offline   Reply With Quote
Reply

Tags
problem, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Still a problem with onboard water system, pump doesn't pump Tooth Doc iRV2.com General Discussion 12 05-25-2017 09:28 AM
Water Pump On? Water Pump off? SpaceNorman iRV2.com General Discussion 21 04-12-2015 07:04 PM
water pump hums but doesn't pump water msg1951 RV Systems & Appliances 2 04-12-2013 04:36 PM
Water Pump won't pump water zzjea RV Systems & Appliances 4 03-06-2012 04:07 AM


All times are GMT -6. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.