Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class A Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-19-2021, 01:33 PM   #1
Junior Member
 
Join Date: Jan 2021
Posts: 3
Winnebago Via 25P Radio not working

I have a 2016 Winnebago Via 25P. The radio/Nav worked fine last trip but when I picked it up today for another trip, the radio/nav wont come on. I decided to switch from Engine Batter to Coach batter to power the radio as a test (dash switch). When I do that the radio comes on. I therefore concluded it must be the radio fuse (13) that protects the radio on the engine battery supply. However, the fuse is good and I verified power to the fuse. Now I'm confused. I don't wee why it would work from coach power but not engine power if the fuse is good. I also checked the glove box light since it says its the same fuse. It goes out when I pull that fuse which seems to validate it is the correct fuse. Any ideas?
Sfav8r is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-20-2021, 12:02 PM   #2
Senior Member
 
Unplanned Tourist's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Join Date: May 2016
Location: Kamloops, BC, 60 miles from the Center of the Universe
Posts: 5,445
Test the switch. If there's power from both systems (house & chassis) then it's the switch.

If not, it might be a bad relay. Usually you can swap with other relays to confirm a bad one.
__________________
Happy Glamping, Norman & Elna. 2008 Winnebago Adventurer 38J, W24, dozens of small thirsty ponies. Retired after 40 years wrenching on trucks! 2010 Ford Ranger toad with bicycles or KLR 650 in the back. Easy to spot an RVer, they always walk around with a screwdriver or wrench in one hand!
Unplanned Tourist is offline   Reply With Quote
Reply

Tags
radio, winnebago



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2017 Winnebago Via 25P WinterStorm iRV2 Owners Registry 0 11-30-2019 11:49 AM
Via 25p dn5172 Travel Supreme Owner's Forum 0 12-17-2018 07:35 PM
2014 via 25p Sharona1947 Class A Motorhome Discussions 3 05-13-2017 02:00 PM
Winnebago Reyo 25P anyone? jerztime Class A Motorhome Discussions 1 08-04-2014 08:00 AM
2014 Via/Reyo 25P tankless hot water heater iRV-in-a-SunStar Winnebago Industries Owner's Forum 5 07-30-2013 06:04 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.