Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > MOTORHOME FORUMS > Class B Motorhome Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-02-2021, 04:37 PM   #1
Junior Member
 
Join Date: Aug 2020
Posts: 1
ECM/TCM Bad ???

2002 Holiday Rambler Vacationer. Workhorse chassis, 8.1 gas engine.
Engine will not turn over when trying to start. No power to starter. Returned from 1500 mile trip. Next day engine problem started. Fuse to ecm/tcm blows
as soon as new one installed. 20 amp. was advised when that fuse blows the
ecm/tcm is shorted??? Sent to G7 computers, reinstalled, same problem. G7 will recheck unit . I hate to wait another 25-30 days when I have no idea if that is the problem. All advice/help appreciated. I have lots of paperwork on the unit but no schematic for the engine/trans.

Thanks!!!!!
Dale Hurley
Landperson is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-02-2021, 04:44 PM   #2
Senior Member
 
Winterbagoal's Avatar
 
Join Date: Mar 2017
Location: Sarnialabad, Peoples Republik of Canuckistan
Posts: 1,680
You might want to move this into the Workhorse chassis forum.
You've posted it in the Class B Van conversion forum.
__________________
All comments are my opinions, and worth exactly what you paid for them.
2018 (2017 Sprinter Cab Chassis) Navion24V + 2016 Wrangler JKU (sold @ ????) - 2016 Sunstar 26HE (sold @ 4600 miles) - 2002 Roadtrek C190P (sold @ 315,000kms)
Winterbagoal is offline   Reply With Quote
Reply

Tags
ecm



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ECM, TCM, ABS Comm flashing on dash tiffon bus Tiffin Owner's Forum 6 01-18-2021 09:53 AM
Good SAM...Bad Sam Bad Bad Bad! STLNLUV iRV2.com General Discussion 43 12-17-2018 07:49 AM
Bad ECM max77713 Class A Motorhome Discussions 0 02-28-2016 05:03 PM
Bad, bad, bad - bad vibrations.... Doc Vegas Ford Motorhome Chassis Forum 21 11-30-2014 05:56 PM
Intermittent short (blown fuse) of ECM/TCM cable WEBBFUT Workhorse and Chevrolet Chassis Motorhome Forum 3 06-29-2013 03:36 PM


All times are GMT -6. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.