Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-19-2021, 12:00 PM   #1
Member
 
Joediver22's Avatar
 
Join Date: Mar 2020
Location: Palatine, IL
Posts: 51
OptiView Issue

I've got my Pace Arrow in REV service right now. We had the OptiView electronic dash just go blank on our trip home along I-90. One morning, I started the engine and the dash was totally blank. A completely black screen. We had to use the Garmin to know how fast we were going and fuel levels were a guessing game. Called the 24/7 phone line and checked fuses, circuit breakers and whatever else the mechanic could think of.

I've searched the forums and haven't seen this brought up anywhere. Anyone out there dealt with this before?

Thanks
Joediver22 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2021, 03:13 PM   #2
Member
 
Joediver22's Avatar
 
Join Date: Mar 2020
Location: Palatine, IL
Posts: 51
OptiView

Just got an update from REV. They sent the coach to Freightliner and apparently the wiring on my Optiview dash is not set up according to the wiring diagrams that they have. Now Freightliner is on the phone with the dash manufacturer trying to decipher the wiring
Joediver22 is offline   Reply With Quote
Old 07-10-2021, 01:11 PM   #3
Junior Member
 
Join Date: Jul 2021
Posts: 3
Any updates on this repair? Our 2021 Holiday Rambler Nautica 33tl just suffered the blank dash issue this morning
Lelandp is offline   Reply With Quote
Old 07-12-2021, 04:26 PM   #4
Member
 
Joediver22's Avatar
 
Join Date: Mar 2020
Location: Palatine, IL
Posts: 51
Quote:
Originally Posted by Lelandp View Post
Any updates on this repair? Our 2021 Holiday Rambler Nautica 33tl just suffered the blank dash issue this morning
After a month at REV (there were some additional warranty items to take care of) they couldn't figure it out. They sent it to Schools Freightliner in Ft Wayne. They had to be on the phone with the dash manufacturer for a week to figure it out. Working fine now.

I never could get a straight answer as to the cause. Let me know if you get an answer.
Joediver22 is offline   Reply With Quote
Old 07-12-2021, 10:59 PM   #5
Junior Member
 
Join Date: Jul 2021
Posts: 3
Thank you! Our rig is currently at the Whittier, CA Freightliner service center. They stated it was a Viper module needing to be replaced. Once I pick it up and have an invoice, Ill post it.
Lelandp is offline   Reply With Quote
Old 08-01-2021, 05:01 PM   #6
Junior Member
 
Join Date: Jul 2021
Posts: 3
It took two weeks and two Viper modules, were now back up and running with a functional dash.
Attached Thumbnails
Click image for larger version

Name:	6A4DBDA1-88B5-4A86-BB90-5C97368F8BE6.jpg
Views:	25
Size:	254.5 KB
ID:	338052  
Lelandp is offline   Reply With Quote
Old 09-27-2021, 11:43 AM   #7
Member
 
FOLEYMECH's Avatar
 
Newmar Owners Club
Join Date: May 2008
Location: Tabernacle NJ
Posts: 72
Just ordered a viper for my 2021 Dutch Star. Blank dash.
FOLEYMECH is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pace Arrow: 36U Newbie Question Re: Surge Guard/DriveTech Joediver22 Fleetwood Owner's Forum 1 10-19-2020 09:44 AM
Demo of the new Freightliner DriveTech Steering Wheel NealC Newmar Owner's Forum 17 11-02-2019 11:00 AM
AGS Issue: 2010 Paeton 40-QTH AGS Issue gjw Tiffin Owner's Forum 1 09-06-2013 04:46 PM
Slide Controller Issue, but maybe slide motor issue also Corwin Newmar Owner's Forum 8 07-16-2012 11:41 AM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Owner's Forum 4 10-21-2009 07:05 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.