Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Freightliner Motorhome Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-13-2014, 04:56 PM   #1
Senior Member
 
resqguy's Avatar
 
Join Date: Sep 2002
Location: Anderson, SC USA
Posts: 194
Intermittent engine and power loss

This was our first major trip of the season and about 3 hours out the Check Engine light came on and the MH dropped power and started to buck. I dropped my speed and pulled off the highway to get fuel. Driving around the area of the exit the MH drove fine. I couldn't get any truck repair places to look at the MH so I just asked one to replace my fuel/water separator. After replacing it I set out again and about 2 hours later I could feel a drop in power again and noticed the check engine, it only lasted a couple of seconds but no bucking this time. The next day it happened once again for a couple of seconds. At my next fuel stop I put in some fuel additive. It ran fine the rest of the day.

On our way home it happened once during the 8 hour trip, and again it only lasted a few seconds.

Are there some things I can check/replace on my own that would be cheaper than a trip to Freightliner? Would a repair facility be able to retrieve the error code several days old?

2004 Winnie Vectra Cummins 350.
__________________
Winnebago Coach Forum Member
2004 Winnebago Vectra 40AD
resqguy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-13-2014, 07:30 PM   #2
Senior Member
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2006
Location: Michigan
Posts: 858
I have the same coach, same engine. I'll give you a few thoughts with the caveat that I'm not a mechanic, just an owner who's gone through similar. There are wiser heads here who might be able to help. Having said that...

On my '04 Vectra with the ISC 350, there was only ONE fuel filter. The engine manufacturer gives the specs, but the chassis builder (with input from the RV manufacturer who's buying the chassis) add things like the fuel filters. Many other models with our engine have two filters, but as said, in my case just one.

In your post you mentioned you changed THE fuel/water separator, which leads me to assume yours is the same. And if you do a bit of Googling you'll find that the filter likely is after the lift pump. See this thread...

Motorhome Magazine Open Roads Forum: Class A Motorhomes: 2000-2004 Cummins ISC owners beware

I had a lot of issues similar issues (attributed to bad fuel) until I had my Freightliner/Cummins shop install a 2nd filter before the lift pump. Not a cheap fix but took care of a lot of issues for me. I'd suggest you have a good Freightliner shop look things over and get their suggestion.

Just my quick thought...
__________________
Ed & Joie
2004 Vectra 40KD
Freightliner Chassis and Cummins ISC
emiddleb is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of Power ISC 8.3 Bompa13 Cummins Engines 11 07-27-2014 08:36 PM
Electrical Power loss Blair T. Class A Motorhome Discussions 13 06-27-2014 07:28 PM
12v Power Loss farmerhouse Fleetwood Owner's Forum 3 05-20-2014 08:39 PM
ISM power loss only after warmed up The Driver Cummins Engines 12 04-25-2014 04:49 PM
Intermittent issue engine has no power (7.4 Vortec) C350AMG Workhorse and Chevrolet Chassis Motorhome Forum 8 01-24-2014 08:25 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.