Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Travel Supreme Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-23-2022, 08:28 PM   #1
Junior Member
 
SheriffMike's Avatar
 
Fleetwood Owners Club
Spartan Chassis
RV Trip Wizard
Join Date: Oct 2019
Location: Lebanon, IN
Posts: 10
Engine Battery Replacement - Wont Start

Good evening everyone. New to this group and new to Travel Supremes. Recently upgraded from a 1999 40’ American Eagle to this new to us 2003 45’ DSO-1 Select. This coach was brought back to the factory in 2007 for a total upgrade to a 2007 model. It has a K2 chassis, 500 Cummins ISM with an Allison transmission. Been upgrading tires, shocks, batteries, service, etc. I changed out the engine batteries and now the coach will not start. All wiring is put back together and checked several times to verify it was put back together properly. When the key is turned to the on position the dash lights come on but it never reaches the “start” light on the dash. If you turn the ignition to crank it just does not crank over. It says no SPDO and then NO DATA in the Speedometer reading area. Wondering if anyone would be willing to video the dash and the transmission gear shift area when their coach is started up so I know what the dash is supposed to look like on start-up? It was starting and running fine prior to me replacing batteries. Maybe shorted something out but I was very careful. Long post but reaching out for any help or wiring documentation that this group may have. The AE group I belonged to was awesome as I am sure you all will be as well. Thank you in advance! Mike
__________________
Mike and Linda Nielsen - Indiana
Current: 2003 Travel Supreme (45 foot)
Past: 1999 American Eagle (40 foot)
SheriffMike is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-24-2022, 05:21 AM   #2
Senior Member
 
Winemaker2's Avatar
 
Join Date: Nov 2006
Location: Western NY
Posts: 5,219
I dont know about that year or ISM but I know my 2013 ISB recommends removing neg term first & replacing last to avoid possible damage to ECM.
No idea if that's possible with your situation. Mine has a pos Betty switch but also a bypass around the sw to keep ECM powered. I have read that following a comolete disconnect there is a procedure or time period for the ECM to reset but again I don't have the details or enough knowledge to advise other than it might be worth looking into.
__________________
Don & Marge
'13 Newmar Ventana 3433 - '14 CR-V TOAD
'03 Winnebago Adventurer 31Y - SOLD
Winemaker2 is offline   Reply With Quote
Old 05-24-2022, 08:24 PM   #3
Junior Member
 
SheriffMike's Avatar
 
Fleetwood Owners Club
Spartan Chassis
RV Trip Wizard
Join Date: Oct 2019
Location: Lebanon, IN
Posts: 10
I wanted to follow up on my post yesterday about my 2003 TS Select. It failed to start after installing new engine batteries. First and foremost, thank you for the responses. I hope by posting the resolution it may help some of you in the future if you have a similar issue.

The problem was the fact that the coach could not verify that the transmission was in neutral so it would not turn over. Clue #1 for me should have been the fact that the gear shift panel was dead. If this is dead there is no way the coach will start because of this saftey feature.

It took forever to trace down where the fuse box was for the transmission. Thanks to Spartan and them sending me the wiring diagrams for my coach I was able to find the BUSSMANN fuse and relay panel for my coach. the fuse for the TRANS ECU was blown. I replaced it and the coach would turn over but not fire. I then went back and checked all the fuses in that transmission fuse and relay block and found both ENG ECU fuses blown. I replaced both of them and the coach fired right up. Best I can tell is that I must have shorted a couple wires to together on my reinstall.

The BUSSMANN fuse box was located in the engine compartment above the rear fender on the passenger side. You could not access it from the rear but you could see it. It had to be accessed though the rear engine access from inside the coach.

I am including a couple of pics for you all to help with your future endeavors. Thanks again for all your help! Mike
__________________
Mike and Linda Nielsen - Indiana
Current: 2003 Travel Supreme (45 foot)
Past: 1999 American Eagle (40 foot)
SheriffMike is offline   Reply With Quote
Reply

Tags
ace, battery, engine, replace, replacement



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No power inside my coach generator wont start jack stands wont work ssellon National RV Owner's Forum 25 05-23-2021 05:26 PM
Generator wont start and batteries wont stay charged Ladonnavegas Class A Motorhome Discussions 5 10-18-2017 09:48 AM
HWH rear lowers wont lift, front lifts wont store Forkyfork Class A Motorhome Discussions 11 07-25-2017 05:09 PM
slide out wont come in leveler wont come up. china3 Tiffin Owner's Forum 2 09-02-2013 02:58 PM
1994 southwind - engine battery wont kick over engine stevenstoli Fleetwood Owner's Forum 7 11-01-2012 03:31 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.