Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Travel Supreme Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-29-2021, 04:26 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 21
Question Hydra-Hot (Aqua-Hot)question

We own a 2007 Travel Supreme Envoy which we thoroughly enjoy. But, we occasionally have a problem with the Hydra Hot system shutting down due to a "low voltage" fault even when we are plugged into 50 amp shore power. We have brand new batteries installed as well. I will either wait the 30 second delay and restart it or go in the basement and reset the unit on the control panel. It will restart and usually lasts several hours before shutting down again. Anyone have an answer? Also, when first starting up the unit to get ready for a new trip I have to push the green button three times for the unit to fire up so I am wondering if there is a connection with the other problem? Any help you can offer is much appreciated - Thank You!
MiniPearl7 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-30-2021, 08:18 AM   #2
Senior Member
 
The Driver's Avatar
 
Join Date: May 2011
Location: Dayton, Ohio
Posts: 742
Sounds to me like a loose connection down on the unit. If you are in Hartford City, you are close to the territory of a Hydro Hot master, Darin Hathaway. At this time of year he's headquartered around Elkhart. Call him and arrange to drive the coach to where he can meet you; he's mobile with all the tools and most of the parts he needs. Wonderful, capable, pleasant guy. Phone is 574-612-4826.
__________________
Doug, Robyn, Ross & Ryan
06 TS Select 45
see our blog: www.thebigtaxi.com
The Driver is offline   Reply With Quote
Old 07-30-2021, 09:41 AM   #3
Junior Member
 
Join Date: May 2013
Posts: 21
Thank you Mr. Ryan - we will do just that! I appreciate your interest and knowledge! Ron Wolf
MiniPearl7 is offline   Reply With Quote
Old 07-31-2021, 05:24 AM   #4
Senior Member
 
Join Date: Nov 2017
Location: Johnson Vermont
Posts: 174
Quote:
Originally Posted by MiniPearl7 View Post
We own a 2007 Travel Supreme Envoy which we thoroughly enjoy. But, we occasionally have a problem with the Hydra Hot system shutting down due to a "low voltage" fault even when we are plugged into 50 amp shore power. We have brand new batteries installed as well. I will either wait the 30 second delay and restart it or go in the basement and reset the unit on the control panel. It will restart and usually lasts several hours before shutting down again. Anyone have an answer? Also, when first starting up the unit to get ready for a new trip I have to push the green button three times for the unit to fire up so I am wondering if there is a connection with the other problem? Any help you can offer is much appreciated - Thank You!
RV Hydronic Heater Forum check out this forum
Herb51 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydra/aqua hot inspection 12amNSX Class A Motorhome Discussions 14 10-14-2018 03:38 PM
Does the Hydra Hot Deisel have to be on for furnace Jdaniel2509 Travel Supreme Owner's Forum 4 03-06-2014 09:10 AM
Hydra hot tank overflow Garvmed Country Coach Owners Forum 11 03-03-2014 06:33 PM
Hydra-Hot heating or heat pumps LABergo Newmar Owner's Forum 5 12-24-2010 03:06 PM
Winterizing a Newmar 4304 with Hydra-Hot dav-cle Newmar Owner's Forum 8 12-22-2010 10:33 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.