Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-01-2015, 05:54 AM   #1
Senior Member
 
Mwoodofd's Avatar


 
Entegra Owners Club
Join Date: Apr 2013
Location: Las Colinas, Texas
Posts: 1,608
Aqua Hot 375 LP

My LP burner will not light. (Electric working fine) I Called AH on Friday to get some tips on things to check over the weekend.

My fan was not running on the burner assembly, and I hooked it to a 12v source, and it works. I found the 30 Amp fuse in the AH case was blown. (30 Amp fuse seem high) The burner lit while I had the fan running, so I believe it is leading to the Buck Booster Control Switch. When I installed a new 30 amp fuse, something around the Buck Booster Control plug smoked. I figured that was not a good sign, but it did not blow the fuse. (probably fried the Booster)

When I connect the fan to a 12V source, the burner will light, but I will not leave it hooked up this way. May have fried the Buck Booster Control switch. Anyone have any experience with this?
__________________
Mark & Debra Wood, Las Colinas, TX.
2013 Entegra Aspire 42RBQ
2013 Thor Challenger 37DT - Sold
2014 Jeep Wrangler Sahara
Mwoodofd is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-01-2015, 07:44 AM   #2
Member
 
Keith W's Avatar
 
Join Date: Oct 2013
Location: Moscow, TN
Posts: 85
You might already have this but here is some trouble shoot info for both boosters.

Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1446388921.154081.jpg
Views:	151
Size:	199.3 KB
ID:	110875
Click image for larger version

Name:	ImageUploadedByiRV2 - RV Forum1446388950.404538.jpg
Views:	126
Size:	192.7 KB
ID:	110876

Keith


Moscow, TN
2013 Aspire DEQ IFS
Buick Enclave
Keith W is offline   Reply With Quote
Old 11-01-2015, 07:47 AM   #3
Senior Member
 
Join Date: Oct 2014
Location: McMurray, Pa
Posts: 868
Ours did the same thing after almost three years of ownership. You will need replace the controllers on the right lower side of the AH. Wh enough I called CS they had me replace the 30amp fuse and the fuse blew right away. Since we were trading the coach I told the tech about it and they were going to address it.
__________________
John
2016 Anthem 44B
2013 MKX
waterboy10 is offline   Reply With Quote
Old 11-01-2015, 12:47 PM   #4
Senior Member
 
coachmanrvr's Avatar
 
Entegra Owners Club
Join Date: Dec 2008
Location: Chattanooga, TN
Posts: 865
Ours has given us little problems other than needing air adjustment on the blower. Change of seasons get it cranky and needs a small adjustment to start the burner.

Good luck, the manual for these things are quite good.
__________________
2012 Entegra Aspire
2012 Nissan Xterra Pro4x Tow
Ready Brute Elite
coachmanrvr is offline   Reply With Quote
Old 11-01-2015, 03:22 PM   #5
Senior Member
 
voltdoc's Avatar
 
Entegra Owners Club
Join Date: Oct 2010
Location: East Greenwich, RI
Posts: 1,748
Quote:
Originally Posted by waterboy10 View Post
Ours did the same thing after almost three years of ownership. You will need replace the controllers on the right lower side of the AH. Wh enough I called CS they had me replace the 30amp fuse and the fuse blew right away. Since we were trading the coach I told the tech about it and they were going to address it.
Yeah, that's probably it, one of the two buck/boost (voltage regulators) modules has probably fried. I had the same problem about a year ago. Mine kept popping the 20A fuse inside the AH cabinet. In my case the bad module was obvious, it looked and smelled of burnt electronics. Easy to swap out.

The info Keith posted walks you thru the troubleshooting process. You can get the entire service manual on the AH site.

The buck/boost modules keep the voltage supplied to the various components at a constant and precise 12 volts, it will 'boost' it if it's less than 12.0 and 'buck' it back down if its more.
__________________
Rob & Linda https://MyQuantumDiscovery.com
2017 Entegra Aspire 44B - 2021 Jeep Grand Cherokee L Overland
2013 Entegra Aspire 42RBQ
voltdoc is offline   Reply With Quote
Old 11-01-2015, 04:19 PM   #6
Senior Member
 
Mwoodofd's Avatar


 
Entegra Owners Club
Join Date: Apr 2013
Location: Las Colinas, Texas
Posts: 1,608
I did download the service manual, and followed the troubleshooting section trying to narrow down the possible issues, and could not understand some of the volt meter tests and where to place the leads of the meter, but the tests I could complete point to the booster. I wrote down all the readings and steps, and will call AH tomorrow morning.

Voltdoc, did you go to a 25 or 30 amp fuse and everything work once the boosters were replaced? Mine had a 30 amp in it, and when I replaced it, that is when the bcuk booster control smoked, and had that electronic burn smell. Sounds like the same issue.
__________________
Mark & Debra Wood, Las Colinas, TX.
2013 Entegra Aspire 42RBQ
2013 Thor Challenger 37DT - Sold
2014 Jeep Wrangler Sahara
Mwoodofd is offline   Reply With Quote
Old 11-03-2015, 08:53 AM   #7
Senior Member
 
voltdoc's Avatar
 
Entegra Owners Club
Join Date: Oct 2010
Location: East Greenwich, RI
Posts: 1,748
Quote:
Originally Posted by Mwoodofd View Post
I did download the service manual, and followed the troubleshooting section trying to narrow down the possible issues, and could not understand some of the volt meter tests and where to place the leads of the meter, but the tests I could complete point to the booster. I wrote down all the readings and steps, and will call AH tomorrow morning.

Voltdoc, did you go to a 25 or 30 amp fuse and everything work once the boosters were replaced? Mine had a 30 amp in it, and when I replaced it, that is when the bcuk booster control smoked, and had that electronic burn smell. Sounds like the same issue.
Mark, I did not change any fuse ratings. As I recall the master fuse inside the AH cabinet was 20A and the feed from the compartment in front of the driver side front tire was a 30A. Best to check with AH and use what they recommend. My guess is the module shorted, popped the fuse, then when you replaced the fuse it continued to fry. You didn't hurt anything and the ratng of the fuse didn't really matter since the module was already bad. Fuse ratings are usually designed to protect the wiring.

Good luck!
__________________
Rob & Linda https://MyQuantumDiscovery.com
2017 Entegra Aspire 44B - 2021 Jeep Grand Cherokee L Overland
2013 Entegra Aspire 42RBQ
voltdoc is offline   Reply With Quote
Old 11-03-2015, 07:51 PM   #8
Senior Member
 
Mwoodofd's Avatar


 
Entegra Owners Club
Join Date: Apr 2013
Location: Las Colinas, Texas
Posts: 1,608
Rob,

Thank you - I did get the info from Aqua Hot, and after a few trouble shooting tips on the phone with them, were did determine it is the fan control Buck Booster card, and I have on on the way to arrive on Thursday - should fix the unit. I will report back once installed.
__________________
Mark & Debra Wood, Las Colinas, TX.
2013 Entegra Aspire 42RBQ
2013 Thor Challenger 37DT - Sold
2014 Jeep Wrangler Sahara
Mwoodofd is offline   Reply With Quote
Old 11-05-2015, 05:55 PM   #9
Senior Member
 
Mwoodofd's Avatar


 
Entegra Owners Club
Join Date: Apr 2013
Location: Las Colinas, Texas
Posts: 1,608
Aqua Hot Unit fixed.

I received the buck booster control today from Aqua Hot. Replaced the defective booster in about 5 minutes, and all is well. The unit is functioning normal, and we are back in the hot water, and may need the heat in a week. (we are staying in the MH for about 2 months while we build a house moving around the DFW area, out by Texas Motor Speedway now, and the races are in town)

I want to say that I am very happy working with Aqua Hot Technical support trouble shooting the problem to getting the part in 2 days. Many thanks to Jim for helping me through this.
__________________
Mark & Debra Wood, Las Colinas, TX.
2013 Entegra Aspire 42RBQ
2013 Thor Challenger 37DT - Sold
2014 Jeep Wrangler Sahara
Mwoodofd is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aqua Hot exhaust pipe replacement. B nehusker33 Class A Motorhome Discussions 6 09-30-2015 05:44 AM
Let's talk Aqua Hot castrol Monaco Owner's Forum 38 07-28-2015 10:57 AM
375 Aqua Hot coachmanrvr Entegra Owner's Forum 5 05-21-2015 01:41 PM
Class A bunkhouse with Aqua Hot? RVseeker Class A Motorhome Discussions 3 05-15-2015 01:49 PM
Aqua Hot problem Inspector 77 RV Systems & Appliances 8 04-24-2014 07:20 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.