Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-28-2023, 06:20 PM   #1
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Coach wonít start. (HELP)

We have a 2019 Entegra Aspire. We just had our coach batteries replaced in Feb 2023 no issues until today. Went to start coach and I get 3 green flashing lights on the start button and nothing else. I changed batteries in the key fobs and same thing. Is there a fuse some where or some other trick I might try? I reached out to Spartan after hours and have received no call back. Any recommendations would be appreciated. TIA
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-28-2023, 06:23 PM   #2
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 30,723
If you have no air pressure, there's an over ride switch next to the brake pedal. Both must be pressed at the same time.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 05-28-2023, 06:33 PM   #3
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Quote:
Originally Posted by brobox View Post
If you have no air pressure, there's an over ride switch next to the brake pedal. Both must be pressed at the same time.


I tried that no luck still flashed green 3 times.
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 05-28-2023, 07:00 PM   #4
Member
 
Join Date: Mar 2016
Posts: 51
Go to the back battery bay for chassis batteries, turn off both switches for 30 seconds , then turn back on and try to start the unit
rrk8091 is offline   Reply With Quote
Old 05-28-2023, 07:10 PM   #5
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Coach wonít start. (HELP)

Spartan called back they had me place key fob the fake wood on dash passenger side. They had be shut off both master switch to chassis and remove both F10 and F11 fuse and wait 10 minutes. Still didnít work. He says it probably the TriMark box and to call them Tuesday and they could overnight one to me. He says they are just plug and play.
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 05-28-2023, 08:17 PM   #6
Senior Member
 
Jimjensen's Avatar
 
Join Date: Jul 2016
Location: Lake Havasu, Az
Posts: 154
Quote:
Originally Posted by Armye7 View Post
Spartan called back they had me place key fob the fake wood on dash passenger side. They had be shut off both master switch to chassis and remove both F10 and F11 fuse and wait 10 minutes. Still didnít work. He says it probably the TriMark box and to call them Tuesday and they could overnight one to me. He says they are just plug and play.
Iíve had the same issue. I was told to shut both main switches for 15 minutes, did it for ten no joy. Tried again for 15 and away it went. Try it again for a full fifteen and hopefully you have the same results I did.
__________________
Jim and Alice
2023 CS 45D
2016 Anthem 44B sold
Jimjensen is offline   Reply With Quote
Old 05-28-2023, 08:50 PM   #7
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Quote:
Originally Posted by Jimjensen View Post
Iíve had the same issue. I was told to shut both main switches for 15 minutes, did it for ten no joy. Tried again for 15 and away it went. Try it again for a full fifteen and hopefully you have the same results I did.


Did you also remove the F10 and F11 fuses
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 05-29-2023, 01:08 AM   #8
Senior Member
 
Join Date: May 2014
Location: AZ
Posts: 210
Make sure your chassis battery connections are tight. My Aspire did the same thing and it ended up being the battery connections that looked tight but were not.
__________________
Ron S.
2014 Aspire 44U
2006 H3 & 2015 GMC Terrain Denali
ronlin11 is offline   Reply With Quote
Old 05-29-2023, 06:17 AM   #9
Senior Member
 
Join Date: Jul 2017
Location: Cypress, Tx.
Posts: 1,048
I agree with trimark box being bad. Spartan will send you a new box with 2 new keyfobs. When you get new box put it right next to the original one. Then unplug one connector from the old to the new. Should take about 5 minutes
__________________
2014 Foretravel IH45
Houston (Cypress), TX.
Turbojack is offline   Reply With Quote
Old 05-29-2023, 06:41 AM   #10
Senior Member
 
Jimjensen's Avatar
 
Join Date: Jul 2016
Location: Lake Havasu, Az
Posts: 154
Quote:
Originally Posted by Armye7 View Post
Did you also remove the F10 and F11 fuses
I did not. I have a 23 and Iím told starting process on the 22 and 23 are different than earlier years. In my case I was told to remove any keys from the fob and place it next to the shift pad ( on the 23 itís located horizontally next to bank of switches and phone charger ) because the antenna for the TriMark box is located directly below in that panel. In your case the box is apparently located under the dash panel as my 2016 was.
__________________
Jim and Alice
2023 CS 45D
2016 Anthem 44B sold
Jimjensen is offline   Reply With Quote
Old 05-29-2023, 08:37 AM   #11
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
I will definitely be back on phone with them tomorrow. Hopefully they will be able to overnight. Right now we are stuck in a campground. There is a lot of wires in there hope I can figure this out
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 05-29-2023, 08:41 AM   #12
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Quote:
Originally Posted by Turbojack View Post
I agree with trimark box being bad. Spartan will send you a new box with 2 new keyfobs. When you get new box put it right next to the original one. Then unplug one connector from the old to the new. Should take about 5 minutes


Itís sits in the bottom of that compartment with a lot of wires everywhere in there. But it should be some what easy I hope.
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Old 05-29-2023, 10:49 AM   #13
Junior Member
 
Join Date: Jan 2019
Posts: 21
I have a 19 Insignia and every once in awhile this happens to me. There is a 5 amp fuse in the bay outside under the driver seat. It is behind a screw on panel and labeled TRIMARK. Check to see if that one is bad.
__________________
Doug Worner
2019 Insignia 44R
SOODEW is offline   Reply With Quote
Old 05-29-2023, 02:18 PM   #14
Senior Member
 
Armye7's Avatar
 
Join Date: May 2015
Posts: 284
Quote:
Originally Posted by SOODEW View Post
I have a 19 Insignia and every once in awhile this happens to me. There is a 5 amp fuse in the bay outside under the driver seat. It is behind a screw on panel and labeled TRIMARK. Check to see if that one is bad.



I screwed that panel off nothing thatís marked TriMark.
__________________
Larry & Vickie Carman
2019 Aspire 44W
Springboro Ohio
Armye7 is offline   Reply With Quote
Reply

Tags
coach



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 Winnebago Itasca Horizon will not start won't start 😞 Flares Winnebago Industries Owner's Forum 3 07-27-2021 06:15 PM
Onan EC-30 auto start issues...won't start for HVAC CALL jstdreamin MH-General Discussions & Problems 7 05-24-2016 11:04 AM
Generator Won't Start - Engine Won't Crank Rob Howden RV Systems & Appliances 10 08-02-2015 07:35 PM
2007 600HP ISX stalled after start, now won't start slemnah Cummins Engines 2 01-26-2015 08:06 AM
Jacks won't retract and engine won't start HLB MH-General Discussions & Problems 12 07-31-2009 10:22 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.