Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-31-2021, 12:16 PM   #1
Senior Member
 
RVFunlovers's Avatar


 
Entegra Owners Club
Spartan Chassis
Join Date: Oct 2017
Posts: 462
Cornerstone water pump

My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?
__________________

Hal and Pam
2017 Entegra Cornerstone - B
2020 Ford Edge ST
RVFunlovers is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-31-2021, 12:51 PM   #2
Senior Member


 
Join Date: May 2019
Location: Moosic, PA
Posts: 112
I had a similar situation recently after emptying my fresh tank. Pump worked fine before I drained the tank and didnít use until two weeks later when I left the resort. My pump hummed and vibrated but would not pump water. Turns out I sucked a bunch of air in the system as I used the pump to try to empty the tank quicker beside just opening the drain valve. A full timer mechanic at the resort helped me and I believe he forced water to the pump then let it run to get the air out. There is a thread here somewhere explaining the same procedure. I apologize I was not there to watch as he repaired it. Maybe this will be your solution before replacing the pump.
__________________
Joe, Paula, Joseph, & Preston
2020 King Aire 4531
2018 Wrangler Sahara JKU
JGilchrist is offline   Reply With Quote
Old 01-31-2021, 01:02 PM   #3
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,276
Without seeing your system , I believe the clear hose and valve , are for winterizing and pumping RV anti-freeze from a jug through the coach .

If your not getting water flow after a long period of pump run , then good chance the pump is the problem . Make and model info will be on the pump .
Some makes there is a valve head available if the motor runs.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 01-31-2021, 01:10 PM   #4
Senior Member


 
Join Date: Feb 2013
Location: Cleveland Ohio
Posts: 432
Hal,

Not sure I can be of much help in diagnosing the problem but there are plenty of Posts relating to failure and/or troubleshooting of the pump. I have attached a picture of the SHURFLO pump 4048 that I purchased as a spare and 2 pictures of the wet-bay and area of the pump. I would think that if you were to replace the pump it would be done thru the rectangular opening vs. taking all the associated connections, electrical and plumbing off, remove the panel, remove/replace the pump then put everything back together!
Let us know what the final outcome was when you find out.

Safe travels.
Attached Thumbnails
Click image for larger version

Name:	IMG_1118.jpg
Views:	10
Size:	317.9 KB
ID:	316516   Click image for larger version

Name:	IMG_1119.jpg
Views:	11
Size:	214.8 KB
ID:	316517  

Click image for larger version

Name:	IMG_1120.jpg
Views:	13
Size:	209.6 KB
ID:	316518  
__________________
John & Maria - Chester (furry kid)
2017 Cornerstone 45B - FMCA-#489135
2012 Scion XB - Pushing hard
jrugarber is offline   Reply With Quote
Old 01-31-2021, 01:39 PM   #5
Registered User
 
Join Date: May 2017
Posts: 2,582
Quote:
Originally Posted by RVFunlovers View Post
My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?
I think Entegra started installing the shutoff valve, in 2017, to the pump so water canít fill your tank while hooked to city water. If that valve is closed pump cannot pump water. The valve is in line going to pump. Of course if you havenít closed it that shouldnít be the problem.
Rollin101 is offline   Reply With Quote
Old 01-31-2021, 02:27 PM   #6
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,690
Quote:
Originally Posted by RVFunlovers View Post
My water pump stopped working yesterday. I rarely dry camp so it is generally just used when we are traveling to flush a toilet or run sink water for hand washing.

I checked the circuit breaker and it is ok. Pump makes a hum noise that you can hear and I can feel the pump vibrate but no water output.

Plenty of fresh water in the tank. I checked the little filter on the pump and it is clean. I tried to stick the clear plastic hose in a bucket of water and get no suction no matter what position I put the clear hose valve in. I was thinking that might be to prime the pump.

I think my pump is bad. Any ideas?

It was working fine. Now it is not. I have let is run several times for a while but no output. All water working ok when connected to city water. My water fill switch is in city water position. But I tried it both ways.

If I do need a new pump:

How do I figure out exactly what pump I need to purchase?

The pump looks hard to get to. Do I remove the entire wet bay panel to change the pump or do I try reaching in from the smaller rectangle access panel opening?
If you have the Shurflo 4008 pump the most likely problem is the internal check valve (rubber, about 3/4Ē diameter) is stuck closed and the pump pressure is not enough to open it back up. I had this happen on mine several times before I replaced the pump with a different brand.

The check valve is located inside the black plastic end with the 8 screws. I removed this end and pushed the check valve with my finger to release it. Might want to lube with a thin film of plumbers grease. Re-assemble and you should be good to go.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 01-31-2021, 03:45 PM   #7
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 25,962
Here are several posts on how to prime the water pump. https://www.google.com/search?client...the+water+pump
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 01-31-2021, 03:46 PM   #8
Senior Member
 
RVFunlovers's Avatar


 
Entegra Owners Club
Spartan Chassis
Join Date: Oct 2017
Posts: 462
Thanks for the help. I am going to try to release the check valve. And at least figure out what exact pump I have so I can order a new one if needed.
__________________

Hal and Pam
2017 Entegra Cornerstone - B
2020 Ford Edge ST
RVFunlovers is offline   Reply With Quote
Old 01-31-2021, 03:55 PM   #9
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 25,962
Hal, I would try a simple priming the pump first. If the pump is running, that's a good chance of the problem. The check valve problem normally is the tank over filling.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 01-31-2021, 06:22 PM   #10
Senior Member
 
Join Date: Jan 2018
Posts: 1,059
Most likely it just needs to be primed.

Put the outside shower on the ground, turn it on, and open it's cold valve.
Hook a hose to the shore water inlet.
Turn on the hose and the pump.
Water will come out the hose. Let it run til it's not spitting air.
Work the city/tank valve. city. tank. city tank. repeat until the pump builds pressure.

Remember with the valve in city, the pump never builds pressure.
flip it to tank, once it's primed it should build pressure and stop.
__________________
Jim and Carol, plus furrballs Riley, Nikko, and Kobi

2017 Entegra Aspire, 2008 Monaco Knight, 2000 Fleetwood Pace Arrow
oneknight is offline   Reply With Quote
Old 02-01-2021, 03:47 PM   #11
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,690
Quote:
Originally Posted by brobox View Post
Hal, I would try a simple priming the pump first. If the pump is running, that's a good chance of the problem. The check valve problem normally is the tank over filling.
Chuck,

The tank overfilling would be the check valve sticking open. Mine always stuck closed. You hear the pump running but zero water coming out of any tap. These pumps are for the most part self priming so I cannot see it as a priming problem.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 02-01-2021, 03:49 PM   #12
Senior Member
 
757driver's Avatar


 
Entegra Owners Club
Join Date: Jun 2004
Location: Cambridge, Ontario
Posts: 4,690
Quote:
Originally Posted by RVFunlovers View Post
Thanks for the help. I am going to try to release the check valve. And at least figure out what exact pump I have so I can order a new one if needed.
If it is a Shurflo 4008 I would not replace it with the same model. The 4048 model does much better.
__________________
Don & Gerri
2014 Entegra Anthem 44B
2014 Honda CRV Touring

1300W Solar, 1200AH LiFePO4 FMCA F443497
757driver is offline   Reply With Quote
Old 02-01-2021, 04:23 PM   #13
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 25,962
Quote:
Originally Posted by 757driver View Post
Chuck,

The tank overfilling would be the check valve sticking open. Mine always stuck closed. You hear the pump running but zero water coming out of any tap. These pumps are for the most part self priming so I cannot see it as a priming problem.

I see what your saying, mine was the opposite filling the tank. I did get an air lock in my water system and had to prime the pump and force the air lock out.


Quote:
Originally Posted by 757driver View Post
If it is a Shurflo 4008 I would not replace it with the same model. The 4048 model does much better.
Totally agree, it's an easy upgrade and well worth it.
After my air lock I felt the 4008 was not enough water pump for the system and changed it to the 4048 for that reason.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 02-01-2021, 05:25 PM   #14
Senior Member
 
RVFunlovers's Avatar


 
Entegra Owners Club
Spartan Chassis
Join Date: Oct 2017
Posts: 462
I believe I have a 4008. If I have to get a new pump I will get the 4048. The weather has been unpleasant the past two days so I have not messed with the pump. I am going to try to get my current pump going but I think I will need a new one.

The pump looks hard to get at. But thankfully Amazon sells the 4048 with 2 day shipping.
__________________

Hal and Pam
2017 Entegra Cornerstone - B
2020 Ford Edge ST
RVFunlovers is offline   Reply With Quote
Reply

Tags
pump, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cornerstone :: 2015 Entegra Coach Cornerstone Rwgagnon iRV2 Owners Registry 0 01-13-2021 08:46 AM
Front windshield 2013 Cornerstone vs 2017 Cornerstone TDB1227 Entegra Owner's Forum 5 08-27-2016 05:39 PM
Cornerstone for a Cornerstone Kevin & Joyce Entegra Owner's Forum 11 06-09-2016 10:17 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.