Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-13-2022, 04:48 PM   #1
Member
 
Join Date: Aug 2020
Posts: 35
Macerator leak

I replaced the pump motor in a Sanicon turbo 700. This is my first outing with it. 4 holes...very small, maybe vent holes bubble a lage amount of liquid out when I open the gate valves. Turn the pump on and it shoots everywhere from these holes...what did I do wrong?
Alfalfa1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-13-2022, 07:21 PM   #2
Senior Member
 
Join Date: Sep 2010
Posts: 4,320
Replaced the Sanicon 700 pump 2 years ago on our 18 LA and didn't have any leaks. The leaks are coming from the Sanicon pump our the hose?
Newmar Man
__________________
Tom/Teri 16031 NKK 117995 FMCA
18 London Aire 4531 Spartan K-3 605
97-04 LA 04-18 Essex 2018 London Aire
tom chelbana is offline   Reply With Quote
Old 08-14-2022, 06:06 AM   #3
Member
 
Join Date: Aug 2020
Posts: 35
all around the top of the pump housing
Alfalfa1 is offline   Reply With Quote
Old 08-14-2022, 06:14 AM   #4
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 28,699
A photo might help others see just what the problem might be. Personally I can't picture where it might be coming from.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is offline   Reply With Quote
Old 08-14-2022, 06:43 AM   #5
Member
 
Darrowman's Avatar
 
Entegra Owners Club
Join Date: Jul 2011
Location: Texas
Posts: 55
Could it be that the o-ring, or in this case the square ring, is not properly seated. This should not be too hard to check, just pretty smelly! Where are the leaks showing up in relation to this picture? Around the inside set of holes? If so, more than likely the ring is not seated. Click image for larger version

Name:	20210111_144916.jpg
Views:	16
Size:	72.2 KB
ID:	373576
__________________
Darrell and Kim
2017 Cornerstone 45W
Chevy Tahoe (toad)
Darrowman is offline   Reply With Quote
Old 08-14-2022, 03:42 PM   #6
Member
 
Spartan Chassis
Join Date: Mar 2021
Posts: 61
Had the same problem the seal on top wasnít in correctly.
AggrevatedRv is offline   Reply With Quote
Old 08-14-2022, 03:57 PM   #7
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 10,677
Blog Entries: 1
I'm also bettin' on the O-ring seal either being missing or not inserted in its slot correctly. Also make sure that the top access is rotated correctly that it bonds with the rubber seal.

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5FI
Gary.Jones is online now   Reply With Quote
Old 08-14-2022, 05:17 PM   #8
Senior Member
 
777 Driver's Avatar


 
Entegra Owners Club
Spartan Chassis
Join Date: Feb 2010
Posts: 3,320
When I replaced my macerator pump, it became apparent that the o-ring had a tendancy to pop out of the channel into which it was seated so that, as you replaced the top panel, it was likely that the o-ring would not be properly seated when the top panel was screwed into place.

My solution was to push Vaseline into the channel before I seated the o-ring into the channel. That seemed to adhere the o-ring into the channel making replacement of the top a simple matter.

Take care,
Stu
__________________
"I would rather have questions that can't be answered than answers that can't be questioned."
2018 Anthem 42DEQ
777 Driver is offline   Reply With Quote
Old 08-15-2022, 06:08 AM   #9
Member
 
Join Date: Aug 2020
Posts: 35
I'll redo the o ring....I was not aware the top was not symetrical
Alfalfa1 is offline   Reply With Quote
Old 08-15-2022, 07:14 AM   #10
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 10,677
Blog Entries: 1
I'm working from memory, and you are working from your actual inspection. The top may be actually square. I was just cautioning you to examine carefully if the "O" ring slot might and top section might be slightly out of position.

Good luck and please come back and give us a follow up analysis of the final "fix".

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5FI
Gary.Jones is online now   Reply With Quote
Old 08-15-2022, 07:30 AM   #11
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 28,699
Use silicone grease to seat the gasket and hold it in place. It will also keep the gasket soft forming a better seal. Silicone grease is sold at any pool supply or HD, Lowes.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is offline   Reply With Quote
Old 08-26-2022, 01:52 PM   #12
Member
 
Join Date: Aug 2020
Posts: 35
Thank you all!

I removed the top screws and placed vaseline in the o-ring channel. after reinstalling the o-ring and top it worked perfectly. Except now, it blew out the discharge hose
Alfalfa1 is offline   Reply With Quote
Old 08-26-2022, 03:27 PM   #13
Senior Member
 
777 Driver's Avatar


 
Entegra Owners Club
Spartan Chassis
Join Date: Feb 2010
Posts: 3,320
Quote:
Originally Posted by Alfalfa1 View Post
I removed the top screws and placed vaseline in the o-ring channel. after reinstalling the o-ring and top it worked perfectly. Except now, it blew out the discharge hose
Glad that you got the top leak fixed. When you say discharge hose, is this what you mean:

Click image for larger version

Name:	Flexible fitting.jpg
Views:	9
Size:	35.8 KB
ID:	374634

If the rubber part has failed, they should be easily available at Lowes/Home Depot/Ace Hardware. If it is just the steel clamp, you should be able to tighten the clamp to stop the leak.

Take care,
Stu
__________________
"I would rather have questions that can't be answered than answers that can't be questioned."
2018 Anthem 42DEQ
777 Driver is offline   Reply With Quote
Old 08-26-2022, 03:44 PM   #14
WDW
Senior Member
 
WDW's Avatar
 
Join Date: Jul 2014
Posts: 1,452
I think what youíll find the problem is with that rubber coupling is that the pipe to the right of it as it extends and connects to the flexible hose is not properly supported. In our situation I removed that flexible hose and re-plumbed it with a solid piece of PVC which I then put two support mounts to hold it in place and to remove the torque that happens when you pull the hose. I then used camlock hose couplings at the end of the PVC piping to attach the extendable hose so that itís easy to replace or remove.
__________________
Taking in the sights with our Trolley ...but life is always better under a Palm Tree
2019 Jayco Embark (Entegra) 39T2. - our Trolley
2019Jeep Cherokee Latitude, Western New York
WDW is offline   Reply With Quote
Reply

Tags
ace, leak, macerator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dometic macerator 8743 Leak JPietri Newmar Owner's Forum 6 07-05-2020 07:32 PM
Macerator malfunction and black water leak GFINPS Fleetwood Owner's Forum 5 03-28-2020 09:14 PM
Dometic Macerator Leak redbaron73 Newmar Owner's Forum 23 08-12-2019 10:14 PM
Leak under macerator in 2016 Aspire The Dean Entegra Owner's Forum 4 02-27-2019 05:43 AM
Crazy leak with macerator toilet when shower is on? blackhawkscp Newmar Owner's Forum 17 08-12-2017 09:29 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.