Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-15-2021, 12:24 PM   #43
Junior Member
 
Entegra Owners Club
Spartan Chassis
Join Date: Aug 2021
Location: Spanish Fort, AL
Posts: 7
I have a new relay and connector, but my connector is not wired same as gary.smith and gswindle.
This is how my macerator relay connector is wired....
Heavy gauge orange wire on 87
Heavy gauge red wire on 86
Red jumper between 86 and 30
Purple wire on 85
Can someone please confirm this is correct as wired by entegra?
Attached Thumbnails
Click image for larger version

Name:	IMG_20211015_105540383.jpg
Views:	10
Size:	183.7 KB
ID:	346141   Click image for larger version

Name:	IMG_20211015_110920052.jpg
Views:	8
Size:	161.9 KB
ID:	346142  

robfralev is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-16-2021, 09:22 AM   #44
Senior Member
 
Join Date: Jul 2017
Location: Cypress, Tx.
Posts: 548
If it worked before I would say it is right. You might have a different relay. Looks like small wire when grounded will activate relay
__________________
2014 Foretravel IH45
Houston (Cypress), TX.
Turbojack is offline   Reply With Quote
Old 10-22-2021, 01:32 PM   #45
Junior Member
 
Entegra Owners Club
Spartan Chassis
Join Date: Aug 2021
Location: Spanish Fort, AL
Posts: 7
Gary.Jones
I had to remove the relay connector because it was melted at pin 30, and I destroyed the female disconnect on that wire. No problem, I can connect to the relay with insulated female disconnects. The size 10/12 do not fit the 8 gauge wires for pins 30 and 87. 8 gauge female disconnects are on order. With the coach powered up, I jumpered the red and orange 8 gauge wires. Nothing happened. Also tried this and cycled macerator switch, nothing happened. I have power on the red 8 gauge wire. At this point, I think the macerator is dead. Is there anything else I could try before making a service appt?
Attached Thumbnails
Click image for larger version

Name:	IMG_20211022_123052980.jpg
Views:	7
Size:	191.4 KB
ID:	346880  
__________________
Bob, Carolyn, and Wolfman
2020 Entegra Aspire 42DEQ
No Toad (yet)
robfralev is offline   Reply With Quote
Old 10-23-2021, 09:28 AM   #46
Senior Member
 
Gary.Jones's Avatar


 
Join Date: Oct 2012
Location: Louisiana
Posts: 9,589
Blog Entries: 1
An additional thing that you can try is to use a 12 volt battery or source and try to activate the motor directly from a 12 volt battery where you know it is getting power. If you get no rotation from direct connection to a battery, you can be pretty sure that the motor is fried.

I have had a motor fail and I just replaced the whole motor/plastic housing. Now, after about a year, the motor seems to be OK but there is no pumping action so when I get home from this trip, I am going to have to tear into it again and see what the problem is !

Gary
__________________
Gary and Dee, Zowie and Bowie (traveling cat sibs)
2019 Cornerstone 45B, X15-605hp, Imperial, Spartan K3,
2013 Honda CR-V toad, Demco Excali-Bar II,
Demco Baseplate, Demco Toad Light system, 73 de W5FI
Gary.Jones is offline   Reply With Quote
Old 10-23-2021, 11:18 AM   #47
Senior Member
 
Magic-carpet's Avatar
 
Join Date: Apr 2012
Location: Washington, Pennsylvania
Posts: 1,190
Quote:
Originally Posted by robfralev View Post
Gary.Jones
I had to remove the relay connector because it was melted at pin 30, and I destroyed the female disconnect on that wire. No problem, I can connect to the relay with insulated female disconnects. The size 10/12 do not fit the 8 gauge wires for pins 30 and 87. 8 gauge female disconnects are on order. With the coach powered up, I jumpered the red and orange 8 gauge wires. Nothing happened. Also tried this and cycled macerator switch, nothing happened. I have power on the red 8 gauge wire. At this point, I think the macerator is dead. Is there anything else I could try before making a service appt?
Its probably the internal over temp switch gone bad. If you take the gray wire off the switch and go direct to ground with it and the pump runs when toggled to run, its the over temp switch. (relay will need to be reinstalled correctly to test this) In that case you need to replace the macerator since its integrated into the pump motor. See the document attached. It will help explain the wiring.
__________________
Jeanne & Rosko
2017 Cornerstone 45B
2014 Anthem 44B Classic (traded)
Magic-carpet is offline   Reply With Quote
Reply

Tags
ace, macerator, replace, replacement



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is the macerator relay? kerrvillepil Entegra Owner's Forum 3 10-20-2019 11:32 PM
Macerator Hose Failure DIY Repair Mwillis Entegra Owner's Forum 121 01-21-2017 10:19 AM
Macerator pump failure Victory Blue Entegra Owner's Forum 5 07-23-2016 04:58 PM
Monaco house battery isolator relay delay- failure LJJSRZ Class A Motorhome Discussions 16 02-22-2014 10:47 PM
macerator failure crah Monaco Owner's Forum 26 10-16-2013 10:16 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.