Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-24-2022, 01:03 PM   #1
Member
 
Join Date: Feb 2020
Posts: 52
Onan Gen problem

Hello,

My 10K Onan gen shuts off after 2-3 minutes in my Brand New Entegra Reatta XL. The generator has 1 hour on it! I am getting an overheat code. Anyone ever experience the same issues?
jgperegrine is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-24-2022, 01:39 PM   #2
Senior Member
 
Magic-carpet's Avatar
 
Join Date: Apr 2012
Location: Hilton Head Island, SC
Posts: 1,265
Sounds like you might have an airlock in the coolant or a pinched hose from the reservoir.

https://www.irv2.com/forums/f103/ona...ck-447474.html
__________________
Jeanne & Rosko
2017 Cornerstone 45B
2014 Anthem 44B Classic (traded)
Magic-carpet is offline   Reply With Quote
Old 06-24-2022, 01:46 PM   #3
Member
Official iRV2 Sponsor
 
Join Date: Feb 2021
Posts: 626
Have you tired turning off the breaker and running the genset to verify itís not shutting down due to loads. Whatís the coolant level in the reservoir?
__________________
.
NATIONAL INDOOR RV CENTERS - NIRVC
Sales | Service | Indoor Storage | Wash
Collision Repair & Paint Restoration


SM Nashville 972-697-6325
Bobby Dowdle is offline   Reply With Quote
Old 06-24-2022, 01:52 PM   #4
Senior Member
 
SillyAnn's Avatar
 
Entegra Owners Club
Spartan Chassis
RV Trip Wizard
Join Date: Apr 2012
Location: Webster, FL
Posts: 124
Clamp not tightened enough

This happened to us in our 21 CS. We took it to Cummins, and we were told that a clamp was not tightened enough, probably from the initial build. This allowed the coolant to leak out. I did not see the tech tighten the clamp, but after he tightened it and poured over a half a container of coolant in, our generator runs as it should.
__________________
Paul & Casey Loranger
2021 Entegra Cornerstone 45B
2020 Chevy Silverado, Blue Ox, SMI AF One
SillyAnn is offline   Reply With Quote
Old 06-24-2022, 02:02 PM   #5
Senior Member
 
HarleySG's Avatar
 
Entegra Owners Club
Spartan Chassis
Join Date: Jun 2016
Location: Pine, CO
Posts: 733
By chance, have you checked the oil. I know it sounds strange, but I know of someone that purchased a new coach where the generator did not have the correct amount of oil. If I remember correctly, it was so full of oil, it wouldn't run at all.

Just a thought!
Cheers!!
__________________
Rusty & Pam
2012 Entegra Aspire RBQ
2007 Harley Street Glide
HarleySG is offline   Reply With Quote
Old 06-24-2022, 07:09 PM   #6
Member
 
Join Date: Feb 2020
Posts: 52
Turned out to be air lock in the coolant. I opened the cap (not the holding tank cap) to the system and fluid gushed out. I closed it replenished system and then it ran fine.

Thanks!!!
jgperegrine is offline   Reply With Quote
Old 06-24-2022, 10:23 PM   #7
Senior Member
 
HarleySG's Avatar
 
Entegra Owners Club
Spartan Chassis
Join Date: Jun 2016
Location: Pine, CO
Posts: 733
Quote:
Originally Posted by jgperegrine View Post
Turned out to be air lock in the coolant. I opened the cap (not the holding tank cap) to the system and fluid gushed out. I closed it replenished system and then it ran fine.



Thanks!!!


Nice catch, thanks for the update.
__________________
Rusty & Pam
2012 Entegra Aspire RBQ
2007 Harley Street Glide
HarleySG is offline   Reply With Quote
Old 06-25-2022, 06:39 AM   #8
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 28,338
Quote:
Originally Posted by jgperegrine View Post
Turned out to be air lock in the coolant. I opened the cap (not the holding tank cap) to the system and fluid gushed out. I closed it replenished system and then it ran fine.

Thanks!!!
Good catch Jeanne, also a common problem with the aqua hots on new coaches. Easy to do with 11 gallons of coolant being added and not bleeding the air while being filled. Sounds like it can happen at Cummins as well. Glad it was an easy fix.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 06-27-2022, 12:46 PM   #9
Senior Member
 
philnail's Avatar


 
Entegra Owners Club
Join Date: Aug 2012
Location: Full Time - Most of the time we are lost.
Posts: 711
What is the error code? Is it error 36?
__________________
BBQ-Guy
philnail is offline   Reply With Quote
Reply

Tags
onan, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan 4000 Gen 4KY FA26100J Gen starts then stops (nothing new to this forum). hearnsconst RV Systems & Appliances 2 04-13-2019 12:05 PM
Another GEN (4.0 ONAN) Problem TW iRV2.com General Discussion 9 07-21-2011 05:24 AM
Onan 7500 diesel Gen problem? Hillbillyjoe Class A Motorhome Discussions 7 07-12-2011 03:45 PM
Onan 6.5 emerald series gen problem bjcarpetguy MH-General Discussions & Problems 3 07-10-2009 08:01 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.