RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-24-2013, 05:32 AM   #1
Member
 
Chad K's Avatar
 
Join Date: Nov 2012
Location: Kansas
Posts: 72
Onan Generator Issue

I have just taken delivery of a new 2014 Entegra Anthem. The generator ran for us on our 500 mile trip home and shows total of 48 hours. Now it won't stay running. It starts and shuts down after about 10 seconds. It has been at a Cummins/Onan dealer for a week now. They have tried several different things and still can't get it to run. They keep working with Onan warranty but don't seem to have any idea what is going on. We primarily dry camp so I am very concerned about this situation. It is the 12.5 KW model. Has anyone else had any generator issues. Any suggestions would be much appreciated. Thanks in advance.
Chad K is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-24-2013, 05:48 AM   #2
Senior Member
 
hogdriver's Avatar
 
Entegra Owners Club
Join Date: Jan 2012
Location: Gulf Breeze, FL
Posts: 3,107
My initial thought is a plugged fuel filter. I'm guessing Onan service folks would check that first. On my previous RV I had a diesel Onan and during it's first 50 hrs I had a similar problem and Onan service discovered a loose fuel line clamp that would'nt leak but would let air into the line.

If it isn't fuel, it might be mechanically broken. Those Kubota motors are great, and you rarely hear of one that is bad, but I guess statistically it has to happen.
__________________
Dave & Debbie
2014 Anthem 44B
2018 Ford F-150 Diesel
2016 Ford Edge toad
hogdriver is offline   Reply With Quote
Old 12-24-2013, 05:50 AM   #3
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
Ongoing/Continuing issues like this with the QuietDiesel series of gensets is rare to say the least. While they are very complex units, repairing them is not. I seriously question the techs whom are trying to repair it - it certainly should not take a weeks worth of investigation and troubleshooting. There must be more to the story. What things have they "tried" as you mention above?

It's obviously shutting itself down on an error code of some sort, do you happen to know which error code it was tossing?
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 12-24-2013, 05:58 AM   #4
Member
 
Chad K's Avatar
 
Join Date: Nov 2012
Location: Kansas
Posts: 72
I'm not exactly sure what all they have done. They ordered some sort of circuit board but said that didn't fix it. The code I got was fault 13 which I believe is low voltage. I was expecting a fairly simple fix but not getting that lucky. The tech acts like he has worked on a number of generators but agree with your comments and am getting concerned each time I talk to them.
Chad K is offline   Reply With Quote
Old 12-24-2013, 06:23 AM   #5
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
There are only a few things that will cause the 13 code.

1. Check with them to see which set of batteries are powering the generator - the house batteries or the chassis batteries. Since *most* RV spec'd gensets do not have an internal 12vdc supply (charger) they rely on clean 12VDC from the RV batteries being recharged from the converter (If you have your Model and Serial number I can check to see if yours is so equipped). If the QD sees less than 12.2 volts at it's connection it will shut down with a 13 code.

2. Poor ground to the 12volt system. I have had a few with bad or loose grounds powering the 12v side of the generator where they ground to the frame. In 1 case I ran a new ground from the batteries straight to the unit.

3. There are 3 windings in the alternator/PMA on these units. All 3 need tested to see if any of the 3 have grounded themselves. It is rare, but possible.

4. Just a plain and simple Inverter/Controller replacement. If everything else above checks out then swapping out the controller is probably necessary. They do go bad for no apparent reason sometimes, and generally within their first few weeks of service ;-)
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 12-24-2013, 06:44 AM   #6
Member
 
Chad K's Avatar
 
Join Date: Nov 2012
Location: Kansas
Posts: 72
Thank you for the responses. Hopefully this will help get my RV out of the service shop. The generator info is model RVQD12500. Model 12.5HDKCB-11506F spec F with sn# D130489591. Thanks so much for the help.
__________________
Chad and Nanci
2014 Entegra Anthem 44SL
Chad K is offline   Reply With Quote
Old 12-24-2013, 07:14 AM   #7
Senior Member
 
DSL417's Avatar
 
Entegra Owners Club
Join Date: Sep 2012
Posts: 6,507
Blog Entries: 2
I too am wondering about interaction between the inverter and the generator. Might want to get Ted Cook involved at Entegra...he's their guru on the set up of the inverter in the Entegra coach. One thing I found a while back is that the various CS sections at Entegra, Spartan, and Cummins don't always look at an issue with an integrated and holistic view...working together...

If the issue is being worked just at the technician level at a service shop, these smart folks might not even be involved.
__________________
Dave and Beth
2015 Cornerstone 45J
2020 Ford F-150 Lariat
DSL417 is offline   Reply With Quote
Old 12-24-2013, 09:45 AM   #8
Senior Member
 
pacwest's Avatar
 
Tiffin Owners Club
Entegra Owners Club
Join Date: Aug 2009
Location: Queen Creek, AZ
Posts: 1,136
Quote:
Originally Posted by Chad K View Post
I have just taken delivery of a new 2014 Entegra Anthem. The generator ran for us on our 500 mile trip home and shows total of 48 hours. Now it won't stay running. It starts and shuts down after about 10 seconds. It has been at a Cummins/Onan dealer for a week now. They have tried several different things and still can't get it to run. They keep working with Onan warranty but don't seem to have any idea what is going on. We primarily dry camp so I am very concerned about this situation. It is the 12.5 KW model. Has anyone else had any generator issues. Any suggestions would be much appreciated. Thanks in advance.
We had the exact thing happen to ours. They replaced the fuel pump. I've spoken to at least 4 other Entegra owners who had the fuel pump replaced early on.
pacwest is offline   Reply With Quote
Old 12-24-2013, 09:53 AM   #9
Senior Member
 
brobox's Avatar


 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 24,179
Check with Johnnyreno on this forum. He just had the same problem on his maiden voyage here it FL and had it repaired at Cummins in Ft Myers.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Old 12-24-2013, 10:13 AM   #10
Member
 
Chad K's Avatar
 
Join Date: Nov 2012
Location: Kansas
Posts: 72
When I first reported the issue to Entegra CS, they were thinking maybe the fuel pump and shared that a number of pumps had been replaced. I shared that with the Onan dealer. They "claim" it is not the pump. They are now closed until Thursday. I will share this very valuable info with them. I am starting to wonder what they really have done to repair the generator. Your responses are very much appreciated
Chad K is offline   Reply With Quote
Old 12-24-2013, 10:45 AM   #11
Member
 
Join Date: Sep 2011
Posts: 56
We has something similar. Ours was a relay issue regarding the auto gen. It would run for a few seconds and throw the error code as well. They replaced the control board and a fuse. Now works well.
Jgehrls is offline   Reply With Quote
Old 12-24-2013, 10:49 AM   #12
Member
 
Chad K's Avatar
 
Join Date: Nov 2012
Location: Kansas
Posts: 72
Do you recall if it was a code 13.
__________________
Chad and Nanci
2014 Entegra Anthem 44SL
Chad K is offline   Reply With Quote
Old 12-24-2013, 07:31 PM   #13
Senior Member
 
Entegra Owners Club
Join Date: Oct 2013
Location: Quebec
Posts: 140
2014 Aspire here...

Had the fuel pump replaced under warranty after the generator quit working and wouldnt start afterwards.

Been working troublefree since then...
__________________
- SOLD -
2014 Entegra Aspire 42RBQ
17' Aluminum Car Hauler
JoyalRV is offline   Reply With Quote
Old 12-25-2013, 04:18 PM   #14
Senior Member
 
Twomed's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: On the road
Posts: 1,783
Push the fuel pump issue. A Kubota motor that never gets up to speed will definitely cause the unit to throw a Code 13, which is low or no volts. The book says replace the $1200 board. Since mine was out of warranty I chose to replace the $56 (O'Reilly's vs $186 Onan, same label on the unit) pump. Problem solved.

Good luck...hope you get back on the road quickly.

PS...for when you guys start getting some miles/hours on those pretty new Entegras
Fuel Pump (electric) Airtex E11020 EXACT replacement for Onan 149-2790 or 149-2692 $60-70 and mine lasted 2400 hours, some last 50 hours... when DW says it's hot where's the a/c power...PRICELESS!
__________________
Happy Trails,
06 Dynasty Countess III ISL//3060
07 Hummer H3
Twomed is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.