Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Entegra Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-11-2022, 09:15 AM   #1
Junior Member
 
Jbnewbanks's Avatar
 
Entegra Owners Club
Join Date: Aug 2021
Posts: 28
Thetford Aria II Deluxe flush problems

This has probably been addressed many times before but I am not finding what I want in the search results.
2015 Anthem 44DLQ electric toilet headaches.
It first started when the mechanical valve would not open at all. Did the 12v reset with no success. Tried to turning the manual override valve handle and would not open. Toilet had been very noisy since we acquired the coach in January. Pulled inline fuse, reinstalled fuse it opened and stuck open thankfully. I thought since it manually wouldn't work the gears were worn/failed.
Replaced the motor/valve assembly #19613 and worked erratically (open fully, open partially, not open just motor sounds, etc.). Pulled fuse worked fine opening fully for several flushes then same thing but, it does operate much quieter.
Then cut out 2 old wire butt splices (someone's been in here before) and re-soldered power wire connection to coach wire coming through the floor. No corrosion was found from moisture intrusion but proceeded anyway. Same result.
Replaced controller unit #28968 thinking erratic signal to the valve motor is due to internal fault. Same result.
Only think left I think is the switch but thought I would post before spending more money.
Thanks in advance.
__________________
Brandon & Jill Newbanks Oreana, IL
2015 Entegra Anthem 44 DLQ
Jbnewbanks is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-11-2022, 11:28 AM   #2
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 21,651
Can you MANUALLY open/close it now that you have a new motor/valve assembly?

What happens if you PRESS BOTH buttons down TWICE?
*should open/stay open
***Close by pressing Large Button ONCE

Did you check the harness connection on the Switch when you changed the controller out?


Have you measured DC Voltage to toilet.......minimum of 10VDC ?
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 05-11-2022, 07:06 PM   #3
Junior Member
 
Jbnewbanks's Avatar
 
Entegra Owners Club
Join Date: Aug 2021
Posts: 28
Quote:
Originally Posted by Old-Biscuit View Post
Can you MANUALLY open/close it now that you have a new motor/valve assembly?

What happens if you PRESS BOTH buttons down TWICE?
*should open/stay open
***Close by pressing Large Button ONCE

Did you check the harness connection on the Switch when you changed the controller out?


Have you measured DC Voltage to toilet.......minimum of 10VDC ?
I am able to manually open and close the valve.

When I push both butto s twice the valve opens and stays open then push once and it closed.

I'm not sure how to get the switch of the bowl to check its connection. I'm afraid of breaking it but whith instructions I will do it.

12.82 volts in connector pins at controller.

Thanks for the suggestions. If you can let me know how to check the switch I would appreciate it.
Jbnewbanks is offline   Reply With Quote
Old 05-11-2022, 09:47 PM   #4
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 21,651
Here are the Instruction for switch removal
https://pdxrvwholesale.com/products/...ch-white-28964


Not sure switch is the issue......may just be bad cable connection at switch
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 05-12-2022, 06:59 AM   #5
Senior Member
 
brobox's Avatar
 
Entegra Owners Club
Join Date: Apr 2007
Location: SW FL
Posts: 28,023
Quote:
Originally Posted by Old-Biscuit View Post
Here are the Instruction for switch removal
https://pdxrvwholesale.com/products/...ch-white-28964


Not sure switch is the issue......may just be bad cable connection at switch
Seeing the switch kit you linked and the telephone wire type connection......I have had connection problems with many of those type of connections used on MH's. As soon as I saw that kit, it made sense where to look. I have had those connections fail on the magnum inverter control panel and the communication cable from the Vega Touch to the transfer switch. Good share on the connection of the Aria toilet. I learned something, thank you.
__________________
Chuck in SW FL
Digital 2021 Cornerstone "B"
A "Digital" 2019 Cornerstone "B" Traded
A "Classic" 2014 Anthem 42 RBQ---Sold
brobox is online now   Reply With Quote
Reply

Tags
ems, ford, luxe, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thetford Aria Deluxe flushing problems biloblake iRV2.com General Discussion 5 11-01-2016 08:36 PM
Noisy Thetford toilet Model 19430 Aria Deluxe Low awichman RV Systems & Appliances 3 11-28-2015 10:21 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.