Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Sprinter Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-28-2021, 08:05 PM   #1
Junior Member
 
Join Date: Sep 2013
Posts: 11
12 Volt Charge Line 7 Pin Connector Wayfarer Sprinter Chassis

Hello:

Just purchased a new 2021 Wayfarer 25RW. Plan to flat tow a Honda CRV with RVi Towed Battery Charger on the CRV. It looks as though I am not getting power on the 7 pin connector from the 12 volt charge pin. Does Sprinter wiring supply 12 volt power to the 7 pin connector? If not what is the remedy? IS it something I can handle my self? My RVi Towed Battery Charger blinks Yellow when I make the connection. When I towed the same vehicle set up the came way with my Tiffin Allegro Red it worked fine. Seems like it may be a problem with the Sprinter Chassis Wiring.

Appreciate any and all input as how to handle.

Thanks
dbtravels is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-28-2021, 09:14 PM   #2
Senior Member
 
Winterbagoal's Avatar
 
Join Date: Mar 2017
Location: Sarnialabad, Peoples Republik of Canuckistan
Posts: 1,755
It does on the 2017 chassis. My Blue Ox set up charges the 2016 Wrangler battery via a wire and a 15A fuse, without any troubles.
I'm not familiar with the RVi system. Maybe it's system related?
If it was the Sprinter wiring, I'd expect to see a lot more posts about it.
9/10 it's the actual wiring, or the system you're using doesn't support it.
__________________
All comments are my opinions, and worth exactly what you paid for them.
2018 (2017 Sprinter Cab Chassis) Navion24V + 2016 Wrangler JKU (sold @ ????) - 2016 Sunstar 26HE (sold @ 4600 miles) - 2002 Roadtrek C190P (sold @ 315,000kms)
Winterbagoal is offline   Reply With Quote
Old 04-28-2021, 09:42 PM   #3
Senior Member
 
rarebear.nm's Avatar


 
Excel Owners Club
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2014
Location: Santa Fe, NM
Posts: 4,934
Typically a 7 pin RV connector has 12v hot on the 1:00 pin and ground on the 7:00 position when looking from the rear of the RV. Turn the key to run position or even start the engine. Use a simple multimeter putting the red test probe at 1:00 and the black probe at 7:00. If there is power at the connector you should see 12.x volts on the meter. If there is no voltage shown on the meter then for some reason the connector may have a problem. It could be a blown fuse at the start of that wire under the hood, in a fuse box probably. It could be a damaged wire. It may be that the 1:00 pin does not even have a wire attached to it.

Frankly, if you are asking this question I doubt you have the knowledge and skills to run a hot lead correctly with proper protection installed. I have never looked under a sprinter chassis and thus could not offeror any opinion on the difficulty of the wire routing aspect of the job. Can it be done, most certainly.

I have worked on the 7 pin connectors on several RVs. I find most of them do not have all seven pins wired and/or are miss-wired in some fashion. I wish that RV manufactures would properly wire all seven pins at the factory. But that cost them a few dollars more.
__________________
Fred & Denise (RVM157) New Mexico
2007 Excel Classic 30RSO & Coach House 272XL E450
2007 RAM 3500, Diesel, 6Spd Auto, SWD, 4x4, CC & LB
rarebear.nm is online now   Reply With Quote
Old 04-29-2021, 07:45 AM   #4
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 3,852
Mercedes makes extensive use of the Canbus system in the Sprinter. The 7-way plug is connected to the Canbus and only supplies power when a load is detected. Put your meter on it and you will only get a few volts. Put an actual load on it and you will get the fill twelve volts.

Whether or not this extends to the 12V line is a good question. It did not in my 2017 Navion but I don't know if it does on 2018 and up models.
__________________
Roger & Mary
2017 Winnebago Navion 24V (Sold)
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Old 05-03-2021, 05:15 AM   #5
Senior Member
 
f14av8r's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2010
Location: Tampa Area (sometimes!)
Posts: 560
Quote:
Originally Posted by luvlabs View Post
Mercedes makes extensive use of the Canbus system in the Sprinter. The 7-way plug is connected to the Canbus and only supplies power when a load is detected. Put your meter on it and you will only get a few volts. Put an actual load on it and you will get the fill twelve volts.

Whether or not this extends to the 12V line is a good question. It did not in my 2017 Navion but I don't know if it does on 2018 and up models.
This is the correct answer. You cannot measure voltages using a simple multimeter. It makes checking the connector maddening difficult! As stated, a load has to be present on the pin.

Your 2021RW almost certainly has 12V on the Aux connector. Something else is probably going on down the line. That said, be sure to check the connection up under the coach where the Tiffin extension harness meets the MB chassis connector.

My supplemental brake system gets power from the 7 pin connector just fine - 2020RW.
__________________
Randy and Tina & pups: Cinnamon & Cookie (RIP Coco )
2020 Tiffin Wayfarer RW
Mercedes Benz 2019 Sprinter Chassis
f14av8r is offline   Reply With Quote
Old 05-03-2021, 05:41 AM   #6
Senior Member
 
lass's Avatar
 
Join Date: Sep 2012
Location: Tarpon Springs, Fl.
Posts: 1,409
I installed my RVI charge line last week and it works great. If you have 12 volts at the 1 o’clock position of the 7 pin connector, use your multi meter to find the voltage at the 6 pin end. Mine was at the center pin of the 6 pin and it’s where I connected the positive lead if the RVI.
__________________
2013 Newmar Ventana 3434
2018 Wrangler JLU Rubicon
lass is offline   Reply With Quote
Old 05-03-2021, 07:45 AM   #7
Senior Member
 
Join Date: Mar 2014
Location: Arkansas
Posts: 220
Just a guess and worth a try, turn your lights on the the Sprinter and retest.
Vongreg is offline   Reply With Quote
Old 05-03-2021, 10:07 AM   #8
Senior Member
 
rarebear.nm's Avatar


 
Excel Owners Club
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Aug 2014
Location: Santa Fe, NM
Posts: 4,934
Quote:
Originally Posted by f14av8r View Post
This is the correct answer. You cannot measure voltages using a simple multimeter. It makes checking the connector maddening difficult! As stated, a load has to be present on the pin.

Your 2021RW almost certainly has 12V on the Aux connector. Something else is probably going on down the line. That said, be sure to check the connection up under the coach where the Tiffin extension harness meets the MB chassis connector.

My supplemental brake system gets power from the 7 pin connector just fine - 2020RW.
I don't have a Sprinter or a Canbus system. But for those folks that do have this setup, will someone, who knows for sure how to place a load on the pins and how to test this system?
__________________
Fred & Denise (RVM157) New Mexico
2007 Excel Classic 30RSO & Coach House 272XL E450
2007 RAM 3500, Diesel, 6Spd Auto, SWD, 4x4, CC & LB
rarebear.nm is online now   Reply With Quote
Old 05-03-2021, 10:21 AM   #9
Senior Member
 
Join Date: Jun 2018
Location: Los Angeles area
Posts: 1,109
On an RV that we rented for a weekend (not a Mercedes) the wiring was there but the fuse was missing. Might be worth looking at...

Mike
__________________
Semi-retired technogeek...electronics / computer / 2-way / ham radio... WA6ILQ (45+years)
1985 Fleetwood 32' Southwind (Chev P30/454/TH400), dubbed "Lazarus" by friends... I resurrected it from the dead...
AnotherMike is offline   Reply With Quote
Old 05-12-2021, 07:30 AM   #10
Senior Member
 
Tiffin Owners Club
Winnebago Owners Club
Join Date: Feb 2012
Location: Las Cruces, NM
Posts: 3,852
Quote:
Originally Posted by rarebear.nm View Post
I don't have a Sprinter or a Canbus system. But for those folks that do have this setup, will someone, who knows for sure how to place a load on the pins and how to test this system?
A good old filament 12V bulb works fine. My dealer, when I first bought my Navion, had a test panel that was made up of good old 12v light bulbs.
__________________
Roger & Mary
2017 Winnebago Navion 24V (Sold)
2014 Tiffin Phaeton 36GH (Sold)
luvlabs is offline   Reply With Quote
Reply

Tags
12 volt, chassis, sprinter, sprinter chassis



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse for 12v hot pin on 7 pin trailer connector Brian D Freightliner Motorhome Chassis Forum 4 12-16-2020 07:04 AM
Fuse location for charge line in 7-pin tow connector gary_l Tiffin Owner's Forum 4 10-16-2020 04:28 PM
7-pin connector question-left turn/stop pin wagonmaster2 Freightliner Motorhome Chassis Forum 12 01-01-2012 05:00 PM
7-pin connector question-turn/stop pin wagonmaster2 Winnebago Industries Owner's Forum 25 12-31-2011 07:27 PM
Help-Need pin-out for Scottsdale 6 pin trailer connector park_ridge_dave Newmar Owner's Forum 2 09-07-2009 06:40 PM


All times are GMT -6. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.