Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Sprinter Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-27-2018, 01:54 PM   #1
Junior Member
 
Join Date: Oct 2018
Posts: 25
Mercedes Glow Plugs

I have a 2019 Dynamax Isata 3 24fw motorhome. When I turn the key to start it, the glow plug indicator will only stay on 1 or 2 seconds. We are in the low 20's and from having a Mercedes before, this is not long enough to warm it properly. Unless I am missing something, I would sure appreciate some experience anyone has had with this! Thanks Leonard

My Motto= DO UNTO OTHERS BEFORE THEY DO UNTO YOU!!!!!!!!!!!! ha ha
19fisherman4 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-27-2018, 03:11 PM   #2
Senior Member
 
Winterbagoal's Avatar
 
Join Date: Mar 2017
Location: Sarnialabad, Peoples Republik of Canuckistan
Posts: 1,955
Does it start and run normally after the (shorter?) glow plug warm up interval?
Is this something that has started occurring recently, or has it always been this way?
What does the chassis manual say about it?
__________________
2018 (2017 Sprinter Cab Chassis) Navion24V + 2016 Wrangler JKU (sold @ ????) - 2016 Sunstar 26HE (sold @ 4600 miles) - 2002 Roadtrek C190P (sold @ 315,000kms)
Winterbagoal is offline   Reply With Quote
Old 11-27-2018, 04:48 PM   #3
Junior Member
 
Join Date: Oct 2018
Posts: 25
I the motorhome for 3 weeks so not much history to go on. You did make me think about the fact that it probably ran ok when started up!!! I read the book again and they sure shy away from any length of time except that if it is on a minute or longer, that is not working right.
Thank you for the reply!!!
19fisherman4 is offline   Reply With Quote
Old 11-27-2018, 05:13 PM   #4
Senior Member
 
Winterbagoal's Avatar
 
Join Date: Mar 2017
Location: Sarnialabad, Peoples Republik of Canuckistan
Posts: 1,955
Hardly a technical answer, but sometimes, "if it ain't broke, don't fix it" works.
__________________
2018 (2017 Sprinter Cab Chassis) Navion24V + 2016 Wrangler JKU (sold @ ????) - 2016 Sunstar 26HE (sold @ 4600 miles) - 2002 Roadtrek C190P (sold @ 315,000kms)
Winterbagoal is offline   Reply With Quote
Old 01-01-2019, 02:35 PM   #5
Senior Member
 
smiller's Avatar
 
Join Date: Jul 2011
Posts: 2,124
Modern glow plugs require only a few seconds of heating regardless of ambient temperature and what you are seeing is normal.
smiller is offline   Reply With Quote
Old 01-01-2019, 02:38 PM   #6
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: AB
Posts: 7,587
Yes,
Attached Thumbnails
Click image for larger version

Name:	IMG_0773.JPG
Views:	76
Size:	72.9 KB
ID:	230725  
__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Old 05-07-2019, 10:05 PM   #7
Member
 
Join Date: Aug 2017
Posts: 67
At 20 degrees it shouldn't need glow plugs to start. I have never seen my glow plug lamp on at that temperature other that the short diagnostic flash that you always get. Tier 4 engines regardless of brand should start with out extra heat at much colder temps.
pfm41 is offline   Reply With Quote
Old 05-12-2019, 12:14 PM   #8
Senior Member
 
milkman55's Avatar
 
Join Date: May 2013
Location: Canyon Lake, TX
Posts: 208
The lamp comes on to tell you to wait until it goes off before you crank. Mine only stays on 2-3 seconds in warm So TX. It never fails to start once the light goes off.
__________________
2021 Dynamax Isata 5 30FW
2014 Honda CR-V
(Formerly 2017 Isata 3 24FW)
milkman55 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poli Glow vrs Mop n Glow jbesdale Class A Motorhome Discussions 37 11-29-2015 07:27 AM
Glow plugs kb9adw Winnebago Industries Owner's Forum 7 10-22-2014 12:19 PM
Glow plugs freedumb42 Caterpillar Engine Forum 2 07-20-2014 04:45 PM
Onan hdcaa diesel 10kwh glow plugs ? bmace Monaco Owner's Forum 6 06-27-2012 05:18 PM
Changing Glow Plugs baja iRV2.com General Discussion 3 08-29-2010 10:53 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.