Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE CHASSIS CLUB FORUMS > Sprinter Chassis Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-06-2021, 02:46 PM   #1
Senior Member
 
Join Date: Mar 2004
Posts: 257
Rear Parking Light Issue

The lower passenger side parking lamp on my 2016 Sprinter chassis comes on and then turns off after a second or so. Sometimes it sits for 10 seconds and repeats the light show. I tried a new bulb with the same result. I checked the socket and it is getting 12 volts but when I checked the upper lamp it shows 3.3 volts and is much dimmer. The bulb stopped it's flashing routine and now I have -.03 volts on the socket. Does it make any sense that the plastic lamp holding assembly has some circuitry inside it that has gone south?
__________________
Dave
2018 Era 170A
magicbus is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-06-2021, 10:25 PM   #2
Senior Member
 
AudiDudi's Avatar
 
Join Date: Jun 2017
Location: Western Montana
Posts: 831
Check for water in the hitch if you have one and check the Curt controller. Look for water in the wiring.
__________________
Mike & JoAnne
Montana Summer / Arizona Winter
'16 Prism 24G / '02 HitchHiker 38 LKTG
AudiDudi is offline   Reply With Quote
Old 07-07-2021, 06:35 AM   #3
Senior Member
 
Join Date: Mar 2004
Posts: 257
Thanks for the ideas, but it has been in my barn since early April so I know it is dry. That and the fact that the upper lamp works fine and the two should work in concert make me suspect there is something in the assembly that should lower the voltage on the bulbs and it has failed on the lower circuit. I found a new assembly for $90 so I'm going to give that a try.
__________________
Dave
2018 Era 170A
magicbus is offline   Reply With Quote
Old 07-15-2021, 05:04 PM   #4
Senior Member
 
Join Date: Mar 2004
Posts: 257
In case anyone ever runs into flaky tail lamps, I picked up a replacement tail light assembly for ~$80 and it works great. Apparently there are some electronics within the assembly that can go bad. Inexpensive and easy fix.
__________________
Dave
2018 Era 170A
magicbus is offline   Reply With Quote
Old 07-16-2021, 09:52 AM   #5
Junior Member
 
Join Date: Jun 2019
Posts: 5
Where did you get the tail lamp assembly from?
Heffy is offline   Reply With Quote
Old 07-16-2021, 02:28 PM   #6
Senior Member
 
Join Date: Mar 2004
Posts: 257
Quote:
Originally Posted by Heffy View Post
Where did you get the tail lamp assembly from?
From here: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1


It came complete with bulbs and the little mounting studs that sometimes break or fly off and disappear when you take the assembly off the Sprinter.
__________________
Dave
2018 Era 170A
magicbus is offline   Reply With Quote
Reply

Tags
light, parking, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parking Brake Light Issue chuckbear MH-General Discussions & Problems 5 03-20-2017 02:08 AM
Parking brake light, brake reserve light Sanford Ford Motorhome Chassis Forum 7 07-29-2016 03:35 PM
rear parking light question geo59wilson Workhorse and Chevrolet Chassis Motorhome Forum 2 12-24-2012 10:16 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.