Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Thor Industries Owner's Forum > Palazzo Motorhomes
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-09-2021, 11:21 AM   #1
Senior Member
 
Join Date: Apr 2016
Posts: 240
Water heater burning continuously

2014 Thor Palazzo 36.1 with an Atwood GC10A-4E water heater.

While on propane, the water heater burns continuously and doesnít seem to shut off.

Any quick things to check before I have it replaced?
__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-09-2021, 11:36 AM   #2
Senior Member
 
OldWEB's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Sep 2018
Posts: 268
With a cold tank, ours burns for maybe 20-30 min before shutting down. There is no adjustable thermostat, but the water is hot.
You said "doesn’t seem to shut off", well does it or not? Maybe you do not wait long enough?

I would suspect that if it would not shut off, the overload (ECO switch) would open to shut it down and/or the pressure relief would be steaming.
OldWEB is offline   Reply With Quote
Old 06-09-2021, 11:40 AM   #3
Senior Member
 
Join Date: Nov 2015
Posts: 16,356
How long is continuously??

If T-stat is NOT held tight against tank wall then higher temps will occur before it opens (preset at 140*F)
If it doesn't open then temps will increase until the ECO (High temp t-stat) opens at 180*F
If ECO fails to open and temps continue to rise then the T&P Relief Valve will POP Open at 210*F/150 PSI


So how long is propane burning....20 minutes, 1 hour etc

How HOT is the water at faucet?

LOW LP System Pressure will cause Low Flame Temp
Low flame Temp...lack of Heat transfer
Lack of heat transfer.......longer time to heat water
LP System 11"WC (0.4psi)
10"WC (0.36 psi) and visually will LOOK the same but BIG difference in flame temps/heat generated.
LP System PSI check should be done with Manometer and 59% of Appliances ON



FYI: IF it is a T-stat, loose wires/connections issue the same Long time to heat would happen using the Electric Element
Same set of t-stat/ECO, controls etc for Gas & Electric on your model
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-09-2021, 12:00 PM   #4
Senior Member
 
Join Date: Apr 2016
Posts: 240
I had water coming out of the valve so I shut it off.

I had not started a stopwatch so I donít know exactly how long it was running.
Attached Thumbnails
Click image for larger version

Name:	DB969FDD-D889-4C31-85D5-88A6E78F391A.jpeg
Views:	3
Size:	162.7 KB
ID:	331507  
__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Old 06-09-2021, 12:11 PM   #5
Senior Member
 
Join Date: Nov 2015
Posts: 16,356
Water weeping from T&P could be from overheating
BUT could also be from Loss of Air Pocket at top of WH Tank

So how HOT is the water?

**Both t-stat/eco failing to open would be very very rare occurrence but that is what the T&P is for

Did you check the t-stat & ECO tightness to tank, check terminal/spade connections, check them out at all?
Have you tried it on Electric?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-09-2021, 02:41 PM   #6
Senior Member
 
Join Date: Apr 2016
Posts: 240
180 degrees and climbing. I shut it off. Probably thermostat?
__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Old 06-09-2021, 06:53 PM   #7
Senior Member
 
Join Date: Nov 2015
Posts: 16,356
Quote:
Originally Posted by just_cruisin View Post
180 degrees and climbing. I shut it off. Probably thermostat?
Both t-stat and ECO are NOT opening
Either due to NOT being held tight against tank wall or bad wire connections etc

Either case.buy new set
Clean spade connectors and tank wall then install the new set


Atwood 91447
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-09-2021, 08:20 PM   #8
Senior Member
 
OldWEB's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Sep 2018
Posts: 268
just_cruisin, could you check the 'lectric part of the heater? My thoughts are the control board being 'locked on'; but I am curious if that also affects the element too.
OldWEB is offline   Reply With Quote
Old 06-09-2021, 09:05 PM   #9
Senior Member
 
Join Date: Nov 2011
Posts: 214
Quote:
Originally Posted by just_cruisin View Post
2014 Thor Palazzo 36.1 with an Atwood GC10A-4E water heater.

While on propane, the water heater burns continuously and doesn’t seem to shut off.

Any quick things to check before I have it replaced?

You should have a schematic and parts diagram for this water heater. It should be in all that wonderful documentation that came with your RV. That is, if you purchased your RV new. On it you should find a fixed temperature thermostat. That sound like the part to check. You reach temperature, but fail to turn off. Then go on form there.
__________________
Marc
2013 Thor Palazzo 33.2
2013 Honda CRV
mlpeloquin is offline   Reply With Quote
Old 06-09-2021, 10:16 PM   #10
Senior Member
 
Join Date: Nov 2015
Posts: 16,356
Atwood Wiring Diagram for Combo Units since 2004
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-09-2021, 10:19 PM   #11
Senior Member
 
Join Date: Nov 2015
Posts: 16,356
Quote:
Originally Posted by OldWEB View Post
just_cruisin, could you check the 'lectric part of the heater? My thoughts are the control board being 'locked on'; but I am curious if that also affects the element too.
OPs model uses One Set Of t-stat/ECO for gas & Electric
12VDC Controls

T-stat Opening (Or ECO if T-stat fails) stops DC ...no heating can occur even if Circuit Board is 'locked on'

Heating NOT shutting off...bad set of t-stat/ECO especially with 180*F temp and climbing
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-10-2021, 06:32 AM   #12
Senior Member
 
OldWEB's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Sep 2018
Posts: 268
Quote:
Originally Posted by Old-Biscuit View Post
OPs model uses One Set Of t-stat/ECO for gas & Electric
12VDC Controls

T-stat Opening (Or ECO if T-stat fails) stops DC ...no heating can occur even if Circuit Board is 'locked on'

Heating NOT shutting off...bad set of t-stat/ECO especially with 180*F temp and climbing
DOH!!
I had looked at the diagram and I still said that!
So sorry, I was having a 'blonde' moment I guess.

So to test the gas valve, the OP should turn on the WH and then if the gas fires up, pull the wire off the ECO sw., that will shut down the flame.
OldWEB is offline   Reply With Quote
Old 06-10-2021, 06:36 PM   #13
Senior Member
 
Join Date: Apr 2016
Posts: 240
Thanks everyone.

I have a new T stat on the way.
__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Old 06-14-2021, 04:55 PM   #14
Senior Member
 
Join Date: Apr 2016
Posts: 240
Replaced both tstats, still get water weeping out of relief valve.
__________________
2014 Thor Palazzo 36.1
just_cruisin is offline   Reply With Quote
Reply

Tags
heat, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keeping water heater on continuously RFisher Travel Trailer Discussion 19 10-17-2019 06:52 AM
Do you run MH water heater continuously? Benderdan MH-General Discussions & Problems 42 12-20-2017 04:23 PM
Water pump runs continuously KonaMan Travel Trailer Discussion 10 10-21-2016 11:15 AM
Water Pump cycles on continuously AUTiger2NC RV Systems & Appliances 11 12-03-2015 11:36 AM
Water Pump Running (almost) Continuously Brghrt4 MH-General Discussions & Problems 19 12-21-2010 08:52 PM


All times are GMT -6. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.