RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Outdoors RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2020, 10:38 AM   #1
Senior Member
 
Join Date: Aug 2019
Location: Mill Creek, WA
Posts: 192
New Suburban Oven Won't Stay Lit

Picked up our new 280KVS from Apache RV in Everett last week and performing our shakeout testing in our driveway at home. Discovered an issue with the oven that we didn't find during our pre-delivery inspection, probably because we didn't leave the oven on long enough. I'm about to call Apache but wanted to see if any of the experts here have suggestions about something I may have missed.

Here's the issue (see the short video):
https://youtu.be/OVqJ6LrnkxE

* It seems difficult to light the pilot, but once lit it stays lit OK
* After the oven has been lit for several minutes, the pilot flame begins to "sputter" and eventually dies, shutting the gas valve and killing the burner flame.

So far I've made sure that the oven is the only propane appliance that's on. The stovetop burners work fine, so I'm pretty sure the gas lines are well-purged. I've also tried switching to the other propane tank, and they're still essentially full.

Thanks for any suggestions you may have!
__________________

__________________
Black Stone 280KVS Titanium
litzdog911 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-20-2020, 10:54 AM   #2
Senior Member
 
Outdoors RV Owners Club
Join Date: Mar 2016
Posts: 840
This is a great post, with the video it really helps to see what the problem is. Unfortunately I don't have any possible solutions other than maybe the thermocouple is bad and/or it is too far away from the pilot flame.
__________________

__________________
2019 Outdoors RV Timber Ridge 27 bhs
2017 Ram Cummins 2500
Soggy side of Oregon
Off Road is offline   Reply With Quote
Old 05-20-2020, 10:59 AM   #3
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 1,836
Have you tried just keeping the pilot lit for and extended period, without turning on the main burner, to see if it sputters and goes out? If it still goes out, I'd suspect an issue with the valve and/or plumbing to the pilot. Clearly, you get good flow at the outset, but the sputtering is to the pilot so the plumbing to that is suspect. Could be a bit of debris in the orifice or pipe. I don't think there is an electronic controls for the pilot, just for the main burner via the thermocouple.


Here is a link to someone who had the exact problem. Not sure if the solution worked, however. https://www.rv.net/forum/index.cfm/f...d/28916336.cfm


Another similar thread. https://www.mygrandrv.com/forum/show...0%99t-stay-lit


It talks about an adjustment for the pilot flame by a small screw on the main control valve, or a control valve replacement. Yours is under warranty so it should be a dealer fix.
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is offline   Reply With Quote
Old 05-20-2020, 11:14 AM   #4
Member
 
Join Date: Dec 2019
Posts: 82
First, Congrat's on finally getting your trailer!

The clue in this is that it takes a lot of heat to cause the problem.

This guy had the same problem. After watching what looks like your video at the start, jump to about 3:30 for the punch line.


__________________
2017 Outdoors RV 26RLS
2015 F350 6.7L
bob26rls is offline   Reply With Quote
Old 05-22-2020, 07:51 AM   #5
Member
 
volks1963's Avatar
 
Join Date: Nov 2017
Location: Sparks NV
Posts: 84
Had the same problem with our stove. Could light the pilot light and it would stay burning. Then turn the oven knob open to start the oven. Would run for a while and then go out. We were up in Oregon and had a service call in with one of the local dealers. They came out and replaced one of the jets and our problems have been solved ever since.
We paid for the service call but the part was covered under warranty.
__________________
2006 GMC 2500HD 4WD 8.1
2018 Outdoors RV Creekside 21RBS
volks1963 is offline   Reply With Quote
Old 05-22-2020, 06:31 PM   #6
Senior Member
 
Join Date: Aug 2019
Location: Mill Creek, WA
Posts: 192
It's fixed!
The video that @bob26rls posted was the key. Apache provided me with the replacement pilot tube assembly (Suburban #161298). Had the oven lit for over an hour this afternoon with no sputtering. Will try baking something this weekend.
__________________
Black Stone 280KVS Titanium
litzdog911 is offline   Reply With Quote
Old 05-25-2020, 12:09 PM   #7
Member
 
Join Date: Dec 2019
Posts: 82
Quote:
Originally Posted by litzdog911 View Post
It's fixed!
The video that @bob26rls posted was the key. Apache provided me with the replacement pilot tube assembly (Suburban #161298). Had the oven lit for over an hour this afternoon with no sputtering. Will try baking something this weekend.
I'm glad the fix was simple. You prompted me to test my oven, as I have never let it run for any length of time.

I went up to the trailer yesterday to start installing the TPMS repeater. While I was there I let the oven run for an hour. It works great! I didn't bake anything though, so nothing to share.
__________________

__________________
2017 Outdoors RV 26RLS
2015 F350 6.7L
bob26rls is offline   Reply With Quote
Reply

Tags
suburban



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suburban SW6D water heater wonít stay lit (with solution) VerboortTech MH-General Discussions & Problems 8 07-08-2019 07:05 PM
Suburban sw6d water heater won't stay lit CdnCruiser RV Systems & Appliances 6 04-18-2014 10:19 AM
Atwood oven in my keystone will not stay lit. Pilot lights ,but the oven will not joe48c Pop Up, Tent Trailer and Teardrop Topics 4 07-21-2012 09:08 AM
Suburban WH won't stay lit MojaveJoe RV Systems & Appliances 7 02-23-2010 12:16 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×