Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Outdoors RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-09-2021, 05:12 AM   #1
Senior Member
 
Outdoors RV Owners Club
Join Date: Oct 2017
Location: Was Minnesota now ???
Posts: 138
Water pump issue

We got to Minnesota indirectly from Florida around the 1st of June. We used the bathroom during fuel stops and the water pump worked fine. I decided it was time to sanitize the water system while here so I filled the fresh tank with diluted bleach water, drained the city water from the system and turned on the pump to fill everything with the chlorinated water. Nothing happened. With the switch on I felt the pump motor and it's running but I am getting nothing from the impeller. Before I try to worm my way in there to remove the pump is there anything else to check?
__________________
2018 Glacier Peak F30RLS
YoungSteven is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-09-2021, 07:49 AM   #2
Member
 
CosmikDebris's Avatar
 
Join Date: Oct 2019
Location: Florence, MT
Posts: 99
When you drained the city water, I assume you opened the low point drains. Did you close them?
CosmikDebris is offline   Reply With Quote
Old 06-09-2021, 08:00 AM   #3
Senior Member
 
Outdoors RV Owners Club
Join Date: Oct 2017
Location: Was Minnesota now ???
Posts: 138
Yes but thanks
__________________
2018 Glacier Peak F30RLS
YoungSteven is offline   Reply With Quote
Old 06-09-2021, 08:36 AM   #4
Senior Member
 
egwilly's Avatar
 
Outdoors RV Owners Club
Join Date: Jul 2012
Location: So Calif
Posts: 3,093
Did you drain the water heater? It might be filling that first before you see pressure at the faucets.

I see no reason your pump would fail just because you drained the system. It might have an air lock too. Connect a city water hose and start the prime that way.
Once connected and water running, turn on the water pump to prime it.

Good luck!
__________________
Outdoors RV Glacier Peak 26RLS Fifth Wheel
Ford F350 Superduty 6.7 Powerstroke
“Stick around please...I may need someone to blame.”
egwilly is offline   Reply With Quote
Old 06-09-2021, 02:41 PM   #5
Senior Member
 
Outdoors RV Owners Club
Join Date: Oct 2017
Location: Was Minnesota now ???
Posts: 138
I'm hooked up to city water and everything works- including the water heater. I guess I'm trying to figure out how to "push" some water through the pump in the event it's air-locked.
__________________
2018 Glacier Peak F30RLS
YoungSteven is offline   Reply With Quote
Old 06-09-2021, 02:50 PM   #6
Senior Member
 
jacwjames's Avatar
 
Monaco Owners Club
Join Date: Jun 2014
Posts: 9,017
If you have a valve that switches from shore to tank fill if it is in the tank fill position the pump will run but only recirculate the water to the tank. Ask me how I know
__________________
Jim J
2002 Monaco Windsor 38 PKD Cummins ISC 350 8.3L
2005 Jeep Grand Cherokee w/5.7 Hemi
jacwjames is online now   Reply With Quote
Old 06-10-2021, 11:38 AM   #7
Senior Member
 
Outdoors RV Owners Club
Join Date: Oct 2017
Location: Was Minnesota now ???
Posts: 138
Water pump fuse

Does anyone know where the inline fuse is for the water pump? GP30RLS.
__________________
2018 Glacier Peak F30RLS
YoungSteven is offline   Reply With Quote
Old 06-10-2021, 12:01 PM   #8
Senior Member
 
Join Date: Jul 2015
Location: Watertown NY USA
Posts: 4,262
Quote:
Originally Posted by YoungSteven View Post
Does anyone know where the inline fuse is for the water pump? GP30RLS.
If you felt the pump running the fuse must be OK.
Sounds like a bad impeller to me. With water in the tank the pump should be self priming.
__________________
2002 Fleetwood Storm 30H on Workhorse P32 chassis 8.1 gas.
LETMGROW is offline   Reply With Quote
Old 06-10-2021, 12:27 PM   #9
Member
 
CosmikDebris's Avatar
 
Join Date: Oct 2019
Location: Florence, MT
Posts: 99
Is there a valve and short hose for getting antifreeze into the pump? I've used that to prime it. Just use a gallon jug of water or water\bleach mix. Once it grabs throw valve back to tank.
CosmikDebris is offline   Reply With Quote
Old 06-10-2021, 12:30 PM   #10
Senior Member
 
Join Date: Oct 2014
Posts: 3,001
Also, when purging air from the lines, be sure there is an open faucet.


Much easier for the pump to prime that way.
__________________
Brett Wolfe
Ex: 2003 Alpine 38FDDS. Ex: 1997 Safari Sahara. Ex: 1993 Foretravel U240
wolfe10 is offline   Reply With Quote
Old 06-10-2021, 04:44 PM   #11
Senior Member
 
egwilly's Avatar
 
Outdoors RV Owners Club
Join Date: Jul 2012
Location: So Calif
Posts: 3,093
My line to add antifreeze is attached to the water pump plumbing with a T and laying on the water pump bay floor. The valve is there as well.

Unless you ran the pump for hours with no water circulating, the impeller should not be the issue.
__________________
Outdoors RV Glacier Peak 26RLS Fifth Wheel
Ford F350 Superduty 6.7 Powerstroke
“Stick around please...I may need someone to blame.”
egwilly is offline   Reply With Quote
Old 06-12-2021, 05:20 AM   #12
Senior Member
 
Outdoors RV Owners Club
Join Date: Oct 2017
Location: Was Minnesota now ???
Posts: 138
PERFECT SOLUTION!!! Primed it through antifreeze connection and the pump took off like a race horse! Thanks E.G.Willy from SR Willy!
__________________
2018 Glacier Peak F30RLS
YoungSteven is offline   Reply With Quote
Old 06-14-2021, 06:44 AM   #13
Junior Member
 
Join Date: Jun 2020
Posts: 2
Posting this here in case someone else is diagnosing a similar issue:

I had a similar problem this spring. Turns out the problem was a seized check valve in the pump. I have to break it free by pressing the check valve open with a screw driver.
Crupshaw is offline   Reply With Quote
Reply

Tags
pump, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8.1 Water Pump Poll: How Long Did Your Original Water Pump Last? ktoutoor Workhorse and Chevrolet Chassis Motorhome Forum 50 09-11-2019 05:45 AM
12 volt water pump won't pump water Shoemaker Monaco Owner's Forum 9 06-15-2017 07:59 AM
Water Pump On? Water Pump off? SpaceNorman iRV2.com General Discussion 21 04-12-2015 07:04 PM
water pump hums but doesn't pump water msg1951 RV Systems & Appliances 2 04-12-2013 04:36 PM
Water Pump won't pump water zzjea RV Systems & Appliances 4 03-06-2012 04:07 AM


All times are GMT -6. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.