Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > TRAVEL TRAILER, 5th WHEEL & TRUCK CAMPER FORUMS > 5th Wheel Discussion
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-03-2022, 12:19 PM   #1
Member
 
Winnebago Owners Club
Join Date: Mar 2017
Posts: 38
Tecma Silence plus toilet

Like I stated previously, We are newbies to the 5th family. We are currently in South Carolina where the temps are reaching triple digits and our main breaker tripped twice. Manage to direct a fan on the box and seems to be working better now. Problem is, when I reset the power the rear toilet stopped discharging the contents of the bowl. Wall switch is working and the inlet water is also working, but there is no discharge pump to empty. Looking for breaker , fuse etc in an attempt to see if that has popped to inhibit the pump from engaging. Any ideas. We need all the help we can get.
BobbyBa is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-03-2022, 12:27 PM   #2
Senior Member
 
Holiday Rambler Owners Club
Join Date: Sep 2013
Location: Phoenix,Az
Posts: 446
Just my .02, but maybe when you reset the master the individual one for the Tecma popped. You might try and reset all the indiv. breakers
__________________
2009 Holiday Rambler Navigator
2020 GMC Denali 3500 SRW
Now shopping 5th Wheels
RVNewbie55 is offline   Reply With Quote
Old 07-04-2022, 02:47 PM   #3
Member
 
Winnebago Owners Club
Join Date: Mar 2017
Posts: 38
Quote:
Originally Posted by RVNewbie55 View Post
Just my .02, but maybe when you reset the master the individual one for the Tecma popped. You might try and reset all the indiv. breakers


Thanks for your response. I reset main breaker and others. I am use to have a dedicated breaker for most everything. There in NOT a breaker labeled for either toilets or bathrooms for that matter. I would think the toilets would have a dedicated breaker assigned to them.
Still looking for help.
BobbyBa is offline   Reply With Quote
Old 07-04-2022, 03:47 PM   #4
Member
 
Winnebago Owners Club
Join Date: Mar 2017
Posts: 38
Quote:
Originally Posted by BobbyBa View Post
Thanks for your response. I reset main breaker and others. I am use to have a dedicated breaker for most everything. There in NOT a breaker labeled for either toilets or bathrooms for that matter. I would think the toilets would have a dedicated breaker assigned to them.
Still looking for help.


To further indicate our issue, the water comes into the toilet fine, then the outlet pump and macerated never engage. Strange I know.
BobbyBa is offline   Reply With Quote
Old 07-04-2022, 04:16 PM   #5
Community Administrator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 14,940
I have seen some builds where there is an inline fuse close to the house batteries for the toilet.
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 07-04-2022, 08:45 PM   #6
NXR
Senior Member
 
NXR's Avatar
 
Join Date: Mar 2019
Posts: 3,625
Tecma Silence plus toilet

Quote:
Originally Posted by BobbyBa
To further indicate our issue, the water comes into the toilet fine, then the outlet pump and macerated never engage. Strange I know.

Not at all. Mine did that near the end of the warranty.

There's only one power wire to that thing. I removed the two side screws and also an access panel behind the toilet seat. Then I could pull the toilet slightly forward to reach stuff.

I removed the plug from the water inlet valve to keep from adding water when I did test flushes. I located the pump/macerator motor connector and saw it indeed had 12 volts to it when doing a test flush but the pump just did not turn.

I unplugged it and put an ohmmeter on the part going to the motor. It should be about 2 ohms but it was infinite. Oops...

Thinking it might be a problem with a motor brush not making contact with the armature, I took the handle of a screwdriver and gave the pump a few raps.

Lo and behold, the resistance now showed about 2 ohms. I connected the motor and a test flush worked. I then reconnected the water inlet valve.

The toilet kept working until we relocated. Then I had to rap it again. Once we got home I had the toilet replaced under warranty.

Ray
__________________
2020 Forest River Georgetown GT5 34H5
NXR is offline   Reply With Quote
Old 07-05-2022, 06:11 AM   #7
NXR
Senior Member
 
NXR's Avatar
 
Join Date: Mar 2019
Posts: 3,625
Oh, and in case you need to travel with the toilet not being able to flush, here's what I did:

I took a one gallon water jug and cut the top off, but leaving the handle section intact.

I put a pair of nitrile gloves on and used a Solo cup to bail as much of the toilet as I could from the toilet into the one gallon jug.

I then did the usual glove doff procedure of pulling the wrist down to turn one glove inside out and placed it in the palm of the still-gloved hand. Then I doffed that glove and tossed both into the trash.

Then I simply poured the one gallon jug into the outside sewer connection and disposed of the jug in the trash.

Since the toilet was not completely empty I put Saran Wrap over the bowl to contain any sloshing from rough roads.

Yes, ours failed on the morning we were leaving after a two-month stay because of course it did...

Ray
__________________
2020 Forest River Georgetown GT5 34H5
NXR is offline   Reply With Quote
Reply

Tags
ecm, tecma, toilet



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thetford Tecma Silence Plus 2G Macerator Toilet kvonfeldt iRV2.com General Discussion 2 08-01-2021 08:08 PM
My Thetford Tecma silence plus Toilet drains tomd85208 Monaco Owner's Forum 2 07-12-2014 07:57 PM
No Water into Tecma Silence Plus Toilet ChrisKW Class A Motorhome Discussions 3 01-20-2014 10:44 PM
tecma silence plus problem Pattijr New Member Check-In 9 01-15-2013 04:48 PM
Tecma silence plus toilet a johnson Fleetwood Owner's Forum 2 06-17-2012 05:40 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.