Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > Gear and Product Discussions
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2019, 07:48 PM   #1
Senior Member
 
Heating man's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2012
Location: Indianapolis, IN
Posts: 274
Reviews of RVI tire patrol tire pressure monior

I was wondering if any other members have purchased this tire pressure monitoring system. I have this system which I purchased at the FMCA family reunion in Perry Georgia in 2018. I have not had much luck with mine seems like every time I try to use it it does not work. They replaced the sensors once but I still have problems with it.
__________________
2004 Itasca Horizon 40AD caterpillar C7 engine 350 HP with 2016 Smart car toad
Heating man is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-24-2019, 09:18 AM   #2
Member
 
Glenn2's Avatar
 
Join Date: Mar 2017
Location: College Station, TX
Posts: 65
The early (Oct. 2017) RVI Tire Patrol sensors were difficult to pair and RVI replaced them three time over a two year period. Each time with the lastest and greatest version. I had decided to go with the TST sensors. RVI sent me their new version hub (2019) and a new set of sensors and the pairing went well. I hope they continue to work.
I use TST on my MH and RVI 3 brake and tire sensors on my toad.
__________________
2017 Thor Challenger 37YT
Glenn2 is offline   Reply With Quote
Old 06-24-2019, 10:53 AM   #3
Member
 
Dov327's Avatar
 
Join Date: Jun 2015
Location: Florida
Posts: 58
RVI System

I bought the RVI3 brake unit and the TPMS for the toad. The brake controller works great. The tablet, hub and TPMS are junk. Tablet is so slow and it hangs up. The TPMS could never get to 100% link or stay linked. The hub stopped working so now nothing will link to the tablet. 100 bucks to replace the HUB. I'l pass.. Just using the brake controller and the rest of system is in the closet.
Dov327 is offline   Reply With Quote
Old 06-24-2019, 03:55 PM   #4
Senior Member
 
Airboss68's Avatar
 
American Coach Owners Club
Join Date: Jun 2018
Location: SD
Posts: 858
Mine works great, pairs quickly, all tires (toad and RV) come up quickly.

Brakes work great. Level indicator works great.
No problems so far.
__________________
2015 American Eagle 45B
2004 Travel Supreme 45 Select DSO4
2021 Winnebago View
Airboss68 is offline   Reply With Quote
Old 06-25-2019, 06:31 AM   #5
Senior Member
 
bydnar's Avatar
 
Join Date: Oct 2015
Location: Portage, MI
Posts: 400
Heating man...I would encourage you to continue to work with RVi tech service. My experience has been very good with the people there. Yes, the system has had some start-up issues. Oh, how I know. I've spent a lot of time with their support staff and waiting for replacement units. The last iteration was early 2019. I had all 10 sensors operational without fault for an entire trip from Arizona back to Michigan. My only hope now is that the next time I put the system back in service, everything will be OK. fingers crossed.
__________________
Randy & Karin B, Portage, MI
2017 Newmar Ventana LE 4037 & 2021 Chevy Trailblazer
bydnar is offline   Reply With Quote
Old 06-26-2019, 10:47 AM   #6
Senior Member
 
Heating man's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2012
Location: Indianapolis, IN
Posts: 274
Quote:
Originally Posted by bydnar View Post
Heating man...I would encourage you to continue to work with RVi tech service. My experience has been very good with the people there. Yes, the system has had some start-up issues. Oh, how I know. I've spent a lot of time with their support staff and waiting for replacement units. The last iteration was early 2019. I had all 10 sensors operational without fault for an entire trip from Arizona back to Michigan. My only hope now is that the next time I put the system back in service, everything will be OK. fingers crossed.
I agree with you their tech support is good and they try to help. They sent me all new wheel sensors but I continued to have problem. We traveled several months this winter and it was very slow to hook up to the sensors and usually was not ready when I was ready to leave the campground in the morning. I wrote them a letter and I have not had much luck with getting my problems solved. I have their original brake system and I have had no problems with that.
__________________
2004 Itasca Horizon 40AD caterpillar C7 engine 350 HP with 2016 Smart car toad
Heating man is offline   Reply With Quote
Old 06-26-2019, 12:02 PM   #7
Senior Member
 
Airboss68's Avatar
 
American Coach Owners Club
Join Date: Jun 2018
Location: SD
Posts: 858
Quote:
it was very slow to hook up to the sensors and usually was not ready when I was ready to leave the campground in the morning.
First thing I do on our departure days is fire up the hub and tablet with the hub in the rear of the coach.

Takes about 10 minutes for all the tires to show up. Brake unit shows up almost instantly when I plug it in to power. Works much more quickly since I installed the current update but I think the limiting factor is the TPMS sensors only fire every 7 minutes or so when setting still.
__________________
2015 American Eagle 45B
2004 Travel Supreme 45 Select DSO4
2021 Winnebago View
Airboss68 is offline   Reply With Quote
Old 06-26-2019, 08:10 PM   #8
Senior Member
 
texoz's Avatar
 
Join Date: Aug 2017
Posts: 117
I have the brake and tpms. Like others, sensor issues over the last two years but tech support is outstanding and always replacing and improving at no cost to me.
texoz is offline   Reply With Quote
Old 06-26-2019, 08:22 PM   #9
Member
 
Entegra Owners Club
Join Date: Jan 2012
Location: East Tennessee
Posts: 77
I purchased the system at FMCA Perry in 2018. I had considerable trouble getting all the sensors to work correctly throughout 2018, despite having all new sensors sent to me several times. Finally the last set of sensors they sent me (I think it was sometime between this past November and February) solved the problem, and the system has worked flawlessly since. RVI customer support is excellent, and I am a happy customer.
__________________
Ron, Lydia & Crosby The Basset
2017 Entegra Aspire 44B
2019 Ram 1500 Limited
RLH241 is offline   Reply With Quote
Old 07-05-2019, 11:52 AM   #10
Junior Member
 
Join Date: Jul 2019
Location: Louisiana
Posts: 7
No comment on the TPMS but I can vouch for the excellent customer support. I have the RVi3 brake system. It had some sort of error and wouldn't respond to the button presses on the unit. RVi overnighted a replacement to me at the campground where I was staying. The brake now works like a Swiss watch.
joemusic is offline   Reply With Quote
Old 07-07-2019, 11:40 PM   #11
Senior Member
 
bharrisv65's Avatar
 
Tiffin Owners Club
Appalachian Campers
Join Date: Nov 2017
Location: TN
Posts: 157
Quote:
Originally Posted by Heating man View Post
I was wondering if any other members have purchased this tire pressure monitoring system. I have this system which I purchased at the FMCA family reunion in Perry Georgia in 2018. I have not had much luck with mine seems like every time I try to use it it does not work. They replaced the sensors once but I still have problems with it.
I bought both the brake controller and TPMS from RVI because I wanted it all on one screen. The brake unit works GREAT, never had a problem with it...the Tire Patrol is another story! They've replaced all my sensors once and a few more twice. I've still had problems with the system, having to re-pair them several times, now some won't pair at all, etc. and I'm just tired of fooling with them! Each time it takes SEVERAL minutes and they MAY pair or they may not. Their customer service is GREAT, I'll give them that much but at this point, I'm just tired of having to deal with these sensors constantly as I can no longer trust when they might work or not. I was told they improved the welds which some were letting moisture in, killing the batteries. Even after having been sent the "new and improved" ones, I still had issues. I had one last sensor (out of 10!) which was the last hold out working and just this week while traveling, it stopped working, error message said battery needed to be replaced; this sensor was less than a year old. I would recommend the RVI Brake control to everyone and brag on RVI's great customer service but the Tire Patrol, I would stay away from. They may get it right some day, maybe even have now but after having so many issues out of mine in the one year I've had it, I'm going to go with a different, more reliable system.
__________________
Bill, Christine & Rip (Ripley Dash Dutton) (Chihuahua/terrier mix)
2022 Montana Legacy 5th Wheel - 2019 F350 Ford 4X4
bharrisv65 is offline   Reply With Quote
Old 07-08-2019, 08:32 AM   #12
Senior Member
 
Heating man's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2012
Location: Indianapolis, IN
Posts: 274
I want to give an update on my tire patrol experience . I sent a letter to them and did not get much of a response and then I sent a second letter and then I got a phone call from mister Dan Decker he is the president of the company. He told he is an engineer and they have had many problems with the system. He said part of the battery problems was that they needed to wash the circuit boards after production and they have the equipment to do this now. I also mentioned to him how long it took for the tablet to connect to the hub and he said they had made improvements there too. He agreed to send me a whole new system with all new sensors. I got the new system on Saturday July 6 and I installed it . The sensors connected immediately and the hub connected immediately to the tablet. It seems they have made it much better. The hub now can be turned off which it could not be before and there are more different colored lights on the hub to tell you what is going on and when it is connected. I have not gone anywhere with the motor home since I installed the replacement system but it does seem they have made considerable improvements. their customer service had always been good and so I am pleased with the improvements. I have their original braking system and it has always worked great for me. I hope these improvement make the system reliable because it is worthless if it won't work when you need it. I thank you Mr. Dan Decker
__________________
2004 Itasca Horizon 40AD caterpillar C7 engine 350 HP with 2016 Smart car toad
Heating man is offline   Reply With Quote
Old 07-08-2019, 05:36 PM   #13
Senior Member
 
bharrisv65's Avatar
 
Tiffin Owners Club
Appalachian Campers
Join Date: Nov 2017
Location: TN
Posts: 157
Quote:
Originally Posted by Heating man View Post
I want to give an update on my tire patrol experience . I sent a letter to them and did not get much of a response and then I sent a second letter and then I got a phone call from mister Dan Decker he is the president of the company. He told he is an engineer and they have had many problems with the system. He said part of the battery problems was that they needed to wash the circuit boards after production and they have the equipment to do this now. I also mentioned to him how long it took for the tablet to connect to the hub and he said they had made improvements there too. He agreed to send me a whole new system with all new sensors. I got the new system on Saturday July 6 and I installed it . The sensors connected immediately and the hub connected immediately to the tablet. It seems they have made it much better. The hub now can be turned off which it could not be before and there are more different colored lights on the hub to tell you what is going on and when it is connected. I have not gone anywhere with the motor home since I installed the replacement system but it does seem they have made considerable improvements. their customer service had always been good and so I am pleased with the improvements. I have their original braking system and it has always worked great for me. I hope these improvement make the system reliable because it is worthless if it won't work when you need it. I thank you Mr. Dan Decker
I may give them one last shot, although the problem is mine is "technically" out of warranty. I bought the Tire Patrol system in May of last year BUT, they sent me a whole new system in August, then after a week or so, they replaced two sensors that wouldn't pair from that set, then another sensor in October that wouldn't pair. I truthfully can say I didn't use the system more than it wasn't used either due to not traveling as much as I had planned or the sensors weren't paired. Thing is, I REALLY want to only speak good of the company because they are truly great at customer service but I just got tired of the constant problems I had with mine and really want a system I KNOW will work when I need it to.
__________________
Bill, Christine & Rip (Ripley Dash Dutton) (Chihuahua/terrier mix)
2022 Montana Legacy 5th Wheel - 2019 F350 Ford 4X4
bharrisv65 is offline   Reply With Quote
Old 07-09-2019, 07:24 AM   #14
Senior Member
 
Heating man's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Jul 2012
Location: Indianapolis, IN
Posts: 274
Quote:
Originally Posted by bharrisv65 View Post
I may give them one last shot, although the problem is mine is "technically" out of warranty. I bought the Tire Patrol system in May of last year BUT, they sent me a whole new system in August, then after a week or so, they replaced two sensors that wouldn't pair from that set, then another sensor in October that wouldn't pair. I truthfully can say I didn't use the system more than it wasn't used either due to not traveling as much as I had planned or the sensors weren't paired. Thing is, I REALLY want to only speak good of the company because they are truly great at customer service but I just got tired of the constant problems I had with mine and really want a system I KNOW will work when I need it to.
I am with you 100 percent. Mine was out of warranty also. I bought mine at the Perry Georgia FMC rally in March 2017. It was in warranty this winter 2018 while we were traveling. As you say I could not count on it working when I needed it. I had trouble getting it to connect before I left a campground in the morning which made it not very useful. I am sold on tire pressure monitoring it saved me twice on our winter trip when tires went down on our toad. I hope their changes have made it dependable. I was ready to buy something else. I hated to throw away $600.00. Dan knows there are problems with the early ones. Reach out to him maybe he will make yours better too. I wrote to him and he called me back.
__________________
2004 Itasca Horizon 40AD caterpillar C7 engine 350 HP with 2016 Smart car toad
Heating man is offline   Reply With Quote
Reply

Tags
tire pressure



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tire patrol high pressure sheridany Newmar Owner's Forum 12 04-05-2019 09:46 AM
RVI Tire Patrol bharrisv65 Class A Motorhome Discussions 4 09-01-2018 09:31 AM
RVi Brake's Tire Patrol wnytaxman Class A Motorhome Discussions 5 03-13-2018 07:34 AM
RVI Tire Patrol georgew48 Class A Motorhome Discussions 23 03-05-2018 10:15 PM
RVI Tire Patrol TPMS Ron Everson Gear and Product Discussions 2 02-27-2018 03:40 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.