Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-20-2021, 06:53 PM   #1
Junior Member
 
Join Date: Jan 2021
Posts: 5
08 Black and Gray water tank sensors

I have an 08 Newmar Essex and the black tank reads 35 gallons whether empty or full, The gray water tank reads 65 gallons that's what it holds but is empty. Both tanks get cleaned when dumped and don't think there is any buildup, how can I check the sensors to see if they are bad and where can I get new ones ? They are Thetford and have found ones the look the same but different part number .
Dave Caster is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-20-2021, 07:14 PM   #2
Senior Member
 
Join Date: Jan 2018
Location: UT
Posts: 1,161
Quote:
Originally Posted by Dave Caster View Post
I have an 08 Newmar Essex and the black tank reads 35 gallons whether empty or full, The gray water tank reads 65 gallons that's what it holds but is empty. Both tanks get cleaned when dumped and don't think there is any buildup, how can I check the sensors to see if they are bad and where can I get new ones ? They are Thetford and have found ones the look the same but different part number .
Good luck getting any tank sensors to work for very long on black or grey. For some reason buildup in the tanks causes some sort of reading error over time. I've had 3 different RVs all with bad sensors after a short time. Sometimes they work ok, most of the time not correct.
__________________
Ed
iluvuk is offline   Reply With Quote
Old 01-20-2021, 07:29 PM   #3
Senior Member
 
momdoc's Avatar
 
Tiffin Owners Club
Join Date: Jul 2016
Location: Where we park it!
Posts: 12,366
Welcome to the forum.

You are joining a good group of folks here with good information to share. Read the various threads here and ask questions as they come up or add information if you can.

You might want fill both tanks with water and add some Pine Power, if you can find it, or some happy camper. Then drive it around for a bit then empty both tanks.

Good luck and enjoy the adventure!
__________________
momdoc
2018 Tiffin Allegro RED 37PA
2020 JEEP Trailhawk
momdoc is offline   Reply With Quote
Old 01-20-2021, 07:41 PM   #4
Senior Member
 
pddgm's Avatar
 
Join Date: Jun 2013
Location: Sunrise Beach, MO
Posts: 421
My black water tank was showing 2/3's full when empty, I tried several different things, made sure I use the built in tank flusher, etc. Finally went and bought one the wands you put down the toilet, cleaned it for about 10 minutes this morning, got the reading down to 1/3 full...But this is our fourth RV and sooner or later the black water sensors always seem to go bad. No a hard job to replace if you can get to the tank....
__________________
Joe

2015 Chevy 2500HD 4x4,2008 Crossroads Cruiser M29CK, 2008 HD Ultra Classic Trike
pddgm is offline   Reply With Quote
Old 01-21-2021, 12:14 PM   #5
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 49,095
Hi ! Welcome to IRV2! We're sure glad you joined us!

I would try the Happy Camper Extreme tank treatment. Follow the directions carefully and hopefully this will solve the problem!

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Reply

Tags
tank, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tank sensors not working in gray or black tanks Justincase Monaco Owner's Forum 1 11-13-2019 06:43 AM
Water Sensors Black and Gray birddog23 Excel Owner's Forum 3 10-03-2018 08:13 AM
Black and Gray tank sensors not working bepar108 Tiffin Owner's Forum 2 07-21-2018 10:38 AM
How to change black/gray tank quantity sensors vito.a Monaco Owner's Forum 11 08-07-2017 12:37 PM
Sensors in gray water tank stay on when empty. wingman139 Class A Motorhome Discussions 14 01-22-2016 07:50 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.