Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-24-2014, 08:42 AM   #1
Member
 
Art E's Avatar
 
Join Date: Aug 2004
Location: Millbrook, AL
Posts: 47
A/C High Fan Inoperative

I have a roof mounted AirXcel 15,000 BTU a/c that is 18 months old. While camping for a week in very hot weather it stayed on quite a bit. It started making a high-pitched beeping noise, something like a golf cart in reverse, but not that loud. Now it only works on "low fan." It does produce cold air on that setting. However, on high-fan, there is only a low hum like a motor that is stuck. Even on low air I think I can also hear that low hum noise. Anyone have any idea what's going on?
__________________
Art E

2004 Winnebago Sightseer 35'
Art E is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-24-2014, 01:46 PM   #2
Moderator Emeritus
 
RickO's Avatar


 
Join Date: Jan 2007
Location: Litchfield Park, Arizona
Posts: 10,530
I'm sure some of our experts will be along soon with advice, but I have merged the two threads you began on this topic since our rules don't allow duplicate threads.

Rick
__________________
Rick, Nancy, Peanut & Lola our Westie Dogs & Bailey the Sheltie.

2007 Itasca Ellipse 40FD
RickO is offline   Reply With Quote
Old 08-24-2014, 03:29 PM   #3
Member
 
Art E's Avatar
 
Join Date: Aug 2004
Location: Millbrook, AL
Posts: 47
Thanks, I kinda wondered about that. It won't happen again.
__________________
Art E

2004 Winnebago Sightseer 35'
Art E is offline   Reply With Quote
Old 08-24-2014, 03:56 PM   #4
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 24,024
I need the full model number of the rooftop unit to find the service manual, Often this can be seen on a label visible if you remove the filters inside the RV (And clean them while they are out) by looking up through the grid.

Alas there are too many models made by them

When you hae the model google AirXcel 15,000 BTU manual
Select the company link
And click on the Technical Documents and Literature link on the company page, From there you can find the same model number by following the pull down menus and that may lead you to a clue.

Some error codes are expensive,, Sometimes it is saying "Clean me".
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 08-24-2014, 05:07 PM   #5
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
Kinda sounds like it may be a motor issue. But all we can do is guess and offer suggestions, you have to trouble shoot. The fact that the fan and cool works means the t-stat is good and control board on those settings, but it could be t-stat or control board as well.
jesilvas is offline   Reply With Quote
Reply

Tags
fan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RVP/Airxcel/Coleman MACH 8 A/C Quiet Outside Fan Kit voltdoc Entegra Owner's Forum 161 09-10-2017 02:27 PM
Fan belt without the A/C ron55 Workhorse and Chevrolet Chassis Motorhome Forum 20 05-16-2017 03:12 AM
$150 Roof A/C Lesson HicksRA Newmar Owner's Forum 18 07-09-2014 01:29 PM
P-30 dashboard fan switch George Schweikle Class A Motorhome Discussions 6 04-29-2014 06:24 AM
Rear A/C Issue Koop Alpine Coach Owner's Forum 10 02-21-2014 08:28 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.