Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-30-2022, 12:28 PM   #1
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
AC runs for a while then "Clicks" then just hums

Like the title says
Runs about 20-30 minutes, then I hear a click
Then it hums quietly and doesnt run, no circulation fan at this time either

Start run Cap?
Or compressor heating up, thermal swicth going active?

What sy youse guys?
Latech is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-30-2022, 02:11 PM   #2
Senior Member
 
Workhorse Chassis Owner
Join Date: Jul 2005
Location: USA
Posts: 3,462
How long is it off before you hear the click?
__________________
TandW
TandW is offline   Reply With Quote
Old 05-30-2022, 03:17 PM   #3
Senior Member
 
wolfgolden's Avatar
 
Join Date: Dec 2019
Location: Bend,or
Posts: 274
Sounds like new capacitors are needed.
wolfgolden is offline   Reply With Quote
Old 05-30-2022, 03:56 PM   #4
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
It runs, then it clicks,like it trips the thermal overload, blower stops,then the unit just hums
Latech is offline   Reply With Quote
Old 05-30-2022, 03:57 PM   #5
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
Quote:
Originally Posted by wolfgolden View Post
Sounds like new capacitors are needed.
If that is all it needs that would be great.
Latech is offline   Reply With Quote
Old 05-30-2022, 10:30 PM   #6
Senior Member
 
Ford Super Duty Owner
Join Date: May 2006
Location: Near St Louis, MO
Posts: 354
The thermal cutout on the compressor would not stop the fan motor.
Give us the make and model of your air conditioner.
DFord is offline   Reply With Quote
Old 05-31-2022, 04:49 PM   #7
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
duo therm 620315
Latech is offline   Reply With Quote
Old 05-31-2022, 05:33 PM   #8
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
I just dawned on me that it is likely the blower motor that is stopping
funny thing is ,is that I har a click and then blower stops and the unit just kinda hums
given that , the hum could be the compressor still running .
I guess I need to get up on the dam roof,pull the cover and let it run to see what is really going on.....
Latech is offline   Reply With Quote
Old 05-31-2022, 05:34 PM   #9
Senior Member
 
Ford Super Duty Owner
Join Date: May 2006
Location: Near St Louis, MO
Posts: 354
No points for being verbose. My crystal ball is a little hazy right now but those numbers are somewhat of help.

What have you tried so far?

Checked the metal run capacitor for any signs of bulging and checked the plastic start capacitor for any signs of melted wax around the terminals?

Cleaned the outdoor coil so it's not tripping on the high pressure that would cause this problem after so many minutes?
Cleaned the indoor coil so it's not freezing up and tripping on the low pressure that would cause this problem after so many minutes?
Checked all the wiring connections making sure their making good contact and aren't corroded?


Tried attaching a PDF manual but the size exceeded IRV2's limits. Try downloading it with the link below:

https://manuals.heartlandowners.org/...leshooting.pdf
DFord is offline   Reply With Quote
Old 05-31-2022, 05:55 PM   #10
Senior Member
 
Xmcdog's Avatar
 
Join Date: Dec 2019
Location: Nova Scotia
Posts: 1,957
Sounds like the fan motor bearings are getting bad. Drawing too much current and over heating. Kicking out on the internal overload. Check the amps on the fan motor. Good luck.
__________________
Jeff and Annette Smith. Sparky, lemon Beagle.
2022 Chevy Equinox RS.
2011 GMC Diesel 2500 HD. Sold
Xmcdog is offline   Reply With Quote
Old 05-31-2022, 06:47 PM   #11
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
cleaned coils thoroughly a few weeks back. same thing .
Inside electrical box was clean and shiny.
did not see anything funky.
Latech is offline   Reply With Quote
Old 05-31-2022, 08:34 PM   #12
Senior Member
 
Ford Super Duty Owner
Join Date: May 2006
Location: Near St Louis, MO
Posts: 354
Have you downloaded the service manual I linked to and looked at page 1: ROOF MOUNTED AIR CONDITIONER SECTION? You find a column of symptoms and a column of causes next to them with a column of numbers referring to possible fixes.

See if you can find your symptom listed and go from there.
DFord is offline   Reply With Quote
Old 06-05-2022, 09:19 PM   #13
Senior Member
 
wolfgolden's Avatar
 
Join Date: Dec 2019
Location: Bend,or
Posts: 274
Any updates on the resolution?
wolfgolden is offline   Reply With Quote
Old 06-06-2022, 05:53 PM   #14
Senior Member
 
Triple E Owners Club
Join Date: May 2021
Location: Eagle Territory
Posts: 119
Not yet. I had the furnace parts so I fixed that this weekend
I have to go out and try the AC again to see what is actually happening.
I hear the "click" and the circulation fan quits. Not sure if the compressor is still running. I am suspicious of the controller board as it controls fan speed
Latech is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Surge Guard Transfer Switch - "Hums" Jim.B1 Class A Motorhome Discussions 13 11-08-2017 06:24 PM
House sound system clicks and hums Sanibelview Technology: Internet, TV, Satellite, Cell Phones, etc. 3 09-27-2016 02:07 PM
DuoTherm Relay Clicks rapidly, then changes to Heat Pump sknopster RV Systems & Appliances 1 12-31-2014 02:40 AM
Water pump runs.... and runs....and runs tobysdad RV Systems & Appliances 8 10-19-2011 08:13 PM
Help,no DC, Throw breaker, Dimensions hums then clicks off Beabop Winnebago Industries Owner's Forum 2 10-08-2006 12:50 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.