Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-28-2022, 12:13 PM   #1
Senior Member
 
Join Date: Jul 2013
Posts: 329
Advent AC issue

brand new Advent 13.5 runs only on fan .... it start for 4 minutes then stop for 2 minutes no compressor at all...what to check ? capacitor? thanks
mrwrench is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-28-2022, 01:32 PM   #2
Senior Member
 
Join Date: Mar 2021
Posts: 178
Blog Entries: 1
Quote:
Originally Posted by mrwrench View Post
brand new Advent 13.5 runs only on fan .... it start for 4 minutes then stop for 2 minutes no compressor at all...what to check ? capacitor? thanks
Hello, how has this unit not worked and did it ever? Doubt it's the capictor being a brand new unit. Check for any burnt or disconnected wires. While up there if all looks well, take a volt meter and see if the compressor is getting 120 volts. Good luck
craigd853 is offline   Reply With Quote
Old 06-28-2022, 06:45 PM   #3
Senior Member
 
Join Date: Jul 2013
Posts: 329
Quote:
Originally Posted by craigd853 View Post
Hello, how has this unit not worked and did it ever? Doubt it's the capictor being a brand new unit. Check for any burnt or disconnected wires. While up there if all looks well, take a volt meter and see if the compressor is getting 120 volts. Good luck
I installed the units in 8/21 and they worked ok...2 weeks ago I wanted to use it and it work for few hrs and the I saw the compressor is not working.
it runs on fan intermittent...
I will check tomorrow.... thanks
mrwrench is offline   Reply With Quote
Reply

Tags
vent



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
placing Coleman AC with Advent Lukedaddy Class A Motorhome Discussions 2 08-01-2011 01:51 PM
advent a/c vs coleman ac badboy42571 iRV2.com General Discussion 5 08-01-2011 01:38 PM
electric heat blowing breaker 2006 advent. WALLY NJ Winnebago Industries Owner's Forum 10 02-12-2006 07:28 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.