Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2022, 11:50 PM   #1
Senior Member
 
IASM's Avatar
 
Join Date: Nov 2013
Location: Burien ,WA
Posts: 963
Aqua Hot runs 30 seconds then shut down

Aqua Hot 650D
When burner switch is turned on green light comes on.Unit fires and runs clean. After 30 seconds or so green light dims and burner shuts down and green light goes out. If i turn off then back on the cycle repeats.This happend a few years ago on a long distance trip and would do this cycle thing when we got parked but would start working ok later in the evening.
Last week i decided to try to get to the bottom of it so replaced filter,nozzel,set electrodes and still the 30 second run.I also used a fuel can to confirm fuel.

I bridged the thermostat and replaced the flame sensor with same results.
I have to think the green burner light dimming and going out is a clue.
Any thoughts? It seems if its running it would stay running unless something tells it to stop?
IASM is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-28-2022, 10:39 PM   #2
Senior Member
 
IASM's Avatar
 
Join Date: Nov 2013
Location: Burien ,WA
Posts: 963
Just to close the thread in the event someone else has the same problem. After testing the circuits for voltage and testing the flame sensor the only thing left was the controller. $800.00 for the new solid state unit and it works fine now.
IASM is online now   Reply With Quote
Old 09-28-2022, 10:44 PM   #3
Senior Member
 
Join Date: Apr 2018
Posts: 2,564
Thanks for the update, that's a tough one to bite the bullet on with nothing to go on experience wise.
__________________
2004 Dynasty 4
shootist is online now   Reply With Quote
Old 09-29-2022, 11:51 PM   #4
Senior Member
 
IASM's Avatar
 
Join Date: Nov 2013
Location: Burien ,WA
Posts: 963
They provided a very good flow chart for testing. Every component can be tested so in the end all test pointed to the controller. This would have been a lot faster had i had the flow chart when i started.I think this test material will apply to most of there burners so worth keeping on file if one has an aqua hot.
Attached Files
File Type: pdf Burner troubleshooting flowchart.pdf (89.1 KB, 14 views)
File Type: pdf Red Light Burner Status.pdf (48.1 KB, 6 views)
IASM is online now   Reply With Quote
Reply

Tags
aqua hot



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coleman Mach 3 fan runs for a few seconds, then stops rcworship RV Systems & Appliances 5 07-13-2021 09:30 PM
Water pump runs for a couple of seconds then shuts off wpatters1229 RV Systems & Appliances 13 12-06-2013 01:45 PM
Roof top AC compressor kicks on, runs for 3 seconds then kicks off Steven2k7 RV Systems & Appliances 6 04-02-2012 09:54 AM
Water pump runs.... and runs....and runs tobysdad RV Systems & Appliances 8 10-19-2011 09:13 PM
Hot water, then cold, then hot, then cold VACMAN Newmar Owner's Forum 4 05-26-2009 10:48 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.