Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2022, 09:15 PM   #1
Junior Member
 
Join Date: Apr 2022
Posts: 6
atwood 10 gal hotwater heater isn,t right

I,ve been trying to get this electric ,propane working again I,ve replaced controls. elements ,relay, theromostat , and the other stat , actually the later 2 4 times and still everything shuts down at 98 electric or gas both the same ,I cleaned the tank, It wasn,t bad at all , the thermostat and ecd, arenew today and again the same so I jumped them both wit fuses and great it heated till it poped the relief valve , so as you can see I,m completly lost I hepair alot of things with no problems but This is one I can,t figure out any suggestions other than toss and put a surburban in , Thanks
djcanada is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-23-2022, 10:41 PM   #2
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
What year is it?

After 2004 the electric & gas are controlled using 12vDC, common set of t-stat/ECO and circuit board
Prior to 2004....electric/gas were totally separate

So have to think you have a 2004-present vintage with common controls

"I,ve replaced controls. elements ,relay, theromostat , and the other stat....T-stat/ECO New today"

Provided they are held TIGHT to WH Tank wall:
T-stat opens at 140*F
ECO opens at 180*F

*If jumpering should only do the T-stat so ECO is still in the control loop
T&P pops open at 210*F/150 PSI....Scalding water/3rd degree burns

Only heating to 98*F on electric and gas
How are you measuring that temp?
Where are you measuring that temp?

Either t-stat is faulty, spade connections are loose, bad GROUNDS or circuit board is faulty

When heating cycle is going on........
Measure DC on Brown wire TO t-stat and FROM t-stat
***Top connector Brown wire is DC TO T-stat
**Bottom connector Brown wire is DC FROM T-stat (thru the Thermal Fuse) Blows at 190*F and NO DC until replaced/removed
DC should still be TO T-stat when heating cycle stops.
**Top Connector Brown wire
IF DC to t-stat drops out during heating cycle then Circuit Board
IF DC from t-stat drops out during heating cycle before reaching 140*F then T-stat is the problem

__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-23-2022, 11:06 PM   #3
Member
 
Desert Man's Avatar
 
Holiday Rambler Owners Club
Join Date: Nov 2021
Location: Tollhouse CA
Posts: 35
Quote:
Originally Posted by Old-Biscuit View Post
What year is it?

After 2004 the electric & gas are controlled using 12vDC, common set of t-stat/ECO and circuit board
Prior to 2004....electric/gas were totally separate

So have to think you have a 2004-present vintage with common controls

"I,ve replaced controls. elements ,relay, theromostat , and the other stat....T-stat/ECO New today"

Provided they are held TIGHT to WH Tank wall:
T-stat opens at 140*F
ECO opens at 180*F

*If jumpering should only do the T-stat so ECO is still in the control loop
T&P pops open at 210*F/150 PSI....Scalding water/3rd degree burns

Only heating to 98*F on electric and gas
How are you measuring that temp?
Where are you measuring that temp?

Either t-stat is faulty, spade connections are loose, bad GROUNDS or circuit board is faulty

When heating cycle is going on........
Measure DC on Brown wire TO t-stat and FROM t-stat
***Top connector Brown wire is DC TO T-stat
**Bottom connector Brown wire is DC FROM T-stat (thru the Thermal Fuse) Blows at 190*F and NO DC until replaced/removed
DC should still be TO T-stat when heating cycle stops.
**Top Connector Brown wire
IF DC to t-stat drops out during heating cycle then Circuit Board
IF DC from t-stat drops out during heating cycle before reaching 140*F then T-stat is the problem

THANK You f
Desert Man is offline   Reply With Quote
Old 06-23-2022, 11:12 PM   #4
Member
 
Desert Man's Avatar
 
Holiday Rambler Owners Club
Join Date: Nov 2021
Location: Tollhouse CA
Posts: 35
1997 Holiday Rambler Endeavor LE

Biscuit! Fantastic information. I want you for President! I had a service provider go through mine and said it is working? Same scenario as posted. Works great on propane most of the time. No go on the electric side. Have not replaced the heating element because this RV is costing me the same as my ex wife! Any more suggestions? Thank You!
Desert Man is offline   Reply With Quote
Old 06-24-2022, 10:06 AM   #5
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Quote:
Originally Posted by Desert Man View Post
Biscuit! Fantastic information. I want you for President! I had a service provider go through mine and said it is working? Same scenario as posted. Works great on propane most of the time. No go on the electric side. Have not replaced the heating element because this RV is costing me the same as my ex wife! Any more suggestions? Thank You!
Sorry for your troubles
Yours is an older/earlier version with different controls/wiring etc

Should Post your OWN thread so responses are for your issue and don't get confused with current issue OP is having
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-25-2022, 11:49 AM   #6
Junior Member
 
Join Date: Apr 2022
Posts: 6
The water heater was put in in 2012 at camping world this is on my mothers 2006 bounder .we been checking the temp at the sink when it has run a while and they have told me there isn,t enough hot water to get a shower anymore they have ordered a new dometic but won,t be here for a month , and the fact is they live in this rv all that being said I thank you for the imput now i have a way to see were the problem lies
djcanada is offline   Reply With Quote
Old 06-25-2022, 01:24 PM   #7
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Atwood GC10A-4E ( Gas Combo 10 gal 4th version Electronic Ignition)
Cut Out Dimensions: 16″ Wide x 15.5″ High x 20.8″ Deep


Dometic WH-10GEA (Water Heater 10 gal Gas/Electric)
Cut-Out Dimensions: 15.75" Wide x 16.25" High x 20.63" Deep



Atwood 10 gal model in 2006 would be the same model in 2012
Pretty short life span for TWO Atwoods???
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-29-2022, 06:39 PM   #8
Junior Member
 
Join Date: Apr 2022
Posts: 6
hopefully a fifth t stat will be good they have been the same every one of them even the adjustable oneupper 90,s is all then shuts down and will not come back on unless the switch is worked
djcanada is offline   Reply With Quote
Old 06-29-2022, 08:03 PM   #9
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Quote:
Originally Posted by djcanada View Post
hopefully a fifth t stat will be good they have been the same every one of them even the adjustable oneupper 90,s is all then shuts down and will not come back on unless the switch is worked
Did you measure DC Voltage to and from T-stat(s) when heating is occurring?
Also when it shuts down early.

Loss of DC TO T-stat....circuit board
Loss of DC FROM T-stat......t-stat/wire connectors

*When T-stat OPENS there should still be DC TO the t-stat
T-stat controls the heating by opening/closing



Are you SURE the WH Tank BYPASS Valve is NOT leaking thru diluting the Hot water temp?
When heat source shuts off/T-stat Opens......measure water temp via T&P Relief Valve
*CAUTION: S/B 140*F
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-30-2022, 07:04 AM   #10
Junior Member
 
Join Date: Apr 2022
Posts: 6
Yes sir i did from controller it was 12.9 the other side of the theromastat was 2. after shutting off at around 94
djcanada is offline   Reply With Quote
Old 06-30-2022, 01:35 PM   #11
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Quote:
Originally Posted by djcanada View Post
Yes sir i did from controller it was 12.9 the other side of the theromastat was 2. after shutting off at around 94
Was the 94*F measured with water from T&P Relief or from a faucet?

T-stat closes for heating cycle at 110*F
So how can temp be 94*F?????


WH Tank BYPASS
OR
Inside/outside shower not being turned off via hot/cold knobs but just the 'button'/'lever' on shower handle???


5 t-stats failing?????


Having to turn switch Off/back ON to restart heating cycle suggest Circuit Board issue
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 06-30-2022, 03:18 PM   #12
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Are those replacement T-stats : Atwood 91447
12VDC T-stat/ECO
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 07-01-2022, 09:36 AM   #13
Junior Member
 
Join Date: Apr 2022
Posts: 6
well that would be about right I bought the more expensive one ,and it has been used to long to return Sounds about right though it has been the same since new the valve could be faulty ,For the most part I,m a good mechanic, and this thing keeps me having second thoughts ,and the poor folks have been with out since may ,camping world did nothing for them but order another that is a month away from delievry, I,m going to do some more tests today and see if i can figure it out while they are away today,I,m a carpenter not an electrician ,here i go thanks for all the info
djcanada is offline   Reply With Quote
Old 07-01-2022, 09:46 AM   #14
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 22,087
Quote:
Originally Posted by djcanada View Post
well that would be about right I bought the more expensive one ,and it has been used to long to return Sounds about right though it has been the same since new the valve could be faulty ,For the most part I,m a good mechanic, and this thing keeps me having second thoughts ,and the poor folks have been with out since may ,camping world did nothing for them but order another that is a month away from delievry, I,m going to do some more tests today and see if i can figure it out while they are away today,I,m a carpenter not an electrician ,here i go thanks for all the info
Sorry but I feel like I have come in on the middle of a conversation.
The above is not giving any specific info and questions asked are not being answered

Feel like going in circles....hopefully someone can come along and help
__________________
I took my Medication today. HAVE YOU?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Reply

Tags
atwood, heat, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
35 gal black tank only holding 15 gal ? Halestorm Fleetwood Owner's Forum 15 02-24-2019 10:58 AM
2017 GMC Dash US gal or Canadian gal? Ted Lambert Toads and Motorhome Related Towing 11 06-30-2018 03:31 PM
Upgrading Water Heater from 6 Gal to 10 Gal sbleiweiss Class A Motorhome Discussions 12 01-05-2016 09:53 AM
Atwood Hotwater Heater Removal '06 Fleetwood Discovery Mike R Fleetwood Owner's Forum 10 05-14-2013 06:18 PM
Bounder: Atwood hotwater heater Capescout Fleetwood Owner's Forum 7 09-12-2011 05:29 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.