Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-10-2017, 03:04 PM   #1
Junior Member
 
Monaco Owners Club
Join Date: Aug 2017
Posts: 13
Atwood 8940 III DCLP won't stay lit

I have an Atwood 8940 III DCLP in my 2001 Monaco Diplomat that won't stay lit. When I turn it on; the fan runs for a few seconds as it should, the furnace lights (I can here the audible signature of ignition), runs for about 5 seconds then the burner turns off. It relights after about 10 seconds then again after 5 seconds turns off. It goes through this cycle 3X with the fan running throughout. After the third burner shutoff... the fan continues to run indefinitely. It will repeat this process if I turn the heat of and then back on at thermostat. Most likely failure?
Deniseg is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-10-2017, 05:45 PM   #2
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,382
It's odd that it would light then go out immediately. Here is a sequence that may be applicable. If this page doesn't help go to the pdf file.


http://bryantrv.com/docs2/docs/hflamefurn04.pdf
Attached Files
File Type: pdf furnace troubleshooting.pdf (23.4 KB, 198 views)
__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Old 08-10-2017, 08:39 PM   #3
Junior Member
 
Monaco Owners Club
Join Date: Aug 2017
Posts: 13
The sequence in section C toward the bottom of the page on the PDF you provided is what I'm experiencing. I what not aware that the circuit board in the furnace had a light that will blink to indicate failure mode. I'll have to try it again and, assuming I still have the issue, check the light on the board and research the error signal. Thanks
Deniseg is offline   Reply With Quote
Old 08-10-2017, 09:35 PM   #4
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,382
No problem. ...good luck
__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Old 08-11-2017, 06:11 AM   #5
Senior Member
 
Monaco Owners Club
Join Date: Sep 2014
Posts: 4,382
Oh yeah......

__________________
1996 Tioga Class C
2007 Monaco Diplomat 40 PDQ
TOAD 2012 Cadillac SRX 4
okcnewbie is offline   Reply With Quote
Reply

Tags
atwood



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring connections on Atwood 8940 III control board drive805 RV Systems & Appliances 2 02-26-2017 01:25 AM
Replace limit switch on Atwood 8526-III DCLP Furnace No54me RV Systems & Appliances 3 09-26-2016 12:49 PM
Atwood water heater won't stay lit on propane rambler05 Class A Motorhome Discussions 5 05-04-2015 08:34 AM
Atwood Stove Won't Stay Lit NomadBD RV Systems & Appliances 6 11-12-2013 06:46 PM
Atwood water Heater won't stay lit John Hilley RV Systems & Appliances 13 02-07-2012 04:32 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.