Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-29-2020, 10:59 AM   #1
Junior Member
 
Ampedspyder's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
iRV2 No Limits Club
Join Date: Aug 2016
Location: Oregon
Posts: 20
Atwood Hydro Flame Furnace blower motor stuck

Kind of random issue, we have a 2017 Fleetwood Pace Arrow 33D this morning when the heat pump shut off the front gas furnace starting clicking continuously. I turned on the furnace at the thermostat and the fan came on but the gas would not fire no matter the temp setting. Fan ran and ran, when it did finally turn of we were back to the clicking. I did a 12 volt power disconnect for 5 minutes but no change.

After some research I opened the furnace cover and found the clicking was the blower trying to start again. I unplugged the power to the circuit board and hit the reset located on top of the unit. Waited a couple minutes and all systems are go now! I have seen where this happens when moisture gets under the circuit board but I found none and we are in the desert this month.

Hopefully this was random, if not may need a new circuit board. Iíll repost if it happens again, but I wanted to share the solution I found.
Ampedspyder is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply

Tags
ace, atwood, furnace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Hydro flame furnace trouble jkearns6 RV Systems & Appliances 10 06-10-2017 08:57 AM
Troubleshoot Atwood Hydro flame furnace MSgtNobody RV Systems & Appliances 2 10-06-2015 06:44 AM
Atwood Hydro Flame Furnaces bobvau Class A Motorhome Discussions 2 11-21-2011 07:49 PM
Atwood Hydro Flame diggermik85 Monaco Owner's Forum 2 10-17-2011 04:45 PM
Atwood Hydro Flame heater problem Mopar1973Man Travel Trailer Discussion 1 12-10-2010 04:08 PM


All times are GMT -6. The time now is 05:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.