Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-02-2021, 04:34 PM   #1
Junior Member
 
Join Date: Aug 2021
Posts: 2
Question Basement AC/Heat Unit

I am new to this community and the motor home world. I have a 2004 40’ Alpha See Ya Gold Motor home build is 72068. It was abit rough but is coming together nicely. I still have one issue that I can’t figure out and needing some help. Its the basement AC/HEat unit . I can’t get it to work. I have 12volts where I need 12 volts etc. and I have 120volts where it is needed. I have 4 very quick flashing green lights then a pause and it repeats. I had to replace the control board as the old one was burned in all the places this unit is famous for. I updated the control board with the new style.
I can’t get anything to work on the unit meaning I can’t even get the fan to come on. I can jump the fan and it works but thats about it. Any suggestion of what to do. I took the motorhome to a RV repair shop they looked at it for about a month and could not or did not help. Any help would be greatly appreciated.
Pincliff is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-02-2021, 04:46 PM   #2
Senior Member
 
Join Date: Aug 2019
Location: Eastern outskirts of Dallas, TX
Posts: 468
Have you found a manual for the heat/AC unit yet? There is almost always a troubleshooting guide in it that will tell you what the flashes mean and where to look -

Cuz obviously you don’t have the 12 volts or 120 volts in ALL the right places. ��

Them blinking lights are probably trying to tell you something.
MrMark52 is offline   Reply With Quote
Old 08-02-2021, 05:31 PM   #3
Senior Member/RVM #90
 
MSHappyCampers's Avatar


 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 47,830
Hi ! Welcome to IRV2! We're sure glad you joined us!

Good luck, happy trails, and God bless!
__________________
Joe & Annette
Sometimes I sits and thinks, sometimes I just sits.....
2002 Monaco Windsor 40PBT, 2013 Honda CRV AWD
MSHappyCampers is offline   Reply With Quote
Old 08-02-2021, 05:31 PM   #4
Senior Member
 
Join Date: May 2016
Posts: 346
When Shelburne RV replaced the control board in my coach, they had to replace the thermostat also.
__________________
Patrick
Atlanta GA
2000 Itasca Horizon/300 Cat & 2017 Jeep Cherokee Overland
Papa Foxtrot is offline   Reply With Quote
Old 08-03-2021, 08:03 AM   #5
Junior Member
 
Join Date: Aug 2021
Posts: 2
Basement AC

Well, I got it working this morning. Some great comments from many and it got me thinking. When I changed the old control board out for the new control board I crossed two wires and those two are AC1 and AC1White. So, if any are doing this make sure you get T1 from the old board to the right connection on the new board and that will help you not make the same mistake I made. Happy RV everyone…
Pincliff is offline   Reply With Quote
Old 08-03-2021, 11:48 AM   #6
Junior Member
 
Join Date: Jul 2021
Posts: 7
Just a quick hint, when working with electrical units, take pictures before starting.

Fred
fredbon is offline   Reply With Quote
Reply

Tags
heat



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replace heat pump unit with A/C only unit ike1562 Class C Motorhome Discussions 8 04-25-2021 05:37 PM
Replaced basement air with new unit - old unit available Rcdukes Winnebago Industries Owner's Forum 22 06-21-2019 04:12 PM
Basement heat pump unit quit cooling & spikes 50+ amps at start up calvdawg Winnebago Industries Owner's Forum 10 08-14-2016 09:44 AM
Hydro Hot basement heat ?? no fan at heater vent in basement wernie1 Travel Supreme Owner's Forum 3 01-01-2016 11:55 PM
Coleman heat/ac basement unit Donaldshoe RV Systems & Appliances 3 05-31-2013 09:25 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.