RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-22-2009, 10:53 AM   #1
Senior Member
 
Join Date: Sep 2007
Location: FL
Posts: 124
Dometic fridge LP problem

Left for 4 mos trip last week. Had pre-cooled fridge with shore power and all was good. However, while driving the wife noticed the fridge was not powered by LP.

LP tank was 3/4 full and she had just made some lunch with the stove, so had her try the water heater. That worked fine.

After 5 hrs of driving, stopped for gas and while stopped I tried to get fridge lp light to come on. After pushing the on/off button on the fridge many, many times the LP light illuminated. However, after 10 minutes back on the road the wife noticed the light out again.

After another 5+ hrs of driving, stopped at Wally World for the night and the fridge ran fine on LP all night. Now, a week and another 600 miles later it is still working just fine.

My question - Anyone else had this experience and if so, any ideas why it took so long to start up and keep running on LP? Could it be a temp sensor going bad, a spiders nest in the wrong place, or some other common problem.

I just want to know possible causes in advance so we don't end up losing some frozen food when I could have done something on the road to fix the problem.

__________________

NavlAv8r is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-22-2009, 03:14 PM   #2
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,550
Hi Navl AV8R,
In addition to what was mentioned in your OP, it could just be the wind hitting the coach the wrong way. Look at how the gas flame is protected from the wind, as you travel down the road. Consider letting the unit run on propane for a day or two. If the unit has a problem only when traveling, you may need to build additional protection for the flame.

Make sure your batteries are fully charged.
__________________

__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 05-23-2009, 02:36 AM   #3
Community Moderator
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,063
How many hours does the ref. have on LP mode since it was last serviced? It may just need a good cleaning. What brand of ref. do you have and is it in a slide out? If so you may want to assure the lp line is not being kinked when room is retracted.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Old 05-25-2009, 08:01 PM   #4
Senior Member
 
lthrnk's Avatar
 
Tiffin Owners Club
Fleetwood Owners Club
Appalachian Campers
Join Date: Jul 2007
Location: Titusville, FL
Posts: 694
Same problem with Norcold

Not to hijack the thread, but we have had a very similar problem with our Norcold unit the last two days.

Never any problem before but all of a sudden running down the road the LP quit and got "No FL" msg and a beeping alarm on the ref. We were boondocked last night with the gennie running and no mproblem on AC.

Tried to restart the ref. on LP and it light off OK. After about 5 hours of travel, same as yesterday, it quit again. Sitting now and it won't stay lit. Runs for a few minutes and then a loud puff/knock and it tries to relight then quits. Almost sounds like a bad fuel/air mix?

Anyone any more thoughts on this?

Thanks, Mike
__________________
"Home is where we park it" SEMPER FI
Winnie 30 RESS UltraLite TT 2015
Ford F250 XLT 2015
lthrnk is offline   Reply With Quote
Old 05-26-2009, 06:01 AM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,068
Had same problem with fridge when I bought the coach LP wouldn't stay lite. Dealer wanted to replace fridge. I kept forcing into LP mode and finally it would stay in that mode. One thing you have to do is clean out chimney of rust by covering burner tube with a paper towel and gently tapping side of chimney so rust will fall to bottom, than vacuum out rust. If rust flakes get in burner will have trouble keeping heat sensor from working correctly.
Dependent on ventilation for burner what GaryKD said may need to be done add more ventilation while traveling.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 05-26-2009, 07:14 AM   #6
Senior Member
 
sknight's Avatar
 
Appalachian Campers
Join Date: May 2009
Posts: 908
I'd give it a good cleaning and replace the thermocouple. If the thermocouple has gotten lazy then the fridge will shut down to prevent a fire.

The way it was explained to me it the LP flame gets blown out often going down the road. An RV thermocouple reacts incredibly fast, reigniting the flame before gas can build up. If it doesn't get that signal then it shuts off.
__________________
2001 HO Cummins powered Dodge 2500
2014 Sierra 346RETS
Nights camped in 2014-28
sknight is offline   Reply With Quote
Old 06-28-2010, 06:15 PM   #7
Senior Member
 
azloafer's Avatar
 
Winnebago Owners Club
Join Date: Oct 2009
Posts: 1,170
Quote:
Originally Posted by lthrnk View Post
Not to hijack the thread, but we have had a very similar problem with our Norcold unit the last two days.

Never any problem before but all of a sudden running down the road the LP quit and got "No FL" msg and a beeping alarm on the ref. We were boondocked last night with the gennie running and no mproblem on AC.

Tried to restart the ref. on LP and it light off OK. After about 5 hours of travel, same as yesterday, it quit again. Sitting now and it won't stay lit. Runs for a few minutes and then a loud puff/knock and it tries to relight then quits. Almost sounds like a bad fuel/air mix?

Anyone any more thoughts on this?

Thanks, Mike
This too late to help you, but someone else may read it and it might solve their problem. When I had the "FL" reading the dealer determined that I hadn't used the frig for awhile on LP and it somehow got air in the line. This could have happened when the wind blew yours out??? Anyway, they just ran the water heater and furnace and the range on LP for awhile to clear the line and the code vanished and all was well. During warm weather we use the gen while on the road, along with the air. Otherwise we use the LP. Joe
__________________

__________________
2008 Itasca Latitude 39W. Cummins ISB 6.7 Turbo 340HP. Allison 6 Speed. Freightliner XCS. Michelin XRV 255/80R 22.5 LRG. SuperSteer MCU. Safe-T-Plus.
azloafer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dometic refrig problem KayLarGo MH-General Discussions & Problems 7 11-17-2007 04:10 AM
problems with Instamatic fridge nathanfox83 RV Systems & Appliances 3 12-18-2006 01:29 AM
another fridge problem Jim RV Systems & Appliances 7 08-09-2006 11:30 AM
Dometic fridge won't stay lit Riverdog RV Systems & Appliances 10 07-26-2006 08:53 AM
Dometic Fridge won't light, no spark YJ Bill RV Systems & Appliances 5 01-21-2006 01:33 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×