RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-19-2020, 01:04 AM   #1
Senior Member
 
Vintage RV Owners Club
Join Date: Feb 2020
Posts: 135
Furnace problems. I donít know what else to replace to get it fired up.

https://app.photobucket.com/u/Chieft...1-9dd42480b65f <——— photo of suburban furnace.
I replaced the limit switch and electrode and when I get the ticking noise I used to be able to see the electric spark happening on the left side through the little circle window but even after replacing the things I mentioned i still get no sparks. It might do it one time the entire clicking session but that’s it. Can I remove the glass window and stick a candle lighter in there to ignite it? Anyone done this before? I gave up on this thing last season and would like to get it fired up for this upcoming cold season. Also the fan sounds like it’s hitting something every time it comes around.
Chieftain27 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-19-2020, 05:16 AM   #2
Senior Member
 
Join Date: Oct 2017
Location: Boston,ma
Posts: 363
Go to the Wanderlodge owners group site. Then do a search on suburban furnace. there is a whole thread on how to troubleshoot them.
Roy-c is online now   Reply With Quote
Old 09-19-2020, 10:36 AM   #3
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 2,302
Ticking with no spark, correct?

First, be sure the igniter probe is clean as well as the metal piece to which the spark is to ground, usually the burner. Remove all soot/rust from both. Second, set the gap between the probe and ground to ~1/8".

If the above does not produce a regular spark, try replacing the igniter module.

I would not suggest you stick a lighted candle into the furnace. Perhaps a butane lighter with a long "nose", but only if you have someone else turn ON the furnace so the flame is already present from the lighter before the gas valve opens. In other words, you create a manual "pilot light".
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is online now   Reply With Quote
Old 09-19-2020, 01:10 PM   #4
Senior Member
 
Join Date: Nov 2015
Posts: 13,421
That looks like an NT series furnace
Service Manual...see section C items 8 - 12
http://techsupport.pdxrvwholesale.co...ice-Manual.pdf
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 09-19-2020, 09:59 PM   #5
Senior Member
 
Join Date: Apr 2020
Posts: 755
Quote:
Originally Posted by Ljwt330 View Post
Ticking with no spark, correct?


I would not suggest you stick a lighted candle into the furnace. Perhaps a butane lighter with a long "nose", but only if you have someone else turn ON the furnace so the flame is already present from the lighter before the gas valve opens. In other words, you create a manual "pilot light".
LOL! He didn't say a lit candle, he said a candle lighter, exactly the same thing you described.
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Old 09-20-2020, 08:26 AM   #6
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 2,302
Quote:
Originally Posted by HarryStone View Post
LOL! He didn't say a lit candle, he said a candle lighter, exactly the same thing you described.
Well, that's what I get for reading too fast! Never heard of them by that reference though.
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is online now   Reply With Quote
Old 09-30-2020, 08:29 PM   #7
Senior Member
 
Vintage RV Owners Club
Join Date: Feb 2020
Posts: 135
Quote:
Originally Posted by Ljwt330 View Post
Ticking with no spark, correct?

First, be sure the igniter probe is clean as well as the metal piece to which the spark is to ground, usually the burner. Remove all soot/rust from both. Second, set the gap between the probe and ground to ~1/8".

If the above does not produce a regular spark, try replacing the igniter module.

I would not suggest you stick a lighted candle into the furnace. Perhaps a butane lighter with a long "nose", but only if you have someone else turn ON the furnace so the flame is already present from the lighter before the gas valve opens. In other words, you create a manual "pilot light".
I replaced the igniter module and checked gap and have spark now but no fire! Hmmm
Chieftain27 is offline   Reply With Quote
Old 09-30-2020, 08:34 PM   #8
Senior Member
 
Join Date: Nov 2015
Posts: 13,421
Guess it isn't an NT series?????
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 09-30-2020, 08:47 PM   #9
Senior Member
 
Vintage RV Owners Club
Join Date: Feb 2020
Posts: 135
Quote:
Originally Posted by Old-Biscuit View Post
Guess it isn't an NT series?????
Itís a NT34S. I have spark but no ignition now...
Chieftain27 is offline   Reply With Quote
Old 09-30-2020, 09:02 PM   #10
Senior Member
 
Rkesselus's Avatar
 
Tiffin Owners Club
Join Date: Aug 2016
Location: Bastrop Texas
Posts: 1,264
I may not have read everything but in the original post you also mention that the fan seems to be hitting something. Is that still and issue. Also what did you do prior to finally getting the ignitor to spark. So now it an issue of no gas. If so I think it is time to take it our and do some work on it on a bench. lightly tapping on the regulator and switch might help with the gas flow. Normally on start up the fan will come on first then the ignition followed by heating the thermocouple to keep the flame going until thermostat tell is to stop.
__________________
2000 Allegro Bus 35R 3126 Cat 300 Allison 3060MD 6 speed
Rkesselus is offline   Reply With Quote
Old 09-30-2020, 09:07 PM   #11
Senior Member
 
Join Date: Nov 2015
Posts: 13,421
Quote:
Originally Posted by Chieftain27 View Post
Itís a NT34S. I have spark but no ignition now...
Did you check out the troubleshooting in the manual link?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 09-30-2020, 09:13 PM   #12
Senior Member
 
mchero's Avatar
 
Join Date: Mar 2006
Location: Full Time USA
Posts: 2,163
Purchase this tuneup kit
https://pdxrvwholesale.com/products/...4s-tune-up-kit
Furnace that age should have a tuneup kit installed.
Just make sure that heat exchanger does NOT have any rusted out holes in it! If it does please dont use it.
If you do indeed open it up the fan(s) "might" be rubbing on a shroud. Also the burner "might" be rusted out" If the limit switch is not functioning it won't turn on the gas valve.
__________________
Robert & Deb
07 Discovery 39v FWS Full Timers, Henniker NH
1K solar - 05 Jeep Grand Cherokee
mchero is offline   Reply With Quote
Old 10-01-2020, 08:05 AM   #13
Junior Member
 
Join Date: Aug 2020
Posts: 8
You need to pull the furnace and give it a good tune-up. I have experienced two issues with this furnace.

If the fan motor starts and then 20 seconds later you hear one click or clunk, that is the gas valve energizing. If you don't get a spark at that time, replace the circuit board. It sounds like your circuit board is intermittent.

If you get the gas valve energizing and a spark but no ignition. you need to clean out the LP orifice. If it has not worked for the past year or so, it probably has a bug stuck inside the orifice.
A1RVTraveler is offline   Reply With Quote
Old 10-01-2020, 08:21 PM   #14
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 20,744
Quote:
Originally Posted by Chieftain27 View Post
.
Follow old-biscuit's advice, he knows RV appliances.
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Reply

Tags
ace, ems, fire, furnace, problem, problems, replace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
We donít even know what all we donít know ravenclaw Class A Motorhome Discussions 53 12-06-2017 06:02 AM
You donít know what you donít know! 62_inrightlane Class A Motorhome Discussions 12 03-19-2012 06:21 AM
Know /Don't Know Ecker Newmar Owner's Forum 5 12-24-2007 03:02 PM
We fired our dealer GoneFishin Monaco Owner's Forum 12 09-17-2007 10:12 AM


All times are GMT -6. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.