Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-21-2021, 04:41 PM   #15
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
So first pic is the on/off switch?
Second pic is the sail switch?
Third pic is the board I installed. Nothing looks out of the ordinary with this?
mmbrevo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-21-2021, 05:13 PM   #16
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 19,605
1st Pic...on/off switch
RED wire to switch should have 12VDC+

Red & Blue wires FROM switch should have 12VDC+
*Red goes to Circuit Board 'PWR' connection
*Blue goes to Thermostat

2nd picture...Sail Switch
3rd picture...Circuit Board


When Thermostat Closes (Calls for heat)
Blue wire in that connector (2nd pin) should have 12VDC+ and Blue wire to Sail Switch should have 12VDC+
RED wire from 'BLW' on Circuit Board should have 12VDC+ (goes to Fan Motor)
**See Black Wire on Circuit Board???? Where does that Black Wire go?
Where is RED wire from Motor connected to???

Circuit Board wiring doesn't look right......
Connector is OK
But the 2 other wires ???
Should be a RED from On/Off Switch---'PWR'
Should be RED from 'BLW' to fan


A picture showing the whole furnace would help
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-22-2021, 03:58 PM   #17
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
So pic of the furnace and better pic of the board.
Attached Thumbnails
Click image for larger version

Name:	227B078B-67BA-469E-8A20-0BBE55BB3DD3.jpg
Views:	12
Size:	434.8 KB
ID:	349595   Click image for larger version

Name:	DB1B9CCB-FE50-4A1F-8B0B-5B0F7261BC73.jpg
Views:	12
Size:	336.5 KB
ID:	349596  

mmbrevo is offline   Reply With Quote
Old 11-22-2021, 04:22 PM   #18
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 19,605
Black Wire on Board....
What is the terminal labeled as?
*Red is labeled Power

Where does that Black Wire go?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-23-2021, 03:00 AM   #19
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
Blower
mmbrevo is offline   Reply With Quote
Old 11-23-2021, 09:32 AM   #20
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 19,605
OK....Black wire to Blower (Fan Motor)

Then should have 12VDC:
On Red wires to/thru on/off switch....and Blue wire to T-stat
On Red wire to Power on Circuit Board

When t-stat closes should have 12vDC:
On Blue wire from t-stat (2nd blue wire on connector)
On Black wire from Blower on circuit board...fan starts

Follow the DC ...
No DC on Black...blower circuit on board bad
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-23-2021, 05:37 PM   #21
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
Well I did a bone headed thing and switched 2 of the wires when I hooked up the board. I switched them around and the furnace fired up. Thank you all so much especially Old- Biscuit for all of your help. I learned a lot and hopefully Iíll be better prepared the next time something goes wrong. Happy Trails!
mmbrevo is offline   Reply With Quote
Old 11-23-2021, 08:19 PM   #22
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 19,605
Which wires were wrong so folks will understand where the mistake was?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-23-2021, 08:42 PM   #23
Senior Member
 
Workhorse Chassis Owner
Join Date: Jan 2002
Posts: 1,858
I think Mr. Elderly Biscuit deserves a round of applause for his precise questions and answers....and long time service to this forum.
__________________
2003 Dolphin LX 6355 w/ W22 chassis; 8.1L gas & Allison 1000
Scooter is offline   Reply With Quote
Old 11-24-2021, 05:34 PM   #24
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
So, I switched the black wire that was going to the blower, and the red wire that was going to that big black round thing.
mmbrevo is offline   Reply With Quote
Old 11-24-2021, 05:35 PM   #25
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
Definitely
mmbrevo is offline   Reply With Quote
Old 11-24-2021, 08:55 PM   #26
Senior Member
 
Old-Biscuit's Avatar
 
Join Date: Nov 2015
Posts: 19,605
Big round black thing....that is the transformer that provides the high voltage spark for ignition (~2000VDC) for spark electrode

So the RED wire to fan motor is now on the Blower Terminal on circuit board and the Black wire goes to the spark electrdoe
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-25-2021, 07:07 PM   #27
Member
 
Join Date: Sep 2016
Location: Carrboro, NC
Posts: 32
Yes, black to the electrode, red to the blower
mmbrevo is offline   Reply With Quote
Reply

Tags
ace, furnace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace trouble kartfreak RV Systems & Appliances 11 01-30-2016 03:59 AM
Suburban Furnace trouble ? monkey RV Systems & Appliances 5 11-29-2014 02:42 PM
8935 lll furnace Trouble !! ian kelly RV Systems & Appliances 5 05-11-2013 10:05 PM
2011 Keystone High Country Furnace trouble wdperry 5th Wheel Discussion 2 11-21-2011 08:42 PM
Hurricane Furnace Blower Trouble patty98311 Country Coach Owners Forum 3 10-18-2010 02:26 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.