RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2020, 08:43 PM   #1
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Generator starting issues

2014 Newmar Ventana 4369 DP. When trying to start the generator all I get is a clicking sound. Batteries are fine. Iíve been charging with the engine when needed. I can run my fridge, coffee maker and anything else I need with no problem. Voltage is at 13.7 and drops to maybe 12.5 with refrigerator and heat running all night. I cleaned all the battery terminals. Any ideas? Possibly a solenoid or relay between batteries and genny?
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2020, 08:47 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 24,223
Have you tried holding the boost switch while starting the generator ?

What your discribing is often a loose connection. Check the ground cable between the generator and frame.
twinboat is online now   Reply With Quote
Old 09-20-2020, 08:50 PM   #3
Senior Member
 
Join Date: Jul 2000
Posts: 3,156
did you clean and tighten the battery connections at the genny?
__________________
Rich, Ham Radio, Sport Pilot
Retired 9-1-1
2016 Itasca Suncruiser 38Q/2010 Jeep Liberty
rk911 is offline   Reply With Quote
Old 09-21-2020, 05:25 AM   #4
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by twinboat View Post
Have you tried holding the boost switch while starting the generator ?

What your discribing is often a loose connection. Check the ground cable between the generator and frame.
Yes I have tried the battery boost switch. The only connections I cleaned were at the batteries. I will try cleaning others today. They all seemed tight but maybe I missed one.
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Old 09-21-2020, 05:38 AM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 24,223
Did you check the chassis battery connections. Some generators start off them.

As a side note, there is no solenoid hidden between the batteries and the generator. There will be a solenoid on the generator.
twinboat is online now   Reply With Quote
Old 09-21-2020, 04:45 PM   #6
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by twinboat View Post
Did you check the chassis battery connections. Some generators start off them.

As a side note, there is no solenoid hidden between the batteries and the generator. There will be a solenoid on the generator.
Good to know. How about a relay? I didnít get a chance to mess with it today and Iím pulling out of here in the morning. My next few stops have electric so I shouldnít need the generator. I may or may not get to it until I get home which should be in a week or so. Iíll post if I find something. Thanks for the info.
RudysDad is offline   Reply With Quote
Old 09-21-2020, 05:39 PM   #7
Senior Member
 
deandec's Avatar


 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 4,732
Did your attempts to start the generator occur via an inside remote switch or on the side of the generator?
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
Gillig Bus Chassis
deandec is offline   Reply With Quote
Old 09-21-2020, 08:09 PM   #8
Senior Member
 
Join Date: Jul 2006
Location: Michigan
Posts: 812
Forgive a basic question - has the gen worked before, or is this your first experience with it? (Noticed you are fairly new to the forums... not sure of your experience level.) A diesel gen doesn't start immediately... it needs to prime and preheat before the gen starts. You should hold the "stop" side of the gen switch down for about 10 secs to prime the gen and start the preheat. If you are close you should hear a pump running in the gen. Then press the "start" side of the switch... it may take anywhere from 2-10 seconds or more to start, depending upon outside temps. Again, forgive if this is sounding basic, just have seen a lot of new owners posting with varying levels of experience with RV systems.
__________________
Ed & Joie
2004 Vectra 40KD
Freightliner Chassis and Cummins ISC
emiddleb is online now   Reply With Quote
Old 09-22-2020, 05:36 AM   #9
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by deandec View Post
Did your attempts to start the generator occur via an inside remote switch or on the side of the generator?
It was tried from both inside and on the genny with the same results.
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Old 09-22-2020, 05:42 AM   #10
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by emiddleb View Post
Forgive a basic question - has the gen worked before, or is this your first experience with it? (Noticed you are fairly new to the forums... not sure of your experience level.) A diesel gen doesn't start immediately... it needs to prime and preheat before the gen starts. You should hold the "stop" side of the gen switch down for about 10 secs to prime the gen and start the preheat. If you are close you should hear a pump running in the gen. Then press the "start" side of the switch... it may take anywhere from 2-10 seconds or more to start, depending upon outside temps. Again, forgive if this is sounding basic, just have seen a lot of new owners posting with varying levels of experience with RV systems.
I run it monthly for an hour or more with the ac on when Iím home. Itís always started right up. I do preheat and prime. It also makes the clicking noise when Iím doing that which I thought was a bit strange.
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Old 09-22-2020, 09:51 AM   #11
Senior Member
 
deandec's Avatar


 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 4,732
For generator problems I usually refer to the back of the manual for the flowchart of trouble shooting. Very helpful and somewhat standard in many manuals.
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
Gillig Bus Chassis
deandec is offline   Reply With Quote
Old 09-23-2020, 05:52 AM   #12
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by deandec View Post
For generator problems I usually refer to the back of the manual for the flowchart of trouble shooting. Very helpful and somewhat standard in many manuals.
Iím assuming youíre talking abut the generator manual not the RV manual? Iím heading to Michigan this morning and will be there for a week or so. Iíll take a look at it when I get there. Thanks.
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Old 09-24-2020, 07:10 AM   #13
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Quote:
Originally Posted by twinboat View Post
Did you check the chassis battery connections. Some generators start off them.

As a side note, there is no solenoid hidden between the batteries and the generator. There will be a solenoid on the generator.
Thanks for the info. I called Newmar and it does start off the chassis batteries.
__________________
2014 Newmar Ventana 4369
2016 Jeep Grand Cherokee
Birdee the Black Lab
RudysDad is offline   Reply With Quote
Old 09-25-2020, 02:05 PM   #14
Member
 
Newmar Owners Club
Join Date: Nov 2018
Location: Bordentown,N.J.
Posts: 40
Just an update. I replaced a solenoid in the chassis battery compartment. The one in there had a lug that wouldnít tighten. Didnít change anything. Called Newmar again this morning and spoke to a different tech. He said he had dealt with this issue before. Told me to continue to hold the starter switch. May take more than a minute. Started in about 45 seconds. He said that should straighten it out.
Thanks for everyoneís input. Much appreciated.
RudysDad is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cummins Onan Generator Starting Issues - Help Needed! Trigon RV Systems & Appliances 2 08-26-2020 03:08 PM
Generac generator starting issues zzjea National RV Owner's Forum 19 07-08-2018 09:07 AM
Onan Generator Starting issues RVahoy2017 iRV2.com General Discussion 32 11-08-2017 03:47 PM
Starting or deep cycle and starting battery Crankshaft Class A Motorhome Discussions 7 08-18-2015 06:36 PM
Starting and Auxillary starting battery hook up NIFFIT MH-General Discussions & Problems 14 03-25-2010 04:06 PM


All times are GMT -6. The time now is 01:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.