Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-30-2022, 11:12 PM   #1
Junior Member
 
Fleetwood Owners Club
Join Date: Oct 2020
Location: Boca Raton, FL
Posts: 14
Grey tank reading 2/3 full even when empty

Here's a good one.
I have a 2017 Fleetwood discovery 38K. We're in it full-time. I keep the tanks clean and use frequently. My 75 gallon gray tank will not display empty when it's empty, I thought possibly the sensors had gunk on them. I ran it half full with clean water and 3/4 of a gallon of simple green. Drove it for 200 miles, emptied it and still the same issue. Then did the same thing with 2 cups of dish soap, same issue. When it is full it will read full but when it's empty it will not read below 2/3. the reading is same on the wall monitor and the Mira app. I also reset the power to the coach. I'm stumped on this one, anybody have any good ideas? I would greatly appreciate it.
Richdavidson is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-30-2022, 11:22 PM   #2
Senior Member
 
Bobby F's Avatar
 
Join Date: Aug 2019
Location: MN
Posts: 2,292
I fixed one recently like this. (I don't know your sensor system. If you don't have the four sensors in the side of the tank with the wires running to each one, this won't work.) I followed the four wire bundle away from the tanks and found a spot where the insulation had rubbed through on two wires, and they were in constant contact, thus registering a signal. Taped them up, worked great.
__________________
------------------------------------

1993 Rockwood 28' Class C - Ford E-350 7.5L
Bobby F is offline   Reply With Quote
Old 07-02-2022, 02:39 PM   #3
Senior Member
 
rvgrandma's Avatar
 
Join Date: Jan 2001
Location: Richland, wa
Posts: 349
Relax - sensors are rarely correct. You can drive yourself crazy trying to figure out how to keep them reading correctly. I have heard even the ones installed on the outside of the tank have the same problem. When it is full it will come up the lowest point which is usually the tub/shower. If you are concerned then just drain it every few days just time it so you have water in there when dumping your black.

I have owned many RVs over they years and not one of them had correct sensors except for the fresh water.
__________________
Full-Timers

2000 Sea View 34' Ford V10
rvgrandma is offline   Reply With Quote
Old 07-02-2022, 02:46 PM   #4
Community Administrator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 14,862
Check the location of the sensors on the tank. If the 1/3 sensor is located too close to the bottom of the tank it will always read 1/3, even when empty. It should be about 1/3 way up the side of the tank but I've seen some mounted too low. Example below, the red arrows show where the sensors should be and you can see the 1/3 and 2/3 pads are all too low on the tanks.
Attached Thumbnails
Click image for larger version

Name:	TankSensors.jpg
Views:	4
Size:	86.6 KB
ID:	369928  
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Reply

Tags
grey tank, tank



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Potable tank empty, reading 1/3 full Kiss4aFrog RV Systems & Appliances 3 10-22-2019 11:11 AM
Grey tank empty, monitor shows full Jestus Travel Trailer Discussion 16 04-18-2016 08:44 PM
Black and Grey Water tanks reading empty but they're not! jduffey5 Travel Trailer Discussion 21 09-30-2015 04:33 AM
Grey holdimg tank reading 1/4 when empty tom chelbana Newmar Owner's Forum 15 07-18-2012 08:15 AM
Black Tank Sensor shows Empty - even when full! DavidLyle Winnebago Industries Owner's Forum 8 02-17-2010 02:38 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.