Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-14-2013, 09:54 AM   #1
Senior Member
 
daveshan's Avatar
 
Alpine Owners Club
Join Date: Jul 2011
Location: Durango CO
Posts: 582
Heart Freedom 20 Combi inverter/charger charging issue.

OK, usually I can figure stuff out, either by testing or searching. This one's got me stumped.

Charger working fine when I put the coach away for the winter in late Nov. Went over to put a charge on the batteries and after I hooked them up and started generator noticed the charge indicator was below the 10A light.

Tested the voltage at the batteries and it was 13.4V (float numbers) no amps flowing, no noticeable spark at all (yes I'm aware of hydrogen when charging, no charge was happening) when I disconnected the terminals with charger on. Batteries without charger on read 12.4 and 12.1 (Chassis/House)

Checked the 300A fuse inline with the main + cable, it's fine, expected this since 13.4v was at batteries but checked anyway.

Checked the button breakers on the front of the unit, all OK

It's putting out power to the house lights, lights dim/brighten when I turn unit off/on.

Tripped/reset the main 120V breaker to "reset" the unit, no change.

Tried charger on a semi-charged group 31 battery I brought along just in case the batteries were too low to start the generator, no change. Still float voltage and no amps flowing.

Inverter function works as good as it ever did, I did have to set it to always on via the dip switches in the remote panel as the load sensor went wonky a while back.

Checked irv2 search, found very little on this older unit but found reference to two 250ma fuses in the later Xantrex version of this inverter/charger. Before I remove the unit does the older Heart version have these fuses?

I figure it may be end of lifespan on this unit as it's ~14 years old but thought I'd check here to see if I'm missing anything.

Thanks in advance for any ideas.
Dave
__________________
The above post is just my experience/opinion which is worth exactly what you paid for it.
[SIGPIC][/SIGPIC]
'05 Lance 845/'06 F-250 or '99 Alpine 36SDS Usually towing an '01 Wrangler locked on 35"s or moderate '98 Cherokee on 33"s (rear locker only)
daveshan is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-14-2013, 10:05 AM   #2
Senior Member
 
Join Date: Feb 2010
Posts: 4,610
If float voltage is what you measure then that is what it is.

Batteries are floating, or they are past bulk charge.

In the final stage of charging the charge current will be low, and spark not best indicator.

Measure with amp meter.
__________________
Tony & Lori
1989 Country Coach Savannah SE
TQ60 is offline   Reply With Quote
Old 02-14-2013, 10:29 AM   #3
Senior Member
 
daveshan's Avatar
 
Alpine Owners Club
Join Date: Jul 2011
Location: Durango CO
Posts: 582
It's not the final stage of charging. The house battery was at 12.1v, requiring builk charge rate.

The charger is not sensing battery state and entering bulk charging, which at the settings I have it (cold wet cell) should be 14.4v.
__________________
The above post is just my experience/opinion which is worth exactly what you paid for it.
[SIGPIC][/SIGPIC]
'05 Lance 845/'06 F-250 or '99 Alpine 36SDS Usually towing an '01 Wrangler locked on 35"s or moderate '98 Cherokee on 33"s (rear locker only)
daveshan is offline   Reply With Quote
Old 05-31-2021, 05:55 AM   #4
Member
 
Join Date: Dec 2005
Location: upstate S.C.
Posts: 35
Inverter issue

I am having the same issue with my Freedom 15, did you figure out what was the problem with yours, or replace it?
rebrobin is offline   Reply With Quote
Old 06-11-2021, 05:18 PM   #5
Member
 
American Coach Owners Club
Join Date: Apr 2018
Location: Statesboro, Georgia
Posts: 61
Dave,

I had a Source Manager 25 in my 2001 American Eagle that began reading my battery voltage 4 volts greater than it actually was. Result was low voltage that destroyed my batteries and created several low voltage issues before I discovered it. The panel read 14+ volts and charged up to that point and went to float mode. No parts available so no way to fix it. Inverter worked great but it was time to upgrade with a new one. I installed the Xantrex SW 3012 pure sine wave and have been very pleased.

There are a lot of posts on the change out in the following thread:

American Coach: Heart Source Manager 20 Replacement

Keith
kbmiddle is offline   Reply With Quote
Old 06-11-2021, 10:10 PM   #6
Senior Member
 
Isaac-1's Avatar
 
Join Date: Jun 2016
Location: SW Louisiana
Posts: 6,181
I don't know about the Combi 20, but the smaller Combi 10 has a pair of glass fuses inside the case (I think on the back of the circuit board) that are know to fail and cause odd charging behavior. Some revisions of the Combi chargers also have DIP switches on the bottom of the unit to control charging behavior, including reduced charging to limit amp draw.
__________________
2002 Safari Trek 2830 on P32 Chassis with 8.1L w/ 400 watts solar
2017 Jeep Cherokee Overland TOAD with Even Brake,
Demco Commander tow bar and Blue Ox base plate
Isaac-1 is online now   Reply With Quote
Old 06-20-2021, 01:06 PM   #7
Senior Member
 
deandec's Avatar
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 5,161
From Freedom 25 Combi Manual

My Combi is 26+ years old.

Little or no charger output:


1. Wiring Connections: Check both AC and DC wire connections (I assume at the inverter.)

2. AC Input Voltage: Low AC Voltage will produce low DC output. Expect low charging voltage from generators under 3500kw.

Hopefully you can find a low AC voltage situation in your hookups.

If you read the 13.4 dcv with the charger on, but lower dcv with it off, it seems it is trying to charge the batteries. So perhaps determining the AC voltage at the entrance to the Combi could be informative?

You might want to use another battery charger to see if it inputs a higher charging DC voltage?

FWIW, my inverter/ battery circuit has two 300A fuses. One in the battery compartment and one next to the Inverter. Yours of course may be different.
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
Gillig Bus Chassis
deandec is online now   Reply With Quote
Old 06-20-2021, 01:15 PM   #8
Senior Member
 
Join Date: Jul 2014
Posts: 28,018
Unplug the battery temperature sensor and see what happens.

The fail and cause under or over charging. Unplugged they default to 77F.
twinboat is online now   Reply With Quote
Old 06-20-2021, 05:06 PM   #9
Member
 
Join Date: Dec 2005
Location: upstate S.C.
Posts: 35
Resolution.

After too many strange things happening during this issue to relate here, I figured out the 300A fuse was bad, (no break visible in the element, but no current would pass). Replaced the fuse and the unit fired right up, working fine. Thanks all who posted, appreciate the info and help.
rebrobin is offline   Reply With Quote
Reply

Tags
charging



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.