Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-01-2007, 03:49 PM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 4
I have a 6 gal Atwood gas electric water heater that is really giveing me fits. The pilot will light, although the flame is very small it stays lite. When i turn the control to on the burner lights and burns with a normal flame for 1-2 minutes by my watch and then just goes out. Just like i turned it off. The control is new, i just purchased it today. Before new control the pilot would light but the burner would not. Thanks for any help that you can give. (sorry for the long post.)
redwings is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-01-2007, 03:49 PM   #2
Junior Member
 
Join Date: Jan 2007
Posts: 4
I have a 6 gal Atwood gas electric water heater that is really giveing me fits. The pilot will light, although the flame is very small it stays lite. When i turn the control to on the burner lights and burns with a normal flame for 1-2 minutes by my watch and then just goes out. Just like i turned it off. The control is new, i just purchased it today. Before new control the pilot would light but the burner would not. Thanks for any help that you can give. (sorry for the long post.)
redwings is offline   Reply With Quote
Old 11-01-2007, 06:05 PM   #3
Administrator in Memoriam
 
Hitchhiker's Avatar


 
Appalachian Campers
Join Date: Jan 2000
Location: Buladean, NC
Posts: 8,126
Maybe the gas pressure at the regulator is low? Does the gas range and the gas furnace light up and run normally? If they're OK and only the water heater is going out, check for a pinched or blocked gas line, maybe a rubber line under a slide room.

Good Luck.
__________________
'11 GMC Acadia SLT AWD
'11 GMC Sierra 1500 4x4 Extended Cab
Hitchhiker is offline   Reply With Quote
Old 11-01-2007, 07:08 PM   #4
Moderator Emeritus
 
RV Wizard's Avatar


 
Country Coach Owners Club
Appalachian Campers
Gulf Streamers Club
Join Date: Mar 2000
Location: Chattanooga, Tn.
Posts: 12,060
CLose gas vavles on tank(s) and reopen slowly. REtry operation of water heater. If it does not change then you need to check the working gas pressure of the gas regulator. THis will require a monometer. If you cannot adjust the regulator to work at 10.5 to 11" water column you should replace the regulator.
__________________
Mike, RVIA & RVSA Certified Master RV Technician
Amy, Dr. Assistant - Roxie & Mei Ling, four legs each
2000 Gulf Stream Scenic Cruiser 450 hp & 1330# torque
06 Saturn Vue, 06 Chevy Z71 4x4 & 2014 Corvette Z51 M7
RV Wizard is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water leaking from hot water heater marciegirl 5th Wheel Discussion 10 09-02-2008 03:15 PM
Suburban hot water heater not hot enough ?? rvtips Monaco Owner's Forum 4 08-11-2007 05:25 AM
Atwood Hot Water Heater Not Hot GG1 Winnebago Industries Owner's Forum 3 07-11-2005 05:25 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.