Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-15-2021, 06:03 AM   #1
Junior Member
 
Join Date: Dec 2020
Posts: 24
Hydroflame furnace not firing when cold

So for a few years I've. Had my furnace having issues initially I thought it was all because of a bad tstat with bad switches but finally after a nightmare replacing with up to date stat and control unit sadly it still doesn't want to fire up unless I put a portable heater in front of the intake. And run it hot for a few and reset the heater a few times till it fires but it absolutely refuses to ignite while cold. And well winter is a nasty season here I need my heater to be reliable any help or tips would be greatly appreciated
Tk0608 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-15-2021, 02:09 PM   #2
Senior Member


 
Winnebago Owners Club
Join Date: Sep 2015
Posts: 1,418
Quote:
Originally Posted by Tk0608 View Post
So for a few years I've. Had my furnace having issues initially I thought it was all because of a bad tstat with bad switches but finally after a nightmare replacing with up to date stat and control unit sadly it still doesn't want to fire up unless I put a portable heater in front of the intake. And run it hot for a few and reset the heater a few times till it fires but it absolutely refuses to ignite while cold. And well winter is a nasty season here I need my heater to be reliable any help or tips would be greatly appreciated
Sounds like a sail switch. When colder, the fan motor turns harder and since you say this has been going on a few years, you might be right at the threshold of where it blows hard enough when warm but not when cold.

Do you hear any noise. I had one that when on shore power would light and run fine, but on battery alone would not. Fan ran just fine. Took it apart and it had the plastic squirrel cage fan with one blade broken out. On shore power, full 13.6 volts ran fast enough to trip the sail switch. On battery, not quite.
__________________
2006 Winnebago Journey
39K
Cat C7
amosnandy is offline   Reply With Quote
Old 10-17-2021, 03:07 AM   #3
Junior Member
 
Join Date: Dec 2020
Posts: 24
Quote:
Originally Posted by amosnandy View Post
Sounds like a sail switch. When colder, the fan motor turns harder and since you say this has been going on a few years, you might be right at the threshold of where it blows hard enough when warm but not when cold.

Do you hear any noise. I had one that when on shore power would light and run fine, but on battery alone would not. Fan ran just fine. Took it apart and it had the plastic squirrel cage fan with one blade broken out. On shore power, full 13.6 volts ran fast enough to trip the sail switch. On battery, not quite.
Well at first I thought it was battery but whats funny is it actually seems like it fired better on battery than on shore like it'll fire on both if I put a heat gun or space heater in front of the intake but for a while it seems like it'd only ever fire on battery even with low juice lol I'm not the best at not completely frying my batteries lol I've been through 8 in a two year span sadly but the only consistent I have found is adding heat and even at that it can still be quiet the pain in the ass to get it to kick on especially once it gets Down in the 20s and below I believe the Sail is engaging I typically could hear what I've believe to be the dsi sparking atleast last year this year I'm struggling to hear much of anything but i gotta get this running the wife has health issues so it needs to be reliable I'm not very familiar with the system so I don't really know what to poke prod or what are common problems with these to even just throw parts at in an attempt lol not to mention they are old so parts availability isn't ideal to go that route any additional insight is much appreciated
Tk0608 is offline   Reply With Quote
Old 10-17-2021, 06:23 PM   #4
Senior Member
 
Join Date: Nov 2015
Posts: 18,884
Spark Gap too narrow or too wide

Contracts when cold then expands whenyou blow warm air into the intake

What is the actual model number?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is online now   Reply With Quote
Old 10-18-2021, 01:12 AM   #5
Junior Member
 
Join Date: Dec 2020
Posts: 24
Quote:
Originally Posted by Old-Biscuit View Post
Spark Gap too narrow or too wide

Contracts when cold then expands whenyou blow warm air into the intake

What is the actual model number?
It doesn't have its actual model number on there it's got a list of 3 options in its series and in pretty sure it's the 8325 DC its got metal fan blades not plastic the sail seems to be in good working order I managed to break my multimeter so I can't test the actual wires right now but the switch flips fairly smooth and the connections are clean and tight:cleaned everything I could today but didn't have a few tools to get to the igniter or burner but in fairly certain the sail switch is good
Tk0608 is offline   Reply With Quote
Reply

Tags
ace, furnace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbies (not) Firing up Furnace for the first time For The Dogs Newmar Owner's Forum 19 03-12-2017 09:16 PM
Suburban furnace not firing? BVThunder Winnebago Industries Owner's Forum 8 04-19-2016 06:09 AM
Atwood Furnace Not Firing Cougarkid RV Systems & Appliances 7 01-17-2013 10:16 AM
Furnace not firing cgau RV Systems & Appliances 6 04-28-2010 01:18 PM
Hydroflame Furnace Parts Tom Norman MH-General Discussions & Problems 5 01-20-2005 01:19 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.