Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2021, 10:25 AM   #1
Junior Member
 
Join Date: Jul 2018
Location: west sunbury, Pa
Posts: 2
Invisibrake quit working

My Invisibrake 8700 system has stopped working. The system is wired to separate bulbs and no diodes are used.

The symptoms are as follows:

Apply brakes in motorhome both toad brake light come on and the compressor turns on.
Pressure gauge reads about 60 psi

The brake pedal does not move and the slack in the cable is not taken up.

I don’t have a way of verifying that the pressure is actually being sent to the slave cylinder.

Any suggestions?
ceudaly is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-21-2021, 03:24 PM   #2
Member
 
Holiday Rambler Owners Club
Join Date: Sep 2019
Posts: 31
I have an Invisibrake and while I can't give you a specific answer I can suggest you refer to the owners manual and give Roadmaster a call and talk to them about your issue. They can probably help you.

Wish I could have been more help..

Rob
__________________
2016 Holiday Rambler Vacationer 33C towing 2008 Jeep Wrangler Rubicon 2dr 6spd manual.
flyinrob is offline   Reply With Quote
Reply

Tags
brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Invisibrake not working neoflyer Toads and Motorhome Related Towing 1 07-23-2017 09:12 AM
Invisibrake by Roadmaster JDT Toads and Motorhome Related Towing 23 02-26-2013 09:57 AM
InvisiBrake BobD Class A Motorhome Discussions 7 02-04-2012 02:23 PM
Roadmaster - Invisibrake ejm4 Toads and Motorhome Related Towing 3 12-27-2011 09:18 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.