Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-21-2021, 09:39 PM   #1
Junior Member
 
Join Date: Oct 2021
Posts: 2
Itasca Cabria 2014 HwH Leveling System

New to the forum.. Have a 2014 Itasca Cambria 30J. The HWH hydraulic leveling system has stopped operating.
1. Batteries at 14.2 volts.
2. Fluid is topped off
3. Power is going to master 4 post relay. Power from batteries to large post and two small posts. No power going to second large post which goes to second a intermittent relay and hydraulic motor.

When I push the auto level button blue light flashes but no action or clicking or any noise. Fuses checked. Any ideas?

Sent from Yahoo Mail on Android
Chief2004 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2021, 09:46 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,899
Welcome to iRV2.

Do you have any paperwork ( operators manual ) for your HWH system that identifies the system series number ? 325 ? 625 ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 10-22-2021, 09:47 AM   #3
Community Moderator
 
Petro's Avatar


 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Dec 2003
Location: Weyauwega, WI US
Posts: 7,580
Keith;



We are glad you joined us. There is a wealth of RV info available to you here just by asking. Browse the forums that interest you and don't be afraid to ask questions a our members like to help when they can.

In response to your question about your HWH leveling system, we have a member here who is an employee of HWH and he has been very helpful to many of us. His name is Paul Maddox. His user name here is azpete. His telephone number is 602-549-3638. His email is pfmaddox@att.net. I suggest you contact him and I am sure he can point you in the right direction.

Good luck with your problem and let us know how you solve your problem.

Don
__________________
Don & Bev Morgan Weyauwega WI, 05 Itasca Horizon 40KD, 400 HP Cummins, Adopted by a great couple, Toad 07 Saturn Vue AWD, Air Force One, TST 510 TPMS, Mayor of Weyauwega 2007 - 2013, Waupaca Co Board Supervisor 2010 - 2014
Petro is offline   Reply With Quote
Old 10-22-2021, 03:39 PM   #4
Junior Member
 
Join Date: Oct 2021
Posts: 2
Additional Information

I have a HWH 725 Auto Hydraulic leveling system that is not operating. I have checked
1. Emergency brake is set.
2. Batteries are at 14.2 volts engine running, 12.7 volts not running.
3. When control panel Auto Level button is pressed a blue light blinks but nothing happens. No sound from system at all. Push a second time and light stops and nothing happens.
3. No sound from safety and no light at dash.
4. 4 post master relay has 14.2 volts to large post and two small posts but no voltage going to intermittent relay nor from intermittent to hydraulic motor.
5. All known fuses are good.
6. Tried jumping power from master relay to intermittent relay with no success.
7. Tried jumping power to pump motor direct and had no action.
8. Starting to thing the pump motor is out.

Any ideas are grateful.

Chief 2004
Attached Thumbnails
Click image for larger version

Name:	20211005_202519[1].jpg
Views:	9
Size:	369.3 KB
ID:	346884   Click image for larger version

Name:	20210927_182119[1].jpg
Views:	8
Size:	213.1 KB
ID:	346885  

Chief2004 is offline   Reply With Quote
Old 10-23-2021, 07:06 PM   #5
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,899
Quote:
Originally Posted by Chief2004 View Post
7. Tried jumping power to pump motor direct and had no action.
8. Starting to thing the pump motor is out.

Any ideas are grateful.

Chief 2004
OK , relays don't function , power direct to the motor and it won't operate .

Bad motor , OR , bad ground . Did you supply power and ground to the motor ; or only power ?
If the relays share a ground system with the motor , the relays won't function without proper ground.
Try power and ground direct ; jumper cables ; to the motor or test the motor with an ohm meter , power post to frame .
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
leveling, hwh, itasca, leveling system



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual RECALL FOR ALL FLEETWOOD MOTORHOME ALL YEARS cbilodeau Fleetwood Owner's Forum 23 03-21-2016 10:29 AM
i have read all the Fridge issues and tried all now what skidworth RV Systems & Appliances 17 08-12-2011 02:28 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.