RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-28-2020, 05:06 PM   #1
Member
 
Join Date: May 2011
Posts: 35
Lippert 6 point leveling system

Need help with my new Lippert leveling system.
Its in a 2020 Grand Design Solitude. Last used the system July 30th when I parked it. Worked good. Since then I replaced the battery but today when I tried to work the system, pushing the power button on the system, "nothing". Would not power up.
The 5er was not plugged in and the battery was dead. So I plugged it in assuming that would work the leveling system, but no.
Everything worked, slide outs, lights etc after plugging it in but not the Leveling system or the front jacks that are part of the system. Checked all the circuit breakers and fuses, all good.
So is there a reset button somewhere, or is there an inline fuse somewhere or could it be just the dead battery and plugging it in does not work, the battery has to be fully charged.
Was planning on heading to Florida Thursday, but I hate to drag the front jacks all that way....
I think if nothing else, you can use a power drill and move the jacks, but that will be a real pain.
Thanks for any info....
WhiskeyRiver is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-28-2020, 07:37 PM   #2
Senior Member
 
Join Date: Apr 2020
Posts: 1,203
Blog Entries: 1
Find the 15 amp fuse for the display panel, remove it and check it for continuity. Then check, with a meter, for at least 12vdc on the input side of the fuse holder. If both are ok, then after you put the fuse back in, remove the connector from the back of the display for about 15 minutes to reset the system. Hope that helps.
__________________
2006 Damon Daybreak 3276 35'. 3 200 Amp Lithium batteries and 2000 watt Pure wave inverter/charger.
2013 Elantra on a Master Tow dolly.
HarryStone is offline   Reply With Quote
Old 11-28-2020, 07:52 PM   #3
Senior Member
 
Edd505's Avatar
 
Thor Owners Club
KZ RV Club
Join Date: Sep 2015
Location: Elephant Butte, NM
Posts: 740
Batteries need to be fully charged for the system to work, same as the other forum you posted this to. First question Lippert will ask. After you batteries are fully charged you may need to reset zero, Lippert speak for level.
__________________
2015 F350 FX4 SRW CC LB
2017 Durango Gold G353RKT
2006 F350 SRW CC LB sold
Edd505 is offline   Reply With Quote
Old 12-01-2020, 07:34 AM   #4
Member
 
Join Date: May 2011
Posts: 35
Ok so here is the answer if anyone is interested.
Called Lippert and said there is no power at all to the power pad.
He said there is a 10 amp inline fuse near the pump and if it is blown, there will be no power to the power pad. The pump is on the opposite side of the power pad. He said with a low battery you will still get power to the pad, but the jacks will not work..
I did try to find an inline fuse to start with and even after he told me there was one, I had a hard time finding it. But it is there behind and under the pump with what seems like miles of wiring and hydraulic lines in an area you can't see in or get your head in to see. Pulled the fuse & it was blown. It works fine now. The only thing I did was change the battery a couple months ago, so maybe the surge of a new battery blew the fuse, don't know.
If anyone is interested on how to manually operate the system, google "how do you manually raise a Lippert jack" and watch the u-tube video "Stranded on Mt.Washington" it explains it very well and does work as I did it....
And yes Edd505 I did post this same answer to the other forum I posted this to just incase you are concerned...................
WhiskeyRiver is offline   Reply With Quote
Reply

Tags
leveling, leveling system, lippert



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lippert 4 point leveling question chunker 5th Wheel Discussion 6 10-13-2018 11:14 AM
4 point or 6 point leveler system acbaker 5th Wheel Discussion 16 05-30-2016 06:39 PM
six point leveling system by lippert t.l.t. 5th Wheel Discussion 14 09-24-2013 03:54 PM
Lippert six point leveling system t.l.t. 5th Wheel Discussion 5 09-16-2013 09:00 PM
Lippert Auto Leveling Power Pac. Follow on to Lippert Leveling pump Smoking. IMDSailor MH-General Discussions & Problems 4 06-22-2012 06:50 AM


All times are GMT -6. The time now is 03:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.