Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-26-2013, 10:07 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 3
Need help with furnace!!

l have a 95 fleetwood prowler 34 foot. really good shape. had it about 3 weeks now, having problem with the furnace. when l turn it on the blower will run a few min. then cut off. l started it back up and when the blower came on l tapped on the gas valve and it came on. ran about 15 seconds and cut back off.
rayroof10 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-27-2013, 09:38 PM   #2
Moderator Emeritus
 
SarahW's Avatar


 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Oct 2011
Location: In a lawnchair
Posts: 11,980
Howdy and welcome to the forum. Sorry you're having a problem. I'll ask the obvious... do you have plenty of propane? Have you run the furnace successfully before today?
__________________
.2012 Fleetwood Bounder 33C
SarahW is offline   Reply With Quote
Old 05-27-2013, 09:45 PM   #3
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
Does it try to light, do you smell propane, does it actually light?
Like Sarah said, is there fire anywhere else?
jesilvas is offline   Reply With Quote
Old 05-28-2013, 03:25 PM   #4
Junior Member
 
Join Date: May 2013
Posts: 3
my tanks is full and my stove works fine, when l turn the themastat upthe blower comes on for a few minutes then cuts off. l reset it and turn it back up and when the blower came on l tap on the valve and the furnace came on for a few seconds then they both cut off.
rayroof10 is offline   Reply With Quote
Old 05-28-2013, 06:07 PM   #5
Senior Member
 
Join Date: Sep 2012
Posts: 4,232
Ok, do you hear it trying to light, do you smell propane at the outside vent?
jesilvas is offline   Reply With Quote
Old 05-28-2013, 06:18 PM   #6
Senior Member
 
clyon51's Avatar
 
Monaco Owners Club
Join Date: Mar 2012
Location: Angola State Prison - Murder
Posts: 4,230
Are you on shore power and charger is working? If no shore, are the batteries over 12.0v? If it isn't a proper voltage problem, check out these links to run down the problem.

http://www.google.com/search?hl=en&r...ce&v=133247963
__________________
John & Clare Lyon
2007 43.5' Monaco Dynasty Palace III (All Electric)
Towd: 2011 Chevy Equinox
clyon51 is offline   Reply With Quote
Old 05-30-2013, 04:04 PM   #7
Junior Member
 
Join Date: May 2013
Posts: 3
l don,t smell gas. it is a hydro flame furnace. when l cut it on the blower runs for about 2 minutes. then cuts off, and after a few minutes l cut it back on and when the blower starts l stated tapping on the valve and the furnace started up after a few the furnace cuts off. and the blower kept running and a few seconds later the furnace started back up. it kept doing this for a while and then everything cut off. l,m lost.
rayroof10 is offline   Reply With Quote
Old 05-30-2013, 04:37 PM   #8
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 24,958
Do you have an owner manual for your furnace ? You can download them from the companiy web site if not. Troubleshooting guide in the manual.
Has the furnace ever worked since you bought the RV ?
The furnace should , run the fan on start up , sail switch to check fan operation. If the sail switch fails , or the fan is running slowly due to low battery power , the flame will not ignight.
Furnace also has internal sensors to shut it down if the flame goes out due to lack of propane.
So the first things to check are full battery voltage to the furnace , voltmeter , 12.3 volts or above. Propane available ? Does the cook top operate ? light all the burners at once to check that you have good volume.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 05-30-2013, 05:14 PM   #9
Senior Member
 
Rbhein's Avatar
 
Join Date: Feb 2012
Posts: 273
Do easy stuff first. Remove and clean each terminal, one at a time. Many rv problem are caused by poor electrical contacts.
Rbhein is offline   Reply With Quote
Old 05-30-2013, 05:26 PM   #10
Senior Member
 
Join Date: May 2004
Location: Auburn, CA, Havasu, AZ & Mulege, BCS
Posts: 5,356
The solenoid valve for the gas could be bad (sounds from the description that it won't work till you tap on the valve?). I like to test those off the unit w/good battery voltage, & the blow-thru test. If its hinkey, it won't open or it will chatter shut. Hard to tell that in place. They do go bad, had to replace on on a water heater. All ese worked but it wouldn't deliver propane.

The trick of checking all burners on high for the stove is appropriate. One may light but if there isn't enough volume for the furnace (a stove burner is ~8k btu, the furnace may be up to 42k btu so it takes way higher volume), that could be the problem. Maybe the tank got filled but the propane guy only cracked the valve open?
__________________
Baja-tested '08 2-slide 36'
Alpine: The Ultimate DIY'er Project
EngineerMike is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Furnace Problem '08 Excel 33TKE Ltd. Ken & Patti C. Excel Owner's Forum 10 02-25-2012 05:28 PM
Furnace working intermittently SOLVED! Sharps OTP RV Systems & Appliances 2 11-03-2011 11:35 PM
Another LP Furnace problem... Moder2 Winnebago Industries Owner's Forum 26 12-19-2007 06:19 AM
Unreliable Furnace Bob&Pat Winnebago Industries Owner's Forum 11 10-15-2006 01:20 PM
Suburban furnace won't light in cold weather BryannasTreasureBox MH-General Discussions & Problems 9 01-22-2005 08:12 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.