Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-22-2021, 07:43 PM   #1
Junior Member
 
Join Date: Oct 2020
Posts: 18
New Fridge cooling unit, A/C fine no gas

long thread but I wanted to be thorough in my post. Plugged into shore power

New Fridge cooling unit works perfect, except the flame failure light comes on within 10 seconds. The upper control board lights will not illuminate when any button is depressed. IE: AES, gas only, A/C only. Went through the trouble guide, the Brown wire on the Ignitor is reading only 6 volts, VS the ignition lock at 12.62 volts. read out the high voltage cable and electrode continuity check was good.



Also i checked for voltage as per wiring at the pins while fridge was on and pins connected to circut board. on the 6 pin connector brown wire and red wire only had 6 volts. But the yellow wire had 13. volts ( this wire goes from the igntion lock to the fuse to the yellow wire.



On the 4 pin wire the red wire also has 6 volts as well which goes to the lamp light on the inside of the fridge. which according to the wiring diagram the red and brown wire are tied to the gas mode lamp system.



i have ordered an ignitor, this whole system worked as advertised when I installed the new cooling unit, the ignitor would "click" for 3 minutes with no flame (out of propane, my bad) when I refilled the propane the flame lit then it went out, this is when all the problems occured.
Should i stop troubleshooting until the new ignitor shows up?
Is it ok to just let it cool on A/C mode until i can continue troubleshooting gas mode?
Also does anyone know of a vendor that still has these parts available or cross reference chart for newer parts? ebay has been some help but not much
RVforever21 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-22-2021, 08:50 PM   #2
Senior Member
 
Join Date: Nov 2015
Posts: 16,974
You went thru a long posting but didn't mention Brand /Model

12VDC+ to fridge circuit board but only 6 volts to components

What is the Voltage on Both sides of the DC Fuse?

Cooling Unit may be New but sounds like Upper display and lower circuit board are old/original ones

You may need new lower circuit board

Brand/Model???
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 04-22-2021, 09:48 PM   #3
Senior Member
 
Ray,IN's Avatar
 
Join Date: Aug 2001
Location: North America somewhere
Posts: 23,246
After you ran out of LP did you light a stovetop burner or water heater to regain LP pressure in the lines? Have you removed and cleaned the LP burner and combustion chamber???
__________________
2000 Winnebago Ultimate Freedom USQ40JD, ISC 8.3 Cummins 350, Spartan MM Chassis. USA IN 1SG 11B5MX,Infantry retired;Good Sam Life member,FMCA." My fellow Americans, ask not what your country can do for you, ask what you can do for your country. John F. Kennedy
Ray,IN is offline   Reply With Quote
Old 04-23-2021, 12:39 AM   #4
Junior Member
 
Join Date: Oct 2020
Posts: 18
Quote:
Originally Posted by Old-Biscuit View Post
You went thru a long posting but didn't mention Brand /Model

12VDC+ to fridge circuit board but only 6 volts to components

What is the Voltage on Both sides of the DC Fuse?

Cooling Unit may be New but sounds like Upper display and lower circuit board are old/original ones

You may need new lower circuit board

Brand/Model???
My bad, its a 1999 Lance slide in camper, the fridge is a Royal design by dometic RM3604.
unsure of voltage to both sides of fuse, i know from the meter its 12.36 coming out of the 3 amp fuse
RVforever21 is offline   Reply With Quote
Old 04-23-2021, 12:42 AM   #5
Junior Member
 
Join Date: Oct 2020
Posts: 18
Quote:
Originally Posted by Ray,IN View Post
After you ran out of LP did you light a stovetop burner or water heater to regain LP pressure in the lines? Have you removed and cleaned the LP burner and combustion chamber???
When i got more propane I bled the lines out making sure the furnace lit along with the stove. i have not removed the burner yet, I was following the trouble guide for flame burner light on within 10 seconds. I am not sure which way to lean as far as circuit boards being bad. I am also contacting dometic as well
RVforever21 is offline   Reply With Quote
Old 04-23-2021, 01:55 PM   #6
Senior Member
 
Join Date: Nov 2015
Posts: 16,974
Do you get a Flame?

YES......then thermocouple is NOT generating the milliamps to hold safety valve open

NO...then is ignitor sparking, is gas valve opening allowing gas flow?

As for the 6 volts issue

Need to test the circuit board

You state you have checked this pin, that pin etc so it sounds like you have the service manual
Pg 9 Section 4.10 Step 4
http://techsupport.pdxrvwholesale.co...ice-Manual.pdf
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 04-27-2021, 12:19 AM   #7
Junior Member
 
Join Date: Oct 2020
Posts: 18
Quote:
Originally Posted by Old-Biscuit View Post
Do you get a Flame?

YES......then thermocouple is NOT generating the milliamps to hold safety valve open

NO...then is ignitor sparking, is gas valve opening allowing gas flow?

As for the 6 volts issue

Need to test the circuit board

You state you have checked this pin, that pin etc so it sounds like you have the service manual
Pg 9 Section 4.10 Step 4
http://techsupport.pdxrvwholesale.co...ice-Manual.pdf
Tried getting ahold of Dometic for more guidance but have not received a response. So my ignitor will be here tomorrow but i am pretty sure i need a circuit board since i am only outputting in several areas 6 volts from the pins that the wire diagram clearly states 12 volts.
RVforever21 is offline   Reply With Quote
Old 04-27-2021, 10:46 AM   #8
Senior Member
 
litzdog911's Avatar
 
Join Date: Aug 2019
Location: Mill Creek, WA
Posts: 415
Check out the RV refrigerator troubleshooting and repair videos here ....
https://www.youtube.com/playlist?lis...Pb02ayS5H1sKbB
__________________
2020 Black Stone 280KVS Titanium
2020 RAM 2500 Diesel 4x4
litzdog911 is offline   Reply With Quote
Old 04-29-2021, 01:46 AM   #9
Junior Member
 
Join Date: Oct 2020
Posts: 18
UPDATE: Installed new ignitor, turned fridge on and instant spark. But no gas, used a jumper wire and jumped gas valve and instant light off. the only problem was that I had to move the thermocouple to where the copper line touched the shielding and then the gas valve would work. I metered to pins to the valve and there was 0 volts going to gas valve from the circuit board. According to the manual the board is bad, also there was still no lights on the upper fridge board as well after the install.
RVforever21 is offline   Reply With Quote
Old 04-29-2021, 12:13 PM   #10
Senior Member
 
litzdog911's Avatar
 
Join Date: Aug 2019
Location: Mill Creek, WA
Posts: 415
Quote:
Originally Posted by RVforever21 View Post
UPDATE: Installed new ignitor, turned fridge on and instant spark. But no gas, used a jumper wire and jumped gas valve and instant light off. the only problem was that I had to move the thermocouple to where the copper line touched the shielding and then the gas valve would work. I metered to pins to the valve and there was 0 volts going to gas valve from the circuit board. According to the manual the board is bad, also there was still no lights on the upper fridge board as well after the install.
Sounds like it's time to replace the control board.
__________________
2020 Black Stone 280KVS Titanium
2020 RAM 2500 Diesel 4x4
litzdog911 is offline   Reply With Quote
Old 04-30-2021, 06:02 PM   #11
Senior Member
 
Join Date: Nov 2015
Posts: 16,974
Get a Dinosaur Electronics Circuit Board

Dinosaur Micro P-246 Plus is direct replacement for your RM3604
Better quality PC

Goggle for lowest price
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 05-03-2021, 12:17 AM   #12
Junior Member
 
Join Date: Oct 2020
Posts: 18
UGGHH bang head emoji, so the new control board came in, installed the board and nothing happened. No colts to any of the systems. IE; gas valve, ignitor, heating elements. In fear of the board, I didn't touch it with the ohm meter, I did however contact Dinosaur electronics and asked for help from them, I am hoping I can send the upper and actual control board to them to help better assist with me with my issue, for right now, I am just going to use the jumper wire until I can solve this issue.
RVforever21 is offline   Reply With Quote
Old 05-03-2021, 01:53 PM   #13
Senior Member
 
Join Date: Nov 2015
Posts: 16,974
Did you verify you have DC at the terminal block?
Did you verify you have DC to the Relay with ignition switch ON?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 05-04-2021, 01:03 AM   #14
Junior Member
 
Join Date: Oct 2020
Posts: 18
Quote:
Originally Posted by Old-Biscuit View Post
Did you verify you have DC at the terminal block?
Did you verify you have DC to the Relay with ignition switch ON?
yep took ohm meter out to ignition block, 12.36 volts to ignition block. 12 volts from fuse to the circuit board. Contacted dinosaur electronics waiting to hear back. have jumper wire in for now, ran on propane for 4 hours no problem with old circuit board. it will work for now.
RVforever21 is offline   Reply With Quote
Reply

Tags
cooling, fridge, gas



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fridge cooling unit swap to compressor unit srogers RV Systems & Appliances 11 07-16-2020 07:45 AM
Norcold fridge won't run on 120v, runs fine on gas. Peter27C RV Systems & Appliances 8 08-04-2016 10:52 AM
New cooling unit vs residential fridge Ggrvusa Class A Motorhome Discussions 43 12-13-2015 01:49 PM
Replace cooling unit with Amish unit Keith727 Newmar Owner's Forum 6 05-14-2013 08:45 PM
Amish Fridge Cooling Unit Capabilities golden RV Systems & Appliances 3 06-23-2012 04:08 PM


All times are GMT -6. The time now is 04:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.