RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-24-2020, 02:28 PM   #1
Junior Member
 
Join Date: Jun 2016
Posts: 16
NorCold 1095 issues

Hi everyone, I'll keep this as short as I can:

My Norcold 1095 quit working out of the blue. The display nights no longer work on the front of the fridge. Fridge isn't cooling but has power to all the places it should and both the 5amp and 3amp (glass tube) fuses are good.

I can't get the fridge to respond to anything. Power coming into the board and power on both sides of the 5amp fuse are the same, there's no voltage drop. There is an intermittent clicking coming from the power circuit board about every 45 seconds like a small relay is turning off and on. I purchased and swapped out the Power Circuit board with a new one, only to have it do the exact same thing. I pulled the Display off the front of the fridge and check the voltage there and it's the same as on the power board at the fuse.

It's not a 1200 so it doesn't have the recall, I'm super stumped at this point, surely someone else has seen this issue? Thanks in advance all.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-24-2020, 02:49 PM   #2
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 3,337
What IS the voltage at the control board? If it's too low, it will act like this.

Another thing that will cause it is poor connections to power, if the connectors aren't nice and tight, it could be trying to turn on the electric element which is a large load and if the voltage drops, the relay drops out.

Also, are you on shore power? If yes, does the refer outlet have 120 volts on it?

So make sure ALL the connections to the control board are tight, not wobbly at all, and that the voltages are correct, not 60 volts AC or 9 volts DC.

One thing that happens is that often the refer's AC supply is on the bathrooms GFI, so check that.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 11-24-2020, 02:53 PM   #3
Junior Member
 
Join Date: Jun 2016
Posts: 16
Jim, thanks so much!

I'll tighten the all the connections real quick and test again. I'll also check the bathroom GFI. I've tried plugged in (Shore power) and battery only.

When not on Shore I have 12.6 at the 5amp fuse:
When on Shore I have 14.3 at the fuse:

Both of those stay consistent everywhere I touch:

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 11-24-2020, 03:11 PM   #4
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 3,337
Stay on shore power during testing. Find those two wires that go into the chimney and follow them back to the control board and measure to see if there is 120 volts AC there. If there is, and the chimney is NOT getting hot, that points to a bad element. I don't recall if any of the Norcolds would auto switch to gas if the element is open circuit but supplied with power (trivial design, they could if they wanted) so the 'clicking' you are describing hints that it's the gas circuit AND the electric element that are both on the fritz so try to analyse them separately.

But there must be 12 volt or more AND A GOOD GROUND going to the control board in either case.

Maybe have a friend or neighbor turn on the refer for you and try to localize that clicking. Is it trying to spark maybe?

You have a new control board so doubtful the relay is bad.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 11-24-2020, 03:34 PM   #5
Junior Member
 
Join Date: Jun 2016
Posts: 16
Made sure all the connections were tight, same issue.

The clicking isn't the ignitor, it makes a different noise, the noise I'm hearing is coming from the circuit power board. It will just keep doing it if I don't shut the power off.

Would a bad element cause the front panel on the fridge not to light up? It's dark, with no readouts on it. But if I hit the power button, a clicking on the board occurs, but nothing happens..... so odd.
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 11-24-2020, 04:51 PM   #6
Junior Member
 
Join Date: Jun 2016
Posts: 16
Update:
I unplugged the coach from shore, and turned all power off. Let it sit 5 min and turned everything back on. I now have a lit fridge display but it's flashing "no" even tho everything appears to be working. If I put it on LP, it lights and runs, if I put it on AC it appears to run. Any idea what's happening?
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 11-24-2020, 11:28 PM   #7
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 3,337
No idea. One of those situations where I'd have to look at it.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is offline   Reply With Quote
Old 11-24-2020, 11:46 PM   #8
Senior Member
 
Join Date: Nov 2015
Posts: 14,594
Service Manual with specs, troubleshooting, power requirements, wiring etc
https://norcold.com/wp-content/uploa...52C_091407.pdf
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 11-25-2020, 08:55 AM   #9
Junior Member
 
Join Date: Jun 2016
Posts: 16
Thanks Guys,

At this point I think the only other part I can replace is the display board. I'll order one and see if it corrects what it's doing. I'll make sure to post back the results next week when I have it.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 11-25-2020, 09:22 AM   #10
Senior Member
 
ArtJoyce's Avatar
 
Monaco Owners Club
Freightliner Owners Club
Holiday Rambler Owners Club
Join Date: Sep 2019
Location: Ohio
Posts: 299
Am I to understand it. It works under LP, but does no under 120V AC?

Is so have you tested the he as heating element?
__________________
Art & Joyce
Thornville, OH
Holiday Rambler Endevor
ArtJoyce is offline   Reply With Quote
Old 11-25-2020, 10:18 AM   #11
Junior Member
 
Join Date: Jun 2016
Posts: 16
It works on both now that the display is lit. It is flashing tho so it's getting replaced.

Prior to the display showing signs of life, it wouldn't do anything but make a clicking noise on the power board. Fans wouldn't run LP wouldn't try to light, nothing.
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 11-25-2020, 12:10 PM   #12
Senior Member
 
Join Date: Nov 2015
Posts: 14,594
Have you accessed the 'Diagnostic Mode' and checked for 'stored faults'
Screen 4/5?

AC/DC inputs/outputs...Screen 7/8/9/0?

What is flashing on the Display?
__________________
Is it time for YOUR Medication or Mine?
Dodge 3500 w/Tractor Motor & NUWA 5vr
US NAVY---USS Decatur DDG-31
Old-Biscuit is offline   Reply With Quote
Old 12-01-2020, 08:55 AM   #13
Junior Member
 
Join Date: Jun 2016
Posts: 16
As mentioned "no" lower case is flashing. nothing after it, just "no".

The diag screen modes aren't working which is why I think the Optic board is bad. The board that was sent yesterday wasn't the correct one, I should have the right one on Saturday. I'll post back once it's corrected.

--Rich
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Old 01-17-2021, 09:26 PM   #14
Junior Member
 
Join Date: Jun 2016
Posts: 16
Long time getting back. I've tried 3 power board kits from norcold off Amazon. Crazy thing, they all behaved different (power boards with optic boards). After being fet up, I decided to try just the power board from another vendor and poof, the fridge works like a champ. I read other comments about the boards on amazon being junk, hard to believe, glad I didn't replace the whole unit like I was going too.
__________________
2006 Newmar Ventana
Nitro71455 is offline   Reply With Quote
Reply

Tags
norcold



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Красавч& :: 2014 Couchmen Prism gyamin iRV2 Owners Registry 0 09-01-2019 10:08 AM
"NORCOLD & DOMETIC RECALLS" & Service Manuals Norcold & Dometic "007" RV Systems & Appliances 89 07-18-2019 05:41 PM
Norcold N 1095 Defrost cycle TexasTwoStep Excel Owner's Forum 5 07-16-2015 07:01 AM
norcold 1095 no cool robertleo RV Systems & Appliances 1 01-11-2015 12:45 AM
Norcold 1095 performance on LP jdpm RV Systems & Appliances 5 08-17-2013 04:12 AM


All times are GMT -6. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.