Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > RV SYSTEMS AND TECHNOLOGIES FORUMS > RV Systems & Appliances
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-04-2022, 05:25 PM   #29
Senior Member
 
Join Date: Jul 2018
Posts: 4,303
Quote:
Originally Posted by Dwfowler1175 View Post
It is not like mine. I have pics of it but Im not sure how to attach them.
This link may help with your pictures...

https://www.irv2.com/forums/f62/foru...ics-49134.html
__________________
2005 Four Winds Majestic 23A
To the world you may be one person; but to one person you may be the world. - Dr Suess
Solo_RV_Guy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-04-2022, 06:04 PM   #30
Member
 
Join Date: Sep 2022
Location: Palm Bay Fl
Posts: 39
Pics of my unit
Attached Thumbnails
Click image for larger version

Name:	5B9CDA0F-1D41-4FB8-B7AC-0A836D47ECCD.jpg
Views:	9
Size:	372.1 KB
ID:	375425   Click image for larger version

Name:	6E552A68-B026-48C2-8AF6-75698E67EFCF.jpg
Views:	12
Size:	413.3 KB
ID:	375426  

Click image for larger version

Name:	FC07C6F1-2E2A-4529-BE00-96F720652F18.jpg
Views:	9
Size:	339.9 KB
ID:	375427  
Dwfowler1175 is offline   Reply With Quote
Old 09-04-2022, 07:27 PM   #31
Senior Member
 
Fleetwood Owners Club
Ford Super Duty Owner
Join Date: Aug 2019
Location: Salem, OR
Posts: 771
Quote:
Originally Posted by Dwfowler1175 View Post
Pics of my unit
In your bottom picture. Just to the upper left of the transformer, there is a yellow tubular piece on a wire. Slightly behind the run of wires at a diagonal. That appears to me to be a Buss inline fuse holder. They just pull apart. Might be worth checking it's fuse.
code2e is offline   Reply With Quote
Old 09-04-2022, 07:30 PM   #32
Member
 
Join Date: Sep 2022
Location: Palm Bay Fl
Posts: 39
Quote:
Originally Posted by code2e View Post
In your bottom picture. Just to the upper left of the transformer, there is a yellow tubular piece on a wire. Slightly behind the run of wires at a diagonal. That appears to me to be a Buss inline fuse holder. They just pull apart. Might be worth checking it's fuse.
Yes. It is. Just pulled apart it’s still good but I did find a 8amp glass fuse down deeper and it’s bad. Has 120v to the one side and it’s blown. I’ll advise as soon as I get it replaced.
Dwfowler1175 is offline   Reply With Quote
Old 09-04-2022, 08:52 PM   #33
Member
 
Join Date: Sep 2022
Location: Palm Bay Fl
Posts: 39
Quote:
Originally Posted by Dwfowler1175 View Post
Yes. It is. Just pulled apart it’s still good but I did find a 8amp glass fuse down deeper and it’s bad. Has 120v to the one side and it’s blown. I’ll advise as soon as I get it replaced.
So after replacing the fuse, powered everything back up and the remote indicator was flashing on the battery light. Turn off and on again the flash went away but the ac input light still doesn’t come on. Although I do have ac in receptacles the inv/chrg light is the only lit beside the current dc volts (12). None of the dc amps are lit.
Dwfowler1175 is offline   Reply With Quote
Reply

Tags
ignition



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!!Shut off and now nothing, no lights nada nothing RVBeachbum MH-General Discussions & Problems 4 02-21-2020 07:45 PM
Heater does nothing, water heater does nothing... glennj3cub RV Systems & Appliances 20 01-04-2020 10:50 PM
Nothing For Nothing lllkrob Cummins Engines 3 01-03-2020 02:48 PM
HWH system- all LED's lit and nothing works. Help 68droptop Alpine Coach Owner's Forum 11 09-06-2011 03:12 PM
Removed coach batteries, nothing works?? smlranger Winnebago Industries Owner's Forum 12 07-24-2006 04:16 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.